Page: Previous  1, 2, 3 ... , 24, 25, 26  Next

dark-D
Status: Contributor
Joined: 27 May 2010
Posts: 68
Location: shadows
Reply Quote
is there a way to revert to the old method of diplaying inxi in a small terminal window?
the new one, displays the information with a lot of wasted space. what would fit in a
single terminal, now takes the entire screen and the compacted (-b) is the size of the full.
i use the same tty 90x30 for several years now. this is the old inxi -F from a previous post:
:: Code ::
System:    Host: hell Kernel: 4.13.0-10.1-liquorix-686 i686 bits: 32
           Desktop: Fluxbox 1.3.7 Distro: blackbox
Machine:   Device: laptop System: LENOVO product: 89329WU v: ThinkPad R61/R61i serial: N/A
           Mobo: LENOVO model: 89329WU serial: N/A
           BIOS: LENOVO v: 7OETC3WW (2.23 ) date: 05/12/2009
Battery    BAT0: charge: 17.9 Wh 99.1% condition: 18.1/51.8 Wh (35%)
CPU:       Single core Intel Core2 Duo T5250 (-UP-) cache: 2048 KB
           speed/max: 1495/1500 MHz
Graphics:  Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
           Display Server: X.org 1.19.5 driver: intel tty size: 90x30
Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.13.0-10.1-liquorix-686
Network:   Card-1: Intel PRO/Wireless 3945ABG [Golan] Network Connection
           driver: iwl3945
           IF: wlan0 state: down mac: 00:1b:77:6f:fd:47
           Card-2: Broadcom Limited NetLink BCM5787M Gigabit Ethernet PCIE driver: tg3
           IF: ens4 state: up speed: 100 Mbps duplex: full mac: c8:3a:35:fd:29:58
Drives:    HDD Total Size: 120.0GB (55.8% used)
           ID-1: /dev/sda model: HITACHI_HTS54161 size: 120.0GB
Partition: ID-1: / size: 2.0G used: 1.8G (92%) fs: ext4 dev: /dev/sda1
Sensors:   System Temperatures: cpu: 70.0C mobo: 44.0C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 96 Uptime: 37 min Memory: 369.7/992.3MB Init: systemd runlevel: 5
           Client: Shell (bash) inxi: 2.3.51

this is the new inxi -F:
:: Code ::
System:
  Host: hell Kernel: 4.13.0-10.1-liquorix-686 i686 bits: 32 Desktop: Fluxbox 1.3.7
  Distro: blackbox
Machine:
  Type: Laptop System: LENOVO product: 89329WU v: ThinkPad R61/R61i serial: N/A
  Mobo: LENOVO model: 89329WU serial: N/A BIOS: LENOVO v: 7OETC3WW (2.23 )
  date: 05/12/2009
Battery:
  BAT-0: charge: 16.6 Wh condition: 16.8/51.8 Wh (32%)
CPU:
  Topology: Dual Core model: Intel Core2 Duo T5250 type: MCP L2 cache: 2048 KB
  Speed: 1496 MHz min/max: 1000/1500 MHz Core speeds: 1: 1496 2: 1496
Graphics:
  Card-1: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
  driver: i915 v: kernel
  Display Server: X.org 1.19.6 driver: intel tty: 90x30
  Message: Advanced graphics data unavailable in console. Try -G --display
Audio:
  Card-1: Intel 82801H (ICH8 Family) HD Audio Controller driver: snd_hda_intel
  Sound Server: ALSA v: k4.13.0-10.1-liquorix-686
Network:
  Card-1: Intel PRO/Wireless 3945ABG [Golan] Network Connection driver: iwl3945
  IF: wlan0 state: down mac: 00:1b:77:6f:fd:47
  Card-2: Broadcom Limited NetLink BCM5787M Gigabit Ethernet PCI Express driver: tg3
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: c8:3a:35:fd:29:58
  IF-ID-1: ppp0 state: unknown speed: N/A duplex: N/A mac: N/A
Drives:
  HDD Total Size: 111.79 GiB used: 14.45 GiB (12.9%)
  ID-1: /dev/sda model: HITACHI_HTS54161 size: 111.79 GiB
Partition:
  ID-1: / size: 2.92 GiB used: 1.87 GiB (64.2%) fs: ext4 dev: /dev/sda1
Sensors:
  System Temperatures: cpu: 78.0 C mobo: 47.0 C
  Fan Speeds (in RPM): cpu: 0
Info:
  Processes: 94 Uptime: 9:04 Memory: 992.3 MiB used: 487.3 MiB (49.1%) Init: systemd
  runlevel: 5 Shell: bash inxi: 2.9.02

inxi -Fxxx is just ridiculous, i can't fit it on the screen, even in full screen it takes 2/3 of the 1280x900 screen.
if my point doesn't come across, i could try to post a screenshot, but i have a really old one for the old inxi.
this change makes inxi hard to read and unusable, i hope there is a solution. thank you for the hard work.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3882
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Yes, you can set the config variable:

INDENT_MIN=

whatever column count you wan the auto wrapper to kick in at. The bigger the number, the less l ikely it will kick in. 80 or less and it will never kick in.

Default value is: 90 cols

You can see it kick in if you just make your terminal wider than 90 cols

I personally far prefer seeing more data per line in a narrow terminal, that seems to be the overall consensus so far. I never liked the 80 col wasting 9 columns on margin which is why I changed that in the new one, but of course, users have the option to make it what they want.

The point here is to get more data per line, so it is less likely each line will wrap with basic data output options.

This works pretty well by the way. Also, its' hard to compare new inxi output with old, because it's slightly differently structured, except for -b, which is similar.

But you can set the configs if you want a different trigger point ifor the auto wrap.

All you literally have to do is set your terminal width to 91 cols, and you'll see right away what I'm talking about, since 90 is the trip point.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3882
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
By the way, I hope you appreciate the pure coincidence that was involved in your preferred col width and row height happening to fit inxi.

Others, who use the default 80 col width and low height will be quite pleased that suddenly more information per line will appear. Since many terminals default to tiny sizes like that (why, I have no idea, it hasn't been literally since the 1980s that display terminals were 80 cols wide, yet that arcane standard remains).

I was curious, and checked some of my terminals

125x40 ( I rarely use widths less than 125 because, well, I use terminals for my living, and the more data I see in a row the better, up to about 125 cols, after that it's too much.

150x50

112x50

131x50

as you can see, I lean towards, without even thinking about it, about a 50 row high terminal display, reasonable width, because that gives me a good amount of data per window/tab, very productive. So there's really endless possible preferred width/heights, but the basic default remains stubbornly set in the '80s, 80 cols, and that's why I made the wrapper, because 80 cols just doesn't cut it if you slice off 11 of those for a margin.
Back to top
HeinzDo61
Status: New User - Welcome
Joined: 24 Mar 2018
Posts: 2
Location: Dortmund/Germany
Reply Quote
When I run inxi -s I get this output:
inxi -s
here
Sensors: System Temperatures: cpu: 24.5 C mobo: 25.0 C
            Fan Speeds (RPM): fan-1: 746 fan-2: 1229 fan-3: 0 fan-4: 783 fan-5: 0

What does this "here" mean?

https://imgur.com/a/WaZdJ
Back to top
dark-D
Status: Contributor
Joined: 27 May 2010
Posts: 68
Location: shadows
Reply Quote
:: techAdmin wrote ::
All you literally have to do is set your terminal width to 91 cols, and you'll see right away what I'm talking about, since 90 is the trip point.

for me, it takes effect on 92X30, it would be nice to be at 90, including it, so my OCD isn't triggered. ;-P

:: techAdmin wrote ::
By the way, I hope you appreciate the pure coincidence that was involved in your preferred col width and row height happening to fit inxi.

it's quite funny. this is the terminal window size that feels right on my current resolution.
i'm still waiting for the market to settle, so i can upgrade my setup to a newer/better one.

:: techAdmin wrote ::
Others, who use the default 80 col width and low height will be quite pleased that suddenly more information per line will appear. Since many terminals default to tiny sizes like that (why, I have no idea, it hasn't been literally since the 1980s that display terminals were 80 cols wide, yet that arcane standard remains).

this is where i got very confused, it seams to me that bellow 90 there is a lot of wasted space.
especially on the name of the category (System, Machine, etc.) , 9 lines wasted on a word per line.
maybe word wrapping will benefit smaller terminals as well, i'll leave it at that because my brain hurts.

as a side note, i have noticed that the -b (basic) flag got pretty detailed, maybe it should go back to basic. (pun intended)

i am happy that i solved my issue and now inxi diplays the info as it should.
thanks again for the help and keep on the great work, have a nice weekend.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3882
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
dark-D, thanks for your feedback.

I'm checking between the help of binxi and pinxi (binxi is now old bash inxi, and pinxi is the development perl branch of inxi so it's clear which I'm talking about

Basically the new features are this:

-G - show driver per card, and version. Because one of the main reasons forums etc use inxi is for graphics driver issues, I think it's correct for inxi to show per card driver at all verbosity levels.

-C -b uses the new split speed: .... min/max: .... which it shares with -D and -I

-D uses the split size/used, but I think it's correct to use the same format on all the liines

I tested both with -y 80 width, and yes, both fit into their container, but if you add -x option the bugs in binxi wrapping will grow more and more evident

I think it comes down to how you view the stuff, if you view height as a key, which actually never crossed my mind, but it obviously a valid way to see it, then these changes would matter. If you view width as the key, then the changes would be desirable..

So I guess my bias is width, but to account for the fact that bias may not suite everyone in the INDENT_MIN which basically restores old binxi layout look/feel to pinxi.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3882
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
HeinzDo61, that was a stray debugger I forgot to remove.

that will be corrected in a few minutes in pinxi, and today in inxi.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3882
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
dark-D, I've added a new switch, --indent-min which allows me and you to play around with this a bit. That's in pinxi, will be in, as a probably undocumented, option in inxi later today when I roll out some more fixes for 2.9.06

I certainly hear what you are saying, and when I put my eyes into your head, so to speak (ala being john malkovich), I can see what you are seeing, so it's certainly an understandable point of view.

I think I'd want to get more user feedback on this however since I don't really know who would prefer the new or old ways, or why, but you've made it clear that there is an argument for the old way.
Back to top
kamil
Status: New User - Welcome
Joined: 29 Mar 2018
Posts: 3
Reply Quote
Hi.

When I use --output json in rc.local on system start
for example:
/usr/bin/inxi -m --output json --output-file print > /tmp/AAC.txt

I've got Error 1: You can't run option help in an IRC client!

When I run rc.local manualy everything is ok

I use Debian 9
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3882
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
If you're trying to write to a file, then give the file path, don't use print. Print is to output to stdout, probably for a pipe, or to capture the data in a variable and use it.

:: Code ::
/usr/bin/inxi -m --output json --output-file /tmp/AAC.txt


your use of print in this context is pointless and certainly is not a bug.

:: Code ::

# Pipe it somewhere
pinxi --output json --output-file print | xargs echo

# capture stdout and use it for something
data=$(pinxi --output json --output-file print);echo "$data"


for example would be correct uses of print to stdout. Redirecting to a file would be an example of an incorrect and pointless use of print, since the primary purpose of --output-file [/path/to/file.txt] is to output to a file.

Technically speaking, by using the > you are making inxi think that it's running in IRC since the command tty has no result.

This also happens (as an unfixed bug/issue in inxi) when you use:

ssh username@site.com "pinxi"
Back to top
Display posts from previous:   
Page: Previous  1, 2, 3 ... , 24, 25, 26  Next
All times are GMT - 8 Hours