Page: Previous  1, 2, 3  Next

rooots
Status: Interested
Joined: 17 May 2020
Posts: 43
Reply Quote
What happens if you swap ports of the displays and/or if you boot & login with only one/two display(s) powered and then turn on the others when your desktop is up and running?
Back to top
Mono
Status: Contributor
Joined: 21 Jun 2012
Posts: 115
Reply Quote
Blacklisting nvidiafb worked, and actually made no change to the console display interestingly.

Generally whenever I see a high resolution console it is a sign of impending doom, so I am perfectly fine with 640x480...
Back to top
Mono
Status: Contributor
Joined: 21 Jun 2012
Posts: 115
Reply Quote
:: rooots wrote ::
What happens if you swap ports of the displays and/or if you boot & login with only one/two display(s) powered and then turn on the others when your desktop is up and running?


I've tried lots of stuff. When I looked into it there was an odd problem with the EDID not being communicated when using ports on the GT730. I can set up the display with nvidia but the desktop manager will not detect or use it. No one has a solution to the problem, but it seems to be a driver issue.
Back to top
Mono
Status: Contributor
Joined: 21 Jun 2012
Posts: 115
Reply Quote
:: Code ::
Nov 22 13:39:07 ronin kernel: nvidia-nvlink: Nvlink Core is being initialized, major device number 234
Nov 22 13:39:07 ronin kernel: NVRM: The NVIDIA GeForce GT 730 GPU installed in this system is
                              NVRM:  supported through the NVIDIA 470.xx Legacy drivers. Please
                              NVRM:  visit http://www.nvidia.com/object/unix.html for more
                              NVRM:  information.  The 495.44 NVIDIA driver will ignore
                              NVRM:  this GPU.  Continuing probe...
Nov 22 13:39:07 ronin kernel: nvidia 0000:09:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=io+mem


Great, nvidia has decided to obsolete my GT730 with the latest drivers it seems. I now have 2 perfectly fine, immortal passive cooled GPUs that can no longer be used for the simple purpose of displaying video for which they are perfectly adequate.
Back to top
rooots
Status: Interested
Joined: 17 May 2020
Posts: 43
Reply Quote
If blacklisting nvidiafb solves the issue for you, what's wrong with sticking with the legacy driver? Potentially saves you from borked driver updates ;-)
Back to top
Mono
Status: Contributor
Joined: 21 Jun 2012
Posts: 115
Reply Quote
I use sgfxi to install drivers, maybe it can install the legacy drivers. I don't know if the legacy driver is compatible with the GTX950.
Back to top
rooots
Status: Interested
Joined: 17 May 2020
Posts: 43
Reply Quote
The above screenshot suggests the legacy driver could be the standard driver frozen at 470.xx, which already supported the RTX3000 series (at least unofficially). Older Linux drivers are available on their website, just did a search and found the 2018 version that first added support for the GTX950:

www.nvidia.com/Download/driverResults.aspx/90279/en-us

Will still be interesting how it plays with current kernels, but I'd try the 470.xx, here's what their website shows when searching for the GTX950:

www.nvidia.com/Download/driverResults.aspx/183575/en-us


Good luck!
Back to top
Mono
Status: Contributor
Joined: 21 Jun 2012
Posts: 115
Reply Quote
That page promptly gives me "access denied". Seems to be happening more and more often.

I haven't tried to install nvidia drivers in years. Which blog do I need to read to figure out this week's working installation method...

Today I got a random reboot and machine check errors logged on reboot. The latest kernels seem to be very unstable. No problem on windows.
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 931
Reply Quote
If you don't play games with your system, what's wrong with using Nouveau? Seems like using nvidia drivers with hardware as old as yours is probably not a good idea.
Back to top
rooots
Status: Interested
Joined: 17 May 2020
Posts: 43
Reply Quote
:: Mono wrote ::
That page promptly gives me "access denied". Seems to be happening more and more often.


Then maybe something's wrong with your internet connection, too - I was just able to download both drivers! ;-)
Back to top
Display posts from previous:   
Page: Previous  1, 2, 3  Next
All times are GMT - 8 Hours