Page: Previous  1, 2, 3, 4, 5, 6, 7  Next

wget bug report
Chris M
Status: Contributor
Joined: 11 Aug 2013
Posts: 62
Reply Quote
bugs.debian.org/cgi-bin/bugreport.cgi?bug=813158

Read the whole thread. It looks like a fix is on the way soon for the wget issue.

Not sure that this will take care of my installation issue # 2, but we'll see.
Back to top
dacorsa
Status: New User - Welcome
Joined: 04 Dec 2016
Posts: 3
Reply Quote
savannah.gnu.org/bugs/?52349
Back to top
Chris M
Status: Contributor
Joined: 11 Aug 2013
Posts: 62
Reply Quote
Question for the folks who had this wget problem. Have any of you completely removed the current 1.19.2-1 version and installed the 1.19.1-4 version at snapshot.debian.org/archive/debian/20170626T160736Z/pool/main/w/wget/wget_1.19.1-4_amd64.deb, and then run sgfxi via smxi, or just sgxfi, and if so, what has been the result?

A careful read of the developer's response indicates that this fix will come with the wget planned release of version 1.19.3. 1.19.2 isn't going to be patched, so we could be months away from a fix for this.

Downgrading to 1.19.1-4 gives me the following:

:: Code ::
root@asus:/home/chris# wget -O - smxi.org/sm/sm-versions
--2017-11-09 21:37:36--  http://smxi.org/sm/sm-versions
Resolving smxi.org (smxi.org)... 216.92.31.53
Connecting to smxi.org (smxi.org)|216.92.31.53|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: https://smxi.org/sm/sm-versions [following]
--2017-11-09 21:37:36--  https://smxi.org/sm/sm-versions
Connecting to smxi.org (smxi.org)|216.92.31.53|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1008
Saving to: ‘STDOUT’

-                     0%[                    ]       0  --.-KB/s               smxi=8.15.23:2017-11-03
sm-lib-apt-tools=1.23.42:2015-06-23
sm-lib-clean-up=2.10.15:2012-02-08
sm-lib-distro-conversion=3.3.17:2014-03-29
sm-lib-du-fixes=1.4.12:2015-11-16
sm-lib-graphics=2.6.2:2014-12-19
sm-lib-kde4-updater=0.7.39:2013-11-19
sm-lib-kernel=2.7.0:2017-11-07
sm-lib-kernel-install=2.12.14:2016-05-12
sm-lib-misc-tweaks=1.24.6:2015-03-11
sm-lib-package-install=3.4.38:2016-11-01
sm-lib-package-removal=1.4.2:2011-02-10
sm-lib-warning=2.0.2:2009-04-15
sm-lib-2006-fixes=1.2.2:2008-06-08
sm-lib-2007-fixes=1.3.20:2008-11-17
sm-lib-2008-fixes=1.4.2:2008-12-26
sm-lib-2008-fixes-s=1.0.1:2008-11-17
sm-lib-2008-fixes-t=1.0.2:2008-11-18
sm-lib-2009-fixes=1.1.25:2010-09-16
sm-lib-2009-fixes-s=1.0.1:2009-04-07
sm-lib-2009-fixes-t=1.1.19:2009-12-02
sm-lib-2011-fixes=1.1.0:2011-07-14
sm-lib-2011-fixes-s=1.0.0:2011-02-10
sm-lib-2011-fixes-t=1.1.0:2011-07-14
sgfxi=4.24.18:2017-11-03
svmi=2.8.72:2017-07-27
inxi=2.3.43:2017-10-31
rbxi=2.7.4:2016-12-20
sm-main-version=8.42.00:2017-11-07

###**EOF**###
-                   100%[===================>]    1008  --.-KB/s    in 0s     

2017-11-09 21:37:36 (54.3 MB/s) - written to stdout [1008/1008]


I note that the "sm-main-version=8.42.00:2017-11-07" is "upgraded" from original successful posts (sm-main-version=8.41.58:2017-11-03). In any event, the workaround downgrade solves the wget problem.

Bottom line: Is anyone else having nvidia driver installation problems?
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 282
Location: South Florida
Reply Quote
I only use nouveau and have the issue, installing nvidia could solve the problem, how is this related to a seg fault?
Back to top
Chris M
Status: Contributor
Joined: 11 Aug 2013
Posts: 62
Reply Quote
I don't think the wget seg fault issue is in play, if you downgrade wget. The seg fault issue was always about wget.

There is 1.19.1-4 version of wget from snapshot.debian.org/package/wget/1.19.1-4/

There is also a 1.19.1-5 version that was briefly in sid at: snapshot.debian.org/package/wget/1.19.1-5/

Either deb file will work. I just installed and have pinned the 1.19.1-5 version: snapshot.debian.org/archive/debian/20171024T092932Z/pool/main/w/wget/wget_1.19.1-5_amd64.deb

You have to completely remove 1.19.2-1. I did it through Synaptic, but you could run apt-get purge wget in terminal.

If you install 1.19.1-4 or 1.19.1-5, and then run sgfxi, your driver choice # 2 should be nvidia-debian. This is debian's non-free installation.

But I'm trying to install the current nvidia driver, and I'm getting:

:: Code ::
-> An incomplete installation of libglvnd was found. Do you want to install a full copy of libglvnd? This will overwrite any existing libglvnd libraries. (Answer: Abort installation.)
ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
  ERROR: (245) The nvidia installer exited with the error: 1
A copy of this driver installer error log is also here: /var/log/sgfxi/sgfxi.log


There is no seg fault issue with a downgrade of wget. Now it's an installation issue:

:: Code ::
=========================================================
START sgfxi LOGGING:
=========================================================
Script started: 2017-11-09-23:06:23
Video Card Information: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a2)
Video Card Type: 10de
Video Card Number: 1380
Xorg Version: 1.19.5
Installing driver to kernel: 4.13.0-1-amd64
sgfxi script version: 4.24.18
sgfxi start options:  -o 387.22 -j 1 -! 120 -X -P apt-get
SYSTEM_BASE: debian
SYSTEM_CODENAME: testing
DISTRIB_CODENAME: testing
DISTRIB_ID: debian
DISTRIB_RELEASE:
SIS: debian-testing-64
BITS: 64
FG_DISTRIB_CODENAME: sid
FG_DISTRIB_ID: Debian
APT_TYPE: apt-get
LOGIN_PID: 524
SUDO_START:
B_SYSTEMD: true
B_SYSTEMD_GRAPHICAL: true
B_SYSTEMD_SYSINIT: true
B_UPSTART: false
=========================================================
X is Running: false
Current Runlevel: 5
Connection is live (0=true): 0
=========================================================
INSTALL_TO_KERNEL:
KERNEL_FULL: 4.13.0-1-amd64
KERNEL_BASE: 4
KERNEL_NUMBER: 4.13
KERNEL_MATH: 13
B_IS_XEN: true
Function: create_x_conf - Primary: Start
  xorg is present with xorg.conf file
Function: create_x_conf - Primary: End
Function: check_supported_driver - Utility: Start
Function: check_supported_driver - Utility: End
Function: set_cpu_data - Utility: Start
  BITS: 64 - arch: _64
Function: set_cpu_data - Utility: End
Function: set_driver_install_version - Primary: Start
Function: check_supported_driver - Utility: Start
  Args: last-check
Function: check_supported_driver - Utility: End
Function: print_information_continue - Utility: Start
  Args: standard The graphics installer will be installing the nvidia driver: 387.22
Function: check_ia32_libs - Utility: Start
  Args: test
Function: check_package_status - Utility: Start
  Args: ia32-libs-i386:i386 i
  Package Version:
Function: check_package_status - Utility: End
  32 bit nvidia supported. Showing install option.
Function: check_ia32_libs - Utility: End
Function: print_information_continue - Utility: End
  Installing this driver: 387.22
Function: set_driver_install_version - Primary: End
Function: driver_support_tests - Utility: Start
  Args: supported-driver
Function: driver_support_tests - Utility: End
Function: check_kernel_headers - Utility: Start
Function: check_package_status - Utility: Start
  Args: linux-headers-4.13.0-1-amd64 i
  Package Version: 4.13.4-2
Function: check_package_status - Utility: End
Function: check_package_status - Utility: Start
  Args: linux-headers-4.13.0-1-amd64 c
  Package Version: 4.13.4-2
Function: check_package_status - Utility: End
  headerPresent: Makefile
Module.symvers
arch
include
scripts
headerName: linux-headers-4.13.0-1-amd64
headerInstalled: 4.13.4-2
headerAvailable: 4.13.4-2
headerFile:
Function: check_kernel_headers - Utility: End
Function: check_run_package_tools - Primary: Start
Function: check_run_package_tools - Primary: End
Function: set_download_info - Primary: Start
  download url: https://download.nvidia.com/XFree86/Linux-x86_64/387.22/ - driver file: NVIDIA-Linux-x86_64-387.22
Function: set_download_info - Primary: End
Function: test_module_build_ok - Primary: Start
  Args: return
Function: list_installed_packages - Utility: Start
  Args: nvidia (libkwinnvidiahack|libgl1-nvidia-glx-ia32|libgl1-nvidia-glx:386|modalias|libvdpau)
  packageList:
Function: list_installed_packages - Utility: End
  returnValue: 3
Error Data: No Installed Nvidia:
Function: download_extract_driver - Primary: Start
  Args: https://download.nvidia.com/XFree86/Linux-x86_64/387.22/ NVIDIA-Linux-x86_64-387.22
Function: pre_extract_clean_set_up - Utility: Start
  Args: NVIDIA-Linux-x86_64-387.22
Function: pre_extract_clean_set_up - Utility: End
Creating directory NVIDIA-Linux-x86_64-387.22
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 387.22....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
Function: download_extract_driver - Primary: End
  Function: set_install_directory - set to: /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22
Function: check_patch_driver - Primary: Start
Function: check_patch_driver - Primary: End
Function: x_start_stop_master - Primary: Start
  Args: stop
Function: x_start_stop_master - Primary: End
Function: check_driver_install_tools - Primary: Start
Function: check_package_status - Utility: Start
  Args: module-assistant i
  Package Version: 0.11.9
Function: check_package_status - Utility: End
Function: check_package_status - Utility: Start
  Args: build-essential i
  Package Version: 12.4
Function: check_package_status - Utility: End
Function: check_driver_install_tools - Primary: End
Function: prep_install - Primary: Start
Function: prep_install - Primary: End
Function: preinstall_cleanup - Primary: Start
  Pre Remove: nvidia.ko files:

Function: list_installed_packages - Utility: Start
  Args: nvidia (libkwinnvidiahack|libgl1-nvidia-glx-ia32|libgl1-nvidia-glx:386|modalias|libvdpau|nvidia-bl-dkms|nvidia-cg-toolkit)
  packageList:
Function: list_installed_packages - Utility: End
  Post Purge/Remove: nvidia.ko files:

Function: remove_module - Primary: Start
  Args: nvidia
  operation outcome: unset
Function: remove_module - Primary: End
Function: remove_module - Primary: Start
  Args: nouveau
  operation outcome: unset
Function: set_modesetting_off - Primary: End
Function: add_grub_nomodeset_blacklist_item - Utility: Start
  Args: nouveau
Function: get_active_grub_files - Utility: Start
  grub files:  /boot/grub/grub.cfg /etc/default/grub
Function: get_active_grub_files - Utility: End
Function: add_grub_nomodeset_blacklist_item - Utility: End
Function: add_modprobe_d_blacklist_item - Utility: Start
  Args: nouveau
Function: add_modprobe_d_blacklist_item - Utility: End
Function: set_modesetting_off - Primary: Start
  Args: nouveau unset
Function: remove_module - Primary: End
Function: list_installed_packages - Utility: Start
  Args: fglrx modalias
  packageList:
Function: list_installed_packages - Utility: End
Function: remove_module - Primary: Start
  Args: fglrx
  operation outcome: unset
Function: remove_module - Primary: End
Function: clean_dkms - Primary: Start
Function: clean_dkms - Primary: End
Function: preinstall_cleanup - Primary: End
Function: run_driver_installer - Primary: Start
  driver: 387.22

WARNING: The '--no-network' option is deprecated:  nvidia-installer will
         ignore this option.


WARNING: Unable to find a suitable destination to install 32-bit
         compatibility libraries. Your system may not be set up for 32-bit
         compatibility. 32-bit compatibility files will not be installed;
         if you wish to install them, re-run the installation and set a
         valid directory with the --compat32-libdir option.

libEGL warning: DRI3: xcb_connect failed
libEGL warning: DRI2: xcb_connect failed
libEGL warning: DRI2: xcb_connect failed

ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find
       suggestions on fixing installation problems in the README available
       on the Linux driver download page at www.nvidia.com.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Error logs from nvidia install:
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Nov  9 23:06:32 2017
installer version: 387.22

PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

nvidia-installer command line:
    ./nvidia-installer
    -s
    -N
    --x-module-path=/usr/lib/xorg/modules
    --x-library-path=/usr/lib
    -k
    4.13.0-1-amd64

Using built-in stream user interface
-> Detected 4 CPUs online; setting concurrency level to 4.
-> License accepted by command line option.
-> Installing NVIDIA driver version 387.22.
-> Would you like to register the kernel module sources with DKMS? This will allow DKMS to automatically build a new module, if you install a different kernel later. (Answer: No)
-> Not probing for precompiled kernel interfaces.
-> Performing CC sanity check with CC="/usr/bin/gcc-6".
-> Kernel source path: '/lib/modules/4.13.0-1-amd64/source'
-> Kernel output path: '/lib/modules/4.13.0-1-amd64/build'
-> Performing Compiler check.
-> Performing Dom0 check.
-> Performing Xen check.
-> Performing PREEMPT_RT check.
-> Cleaning kernel module build directory.
   executing: 'cd ./kernel; /usr/bin/make -k -j4 clean NV_EXCLUDE_KERNEL_MODULES="" SYSSRC="/lib/modules/4.13.0-1-amd64/source" SYSOUT="/lib/modules/4.13.0-1-amd64/build"'...
   rm -f -r conftest
   make[1]: Entering directory '/usr/src/linux-headers-4.13.0-1-common'
   make[2]: Entering directory '/usr/src/linux-headers-4.13.0-1-amd64'
   make[2]: Leaving directory '/usr/src/linux-headers-4.13.0-1-amd64'
   make[1]: Leaving directory '/usr/src/linux-headers-4.13.0-1-common'
-> Building kernel modules
   executing: 'cd ./kernel; /usr/bin/make -k -j4  NV_EXCLUDE_KERNEL_MODULES="" SYSSRC="/lib/modules/4.13.0-1-amd64/source" SYSOUT="/lib/modules/4.13.0-1-amd64/build"'...
   make[1]: Entering directory '/usr/src/linux-headers-4.13.0-1-common'
   make[2]: Entering directory '/usr/src/linux-headers-4.13.0-1-amd64'
     SYMLINK /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-kernel.o
     SYMLINK /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-modeset/nv-modeset-kernel.o
    CONFTEST: remap_pfn_range
    CONFTEST: hash__remap_4k_pfn
    CONFTEST: follow_pfn
    CONFTEST: INIT_WORK
    CONFTEST: vmap
    CONFTEST: set_pages_uc
    CONFTEST: set_memory_uc
    CONFTEST: set_memory_array_uc
    CONFTEST: change_page_attr
    CONFTEST: pci_get_class
    CONFTEST: pci_choose_state
    CONFTEST: vm_insert_page
    CONFTEST: acpi_device_id
    CONFTEST: acquire_console_sem
    CONFTEST: console_lock
    CONFTEST: kmem_cache_create
    CONFTEST: on_each_cpu
    CONFTEST: smp_call_function
    CONFTEST: acpi_evaluate_integer
    CONFTEST: ioremap_cache
    CONFTEST: ioremap_wc
    CONFTEST: acpi_walk_namespace
    CONFTEST: pci_domain_nr
    CONFTEST: pci_dma_mapping_error
    CONFTEST: sg_alloc_table
    CONFTEST: sg_init_table
    CONFTEST: pci_get_domain_bus_and_slot
    CONFTEST: get_num_physpages
    CONFTEST: efi_enabled
    CONFTEST: proc_create_data
    CONFTEST: pde_data
    CONFTEST: proc_remove
    CONFTEST: pm_vt_switch_required
    CONFTEST: xen_ioemu_inject_msi
    CONFTEST: phys_to_dma
    CONFTEST: get_dma_ops
    CONFTEST: write_cr4
    CONFTEST: of_get_property
    CONFTEST: of_find_node_by_phandle
    CONFTEST: of_node_to_nid
    CONFTEST: pnv_pci_get_npu_dev
    CONFTEST: for_each_online_node
    CONFTEST: node_end_pfn
    CONFTEST: pci_bus_address
    CONFTEST: pci_stop_and_remove_bus_device
    CONFTEST: pci_remove_bus_device
    CONFTEST: request_threaded_irq
    CONFTEST: register_cpu_notifier
    CONFTEST: cpuhp_setup_state
    CONFTEST: backlight_device_register
    CONFTEST: remap_page_range
    CONFTEST: address_space_init_once
    CONFTEST: kbasename
    CONFTEST: fatal_signal_pending
    CONFTEST: list_cut_position
    CONFTEST: vzalloc
    CONFTEST: wait_on_bit_lock_argument_count
    CONFTEST: bitmap_clear
    CONFTEST: usleep_range
    CONFTEST: radix_tree_empty
    CONFTEST: drm_dev_unref
    CONFTEST: drm_reinit_primary_mode_group
    CONFTEST: drm_atomic_set_mode_for_crtc
    CONFTEST: drm_atomic_clean_old_fb
    CONFTEST: get_user_pages_remote
    CONFTEST: drm_gem_object_lookup
    CONFTEST: drm_atomic_state_free
    CONFTEST: drm_driver_has_gem_prime_res_obj
    CONFTEST: drm_atomic_helper_disable_all
    CONFTEST: drm_atomic_helper_set_config
    CONFTEST: drm_atomic_helper_connector_dpms
    CONFTEST: is_export_symbol_gpl_of_node_to_nid
    CONFTEST: i2c_adapter
    CONFTEST: pm_message_t
    CONFTEST: irq_handler_t
    CONFTEST: acpi_device_ops
    CONFTEST: acpi_op_remove
    CONFTEST: outer_flush_all
    CONFTEST: proc_dir_entry
    CONFTEST: scatterlist
    CONFTEST: sg_table
    CONFTEST: file_operations
    CONFTEST: vm_operations_struct
    CONFTEST: atomic_long_type
    CONFTEST: pci_save_state
    CONFTEST: file_inode
    CONFTEST: task_struct
    CONFTEST: kuid_t
    CONFTEST: dma_ops
    CONFTEST: dma_map_ops
    CONFTEST: noncoherent_swiotlb_dma_ops
    CONFTEST: vm_fault_present
    CONFTEST: vm_fault_has_address
    CONFTEST: kernel_write
    CONFTEST: strnstr
    CONFTEST: iterate_dir
    CONFTEST: kstrtoull
    CONFTEST: backlight_properties_type
    CONFTEST: fault_flags
    CONFTEST: atomic64_type
    CONFTEST: address_space
    CONFTEST: backing_dev_info
    CONFTEST: mm_context_t
    CONFTEST: vm_ops_fault_removed_vma_arg
    CONFTEST: pnv_npu2_init_context
    CONFTEST: drm_bus_present
    CONFTEST: drm_bus_has_bus_type
    CONFTEST: drm_bus_has_get_irq
    CONFTEST: drm_bus_has_get_name
    CONFTEST: drm_driver_has_legacy_dev_list
    CONFTEST: drm_driver_has_set_busid
    CONFTEST: drm_crtc_state_has_connectors_changed
    CONFTEST: drm_init_function_args
    CONFTEST: drm_mode_connector_list_update_has_merge_type_bits_arg
    CONFTEST: drm_helper_mode_fill_fb_struct
    CONFTEST: drm_master_drop_has_from_release_arg
    CONFTEST: drm_mode_config_funcs_has_atomic_state_alloc
    CONFTEST: drm_driver_unload_has_int_return_type
    CONFTEST: kref_has_refcount_of_type_refcount_t
    CONFTEST: drm_crtc_helper_funcs_has_atomic_enable
    CONFTEST: dom0_kernel_present
    CONFTEST: nvidia_vgpu_kvm_build
    CONFTEST: nvidia_grid_build
    CONFTEST: drm_available
    CONFTEST: drm_atomic_available
    CONFTEST: drm_atomic_modeset_nonblocking_commit_available
    CONFTEST: is_export_symbol_gpl_refcount_inc
    CONFTEST: is_export_symbol_gpl_refcount_dec_and_test
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-acpi.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-chrdev.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-gpu-numa.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-cray.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-dma.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-gvi.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-i2c.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-mempool.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-mmap.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-p2p.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-pat.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-procfs.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-usermap.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-vm.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-vtophys.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/os-interface.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/os-mlock.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/os-pci.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/os-registry.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/os-usermap.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-modeset-interface.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-pci-table.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-memdbg.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-report-err.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-ibmnpu.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv_uvm_interface.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nvlink_linux.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-frontend.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-kthread-q.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-kthread-q-selftest.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-instance.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm_utils.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm_common.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm_linux.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/nvstatus.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/nvCpuUuid.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_tools.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_global.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_gpu.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_gpu_isr.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_procfs.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_va_space.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_gpu_semaphore.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_mem.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_rm_mem.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_channel.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_lock.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_hal.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_range_tree.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_range_allocator.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_va_range.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_va_block.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_range_group.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_gpu_replayable_faults.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_gpu_non_replayable_faults.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_gpu_access_counters.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_perf_events.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_perf_module.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_mmu.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_pte_batch.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_tlb_batch.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_push.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_pushbuffer.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_thread_context.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_tracker.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_kepler.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_kepler_ce.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_kepler_host.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_kepler_mmu.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_maxwell.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_maxwell_host.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_pascal.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_pascal_ce.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_pascal_host.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_pascal_mmu.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_pascal_fault_buffer.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_volta_host.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_volta.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_volta_access_counter_buffer.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_volta_fault_buffer.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_policy.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_perf_utils.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_kvmalloc.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_pmm_gpu.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_migrate.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_map_external.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_user_channel.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_hmm.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_perf_heuristics.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_perf_thrashing.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_perf_prefetch.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_test_rng.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_range_tree_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_range_allocator_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_gpu_semaphore_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_mem_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_rm_mem_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_page_tree_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_tracker_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_push_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_channel_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_ce_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_lock_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_perf_utils_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_kvmalloc_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_pmm_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_perf_events_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_perf_module_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_get_rm_ptes_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_fault_buffer_flush_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_mmu_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_peer_identity_mappings_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_va_block_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm/uvm8_range_group_tree_test.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-modeset/nvidia-modeset-linux.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm/nvidia-drm.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm/nvidia-drm-drv.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm/nvidia-drm-utils.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm/nvidia-drm-crtc.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm/nvidia-drm-encoder.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm/nvidia-drm-connector.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm/nvidia-drm-gem.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm/nvidia-drm-fb.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm/nvidia-drm-modeset.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm/nvidia-drm-prime-fence.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm/nvidia-drm-linux.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm/nvidia-drm-helper.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm/nv-pci-table.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm/nvidia-drm-gem-nvkms-memory.o
     CC [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm/nvidia-drm-gem-user-memory.o
   ld -r -o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-interface.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-gpu-numa.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-acpi.o /usr/src/sg
   fxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-chrdev.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-cray.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-dma.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-gvi.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-i2c.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-mempool.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-mmap.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-p2p.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-pat.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-procfs.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-usermap.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-vm.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-vtophys.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86
   _64-387.22/kernel/nvidia/os-interface.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/os-mlock.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/os-pci.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/os-registry.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/os-usermap.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-modeset-interface.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-pci-table.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-memdbg.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-report-err.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-ibmnpu.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv_uvm_interface.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nvlink_linux.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-frontend.o /usr/src/sgfxi-down
   loads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-kthread-q.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-kthread-q-selftest.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia/nv-instance.o
   ld -r -o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-modeset/nv-modeset-interface.o /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-modeset/nvidia-modeset-linux.o
     LD [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia.o
     LD [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm.o
     LD [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-modeset.o
     LD [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm.o
     Building modules, stage 2.
     MODPOST 4 modules
     CC      /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm.mod.o
     CC      /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-modeset.mod.o
     CC      /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm.mod.o
     CC      /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia.mod.o
     LD [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-drm.ko
     LD [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-modeset.ko
     LD [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia-uvm.ko
     LD [M]  /usr/src/sgfxi-downloads/NVIDIA-Linux-x86_64-387.22/kernel/nvidia.ko
   make[2]: Leaving directory '/usr/src/linux-headers-4.13.0-1-amd64'
   make[1]: Leaving directory '/usr/src/linux-headers-4.13.0-1-common'
-> done.
-> Kernel module compilation complete.
-> Unable to determine if Secure Boot is enabled: No such file or directory
-> Installing both new and classic TLS OpenGL libraries.
-> Installing classic TLS 32bit OpenGL libraries.
WARNING: Unable to find a suitable destination to install 32-bit compatibility libraries. Your system may not be set up for 32-bit compatibility. 32-bit compatibility files will not be installed; if you wish to install them, re-run the installation and set a valid directory with the --compat32-libdir option.
-> Will install GLVND GLX client libraries.
-> Will install GLVND EGL client libraries.
-> Skipping GLX non-GLVND file: "libGL.so.387.22"
-> Skipping GLX non-GLVND file: "libGL.so.1"
-> Skipping GLX non-GLVND file: "libGL.so"
-> Skipping EGL non-GLVND file: "libEGL.so.387.22"
-> Skipping EGL non-GLVND file: "libEGL.so"
-> Skipping EGL non-GLVND file: "libEGL.so.1"
Looking for install checker script at ./libglvnd_install_checker/check-libglvnd-install.sh
   executing: '/bin/sh ./libglvnd_install_checker/check-libglvnd-install.sh'...
   Checking for libglvnd installation.
   Checking libGLdispatch...
   Checking libGLdispatch dispatch table
   Checking call through libGLdispatch
   All OK
   libGLdispatch is OK
   Checking for libGLX
   libGLX is OK
   Checking for libEGL
   eglInitialize failed
-> An incomplete installation of libglvnd was found. Do you want to install a full copy of libglvnd? This will overwrite any existing libglvnd libraries. (Answer: Abort installation.)
ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
  ERROR: (245) The nvidia installer exited with the error: 1
A copy of this driver installer error log is also here: /var/log/sgfxi/sgfxi.log


The installation is complaining about libglvnd.

I want to know if other folks are now getting the same installation error. That's not a seg fault/wget issue. As far as I'm concerned, that issue is solved.
Back to top
Chris M
Status: Contributor
Joined: 11 Aug 2013
Posts: 62
Reply Quote
By the way, ckosloff, if you're running sgfxi through smxi, there are 3 options to proceed. Option 1 will run dist-upgrade or update. You can't run that, or you will end up upgrading wget to the 1.19.2-1, and you'll be back to the same seg fault error position.

You have to choose option 2, which says something to the effect of "proceed without dist-upgrade/update". That will retain your downgraded version of wget without the seg fault error.
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 282
Location: South Florida
Reply Quote
Thanks for reply.

I think that I will take the route of waiting for the upgrade to hit the repo.
It is not there yet, today I did a ful dist-upgrade on testing and, after testing smxi, still getting errors.
Back to top
Chris M
Status: Contributor
Joined: 11 Aug 2013
Posts: 62
Reply Quote
Why? What's the hangup with installing the older wget? What are you affraid of? That package is as OS independent as they come. It will not screw you up.

Did you read what I wrote above? The developer isn't going to patch wget 1.19.2. The wget fix won't come in until 1.19.3. That could take months.

I can't troubleshoot what's now looking like an installation issue until the folks having this problem try installing 1.19.1-4 or 1.19.1-5.

Edit: ftp.gnu.org/gnu/wget/

Take a look at the time between the 1.19.1 release and the 1.19.2 release. 8 months.
Back to top
"SOLVED"
Chris M
Status: Contributor
Joined: 11 Aug 2013
Posts: 62
Reply Quote
This wget issue is solved by downgrading.


The separate installation is confirmed:

bugs.debian.org/cgi-bin/bugreport.cgi?bug=879041

devtalk.nvidia.com/default/topic/1024276/linux/-384-90-redundant-installation-error-on-centos-6-9-debian-sid/

The installation issue is more than likely an xserver-xorg related issue. The first link above reporting the bug is dated October 18, and looking at my apt history log, xserver-xorg-core:amd64 came in on that day:

:: Code ::
 Start-Date: 2017-10-18  08:30:52
Commandline: apt-get upgrade
Upgrade: init:amd64 (1.49, 1.50), libsoup-gnome2.4-1:amd64 (2.60.0-1, 2.60.1-1), init-system-helpers:amd64 (1.49, 1.50), libdrm-nouveau2:amd64 (2.4.83-1, 2.4.84-2), xserver-common:amd64 (2:1.19.3-2, 2:1.19.5-1), gir1.2-soup-2.4:amd64 (2.60.0-1, 2.60.1-1), gnome-mime-data:amd64 (2.18.0-1, 2.18.0-2), libparted2:amd64 (3.2-17, 3.2-18), libpam-cap:amd64 (1:2.25-1, 1:2.25-1.1), console-setup-linux:amd64 (1.167, 1.168), xserver-xorg-legacy:amd64 (2:1.19.3-2, 2:1.19.5-1), console-setup:amd64 (1.167, 1.168), libparted-fs-resize0:amd64 (3.2-17, 3.2-18), libsoup2.4-1:amd64 (2.60.0-1, 2.60.1-1), libdrm-amdgpu1:amd64 (2.4.83-1, 2.4.84-2), libtag1v5:amd64 (1.11.1+dfsg.1-0.1, 1.11.1+dfsg.1-0.2), libcap2:amd64 (1:2.25-1, 1:2.25-1.1), libcap2-bin:amd64 (1:2.25-1, 1:2.25-1.1), lintian:amd64 (2.5.54, 2.5.55), parted:amd64 (3.2-17, 3.2-18), libdrm2:amd64 (2.4.83-1, 2.4.84-2), keyboard-configuration:amd64 (1.167, 1.168), libdrm-intel1:amd64 (2.4.83-1, 2.4.84-2), libdrm-radeon1:amd64 (2.4.83-1, 2.4.84-2), libtag1v5-vanilla:amd64 (1.11.1+dfsg.1-0.1, 1.11.1+dfsg.1-0.2), libxslt1.1:amd64 (1.1.29-2.1, 1.1.29-2.2), libdrm-common:amd64 (2.4.83-1, 2.4.84-2)
End-Date: 2017-10-18  08:30:59

Start-Date: 2017-10-18  08:31:10
Commandline: apt-get dist-upgrade
Install: libegl1:amd64 (0.2.999+git20170802-5, automatic), libegl-mesa0:amd64 (17.2.2-1, automatic), libgl1:amd64 (0.2.999+git20170802-5, automatic), libllvm5.0:amd64 (1:5.0~+rc2-1, automatic), libglx0:amd64 (0.2.999+git20170802-5, automatic), libglx-mesa0:amd64 (17.2.2-1, automatic), libglvnd0:amd64 (0.2.999+git20170802-5, automatic)
Upgrade: xserver-xorg-core:amd64 (2:1.19.3-2, 2:1.19.5-1), libglapi-mesa:amd64 (13.0.6-1+b2, 17.2.2-1), libxatracker2:amd64 (13.0.6-1+b2, 17.2.2-1), libegl1-mesa:amd64 (13.0.6-1+b2, 17.2.2-1), libgbm1:amd64 (13.0.6-1+b2, 17.2.2-1), libwayland-egl1-mesa:amd64 (13.0.6-1+b2, 17.2.2-1), libgl1-mesa-dri:amd64 (13.0.6-1+b2, 17.2.2-1), libgl1-mesa-glx:amd64 (13.0.6-1+b2, 17.2.2-1), mesa-vdpau-drivers:amd64 (13.0.6-1+b2, 17.2.2-1), mesa-va-drivers:amd64 (13.0.6-1+b2, 17.2.2-1)
End-Date: 2017-10-18  08:31:13

Start-Date: 2017-10-18  08:31:34
Commandline: apt autoremove
Remove: libllvm3.9:amd64 (1:3.9.1-10)
End-Date: 2017-10-18  08:31:34

Start-Date: 2017-10-18  09:24:13
Commandline: /usr/sbin/synaptic
Upgrade: linux-headers-4.13.0-1-amd64:amd64 (4.13.4-1, 4.13.4-2), linux-headers-4.13.0-1-common:amd64 (4.13.4-1, 4.13.4-2), linux-image-4.13.0-1-amd64:amd64 (4.13.4-1, 4.13.4-2), linux-kbuild-4.13:amd64 (4.13.4-1, 4.13.4-2)
End-Date: 2017-10-18  09:24:25


It doesn't look like the 1st link bug report has been responded to, and it may not, since it's reporting a bug related to the proprietary 384.90 installation. The Debian nvidia-driver is at version 375.82-8, and it's installing fine.

The installation issue doesn't seem to be too common, so it could be individual issue related to the timing of an xorg upgrade and kernel upgrade on the same day. Looking forward to kernel upgrade, and considering reaching up into sid to install 4.13.10-1. Also considering trying to reinstall xorg-server.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3937
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Note that I have updated smxi and sgfxi to install curl, which then is going to replace the broken wget -O -

Further note that upstream gnu wget has fixed the issue as of nov 6, but that has still not hit Debian sid/testing, so I decided not to wait any longer.

Note that fresh installs of smxi will work fine, and the curl auto installer may work fine but I haven't tested it, since i have curl on all my systems.

I did not replace all instances of wget, only the ones that use -O which curl has an exact drop in replacement for in terms of default features.

Note: I tested this, and in smxi, the curl autoinstall doesn't trigger unless it's a fresh smxi install. If you keep getting downloader errors, do:

apt-get install curl

then:
:: Code ::

cd /usr/local/bin && rm smxi && wget -Nc smxi.org/sm/smxi && chmod +x smxi


Then try starting smxi in gui: smxi -G

and it should all work again

sgfxi should install missing curl by itself however, but you may still need to manually update it same as above, unless you start it from smxi, then it will update fine.
Back to top
Display posts from previous:   
Page: Previous  1, 2, 3, 4, 5, 6, 7  Next
All times are GMT - 8 Hours