Page: 1, 2  Next

Please help with ntfs-3g [SOLVED!]
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
I have an HP Pavilion laptop with two hard drives.
sda1 is partitioned as swap and root with ext4.
The second drive, sdb1, is ntfs.
I also have a 2TB Seagate plugged in to USB, which I use to store stuff.
That one is also formatted as ntfs, because of portability.
I had everything working fine in aptosid, and saved that fstab to the storage device, which I call Giant.
Will post it subsequently, after I access it.
This is my actual fstab which does not work.
It is just one of my tries, I also wrote it as the sample code in smxi, but it did not work either, ntfs-3g is not finding the mount point.
I am following instructions in fstab itself, which recommends to use UUID, found in blkid.
SOL so far.
So, here is my present fstab, I will delete last two lines after I post, in order to access storage device and post the fstab I had in aptosid and which mysteriously does not work now.
I am using mcedit, but that is what I used to write it in aptosid.
:: Code ::

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda2 during installation
UUID=84e524f2-64c9-4f99-b730-47a5cc1437eb /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda1 during installation
UUID=10e8c831-efc1-44f0-9abf-ac73f6bb8dbb none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
UUID=66E700D429DAEEEE    /media/sdc1                   ntfs-3g   defaults  0  0
UUID=658BC7AE41BE5506    /media/sdb1                   ntfs-3g   defaults  0  0

[/code]

< Edited by ckosloff :: Jan 2, 12, 20:09 >

Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
:: Code ::

UUID=067be746-2ded-411c-ba21-1d1d7e4597aa     none                 swap         sw                                            0    0   
UUID=b3b2bbdf-e402-4930-be57-98330fa9dca7     /                    ext4         defaults,relatime,errors=remount-ro           0    1   
UUID=66E700D429DAEEEE                         /media/disk1part1    ntfs-3g         defaults  0    0
UUID=658BC7AE41BE5506                         /media/disk3part1    ntfs-3g         defaults  0    0


This is the fstab I had in aptosid, same machine, UUIDs did not change (I checked), maybe the mountpoints changed, and that is what is reported on boot, but mnt only has CD-ROM.
Please note that I only have read access to drives, but I need to write to them.
Back to top
aus9
Status: Assistant
Joined: 21 Sep 2008
Posts: 358
Location: Australia
Reply Quote
hi

I don't use any ntfs format but 2 suggestions for you.

one create labels on your usb drives and then create a fstab using label which should resolve your first issue....what is loaded first

techadmin has a page on fstab and it linked to this which I refer to TWICE
sorry for the shout

once for the label issue and second for your use of defaults ok?

ubuntuforums.org/showthread.php?t=283131

now it says defaults means

:: Quote ::
defaults = rw, suid, dev, exec, auto, nouser, and async


of interest to you is that its nouser and you might like to change to individual options and maybe use ...."users" different to his link but depends on who are your users on your computer

good luck
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
:: aus9 wrote ::
techadmin has a page on fstab and it linked to this which I refer to TWICE

Please post a link to that page, I am using the Ubuntu instructions you posted but still stuck.
Thank you.
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
Still stuck with the USB storage device Giant.
Here is my present fstab:
:: Code ::

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda2 during installation
UUID=84e524f2-64c9-4f99-b730-47a5cc1437eb /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda1 during installation
UUID=10e8c831-efc1-44f0-9abf-ac73f6bb8dbb none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/sdc1   /media/Giant   ntfs-3g      defaults   0   0
/dev/sdb1   /media/Data   ntfs-3g      defaults   0   0


I was getting error in previous fstab because those directories were not created in /media.
The strange thing is that Data (internal device) mounts fine and is writable, however Giant (USB storage) still refuses to mount on boot.
I can mount it manually with command:
mount -t ntfs-3g /dev/disk/by-uuid/[uuid from blkid] /media/Giant
but I shouldn't be doing this all the time.
I need to find solution in fstab.
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
Just one more thing before I leave.
I deleted altogether the Giant line and now Dolphin sees it unmounted, but clicking on it mounts it writable, go figure.
So the only problem left is how to get the damn thing to mount on boot without errors.
Will be back on this later.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4043
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
/dev/disk/by-uuid/ is what you should use, not

UUID

looking at my old fstab, that's what I had for the old ntfs stuff

/dev/disk/by-uuid/6CC4EB8EC4EB58BA /media/sda3 ntfs ro,umask=000 0 0

ignore my settings, ro,umask etc, that's for something I can't even remember

the system doesn't always find UUID but it does always find /dev/disk/by-uuid/

Also, using a label gets rid of that, same applies, if in doubt, use:
/dev/disk/by-label/[label]

labels are static, and should always be the first, not the last, choice. The problem is, and this is a real problem, and is why debian and others still don't' use labels by default, is that a user, if left to their own devices, will always pick a name that is not unique, like root, data, web, music, and that can in fact cause failed boots if two partitions on boot have the same label.

That's why I start my labels with the machine or device type/name, then the label itself, then usually a number.

like: fred-root-1

that way if you swap the drive, or attach it, it will always have a unique label.

Debian's refusal to use user friendly labels by default in grub to this day, years after a patch was submitted, that is non invasive and works perfectly, continues to baffle and annoy me. Some anal geek thing is the only explanation, but I don't want to know more. There's a reason grub2 is so user unfriendly.
Back to top
aus9
Status: Assistant
Joined: 21 Sep 2008
Posts: 358
Location: Australia
Reply Quote
1) a link to how to create labels for ntfs
ubuntuforums.org/showthread.php?t=283131

:: Quote ::

Changed slightly as you may be ex-MS user

You may also change the label of an existing filesystem using Windows.
linux command is below
ntfslabel /dev/XXX mylabelname


2) the original link to the label issue
techpatterns.com/forums/about848.html&highlight=label

3) So lets assume your partitions have correct labels
then use root powers to create directories.
SKIP if you already have them
:: Code ::

su
mkdir /media/Giant /media/Data


now your fstab with a "basic" labelname as example.
Do not ignore Techadmin's suggestion on using a better labelname but your mount point can still remain basic, please.

4)

/dev/disk/by-label/Giant /media/Giant ntfs-3g auto,users,permissions 0 0
/dev/disk/by-label/Data /media/Data ntfs-3g auto,users,permissions 0 0



good luck
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
Thanks for all answers.
Please note that I don't post all the tests that I made.
I did test with LABEL, the problem remained the same.
Again, the problem is exclusively with the USB drive, the other works fine.
One thing I noted is that USB drive creates its own directory on the fly.
For example, if I hard create a directory called Giant in /media, USB drive will create another one called Giant_.
If I only leave Data dir. in there, Giant is created on the fly.
Now I have commented out the Giant line and I boot without errors.
I can see the drive in Dolphin, click on it and it is mounted writable without further ado, it creates its own mountpoint in the same action, like I just said.
At this point I am wondering if it is even necessary to have this drive in fstab.
Will test some more and be back with results.
HAPPY NEW YEAR!!
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4043
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
You may have one of those usb drives that is linux unfriendly due to some weird firmware they use, standard usb drives mount fine in my experience.

You can confirm/deny this by just sticking in a usb memory stick, if it has the same issue, then the problem lies elsewhere, just format one ntfs, and see if that works.

I don't remember the usb drive maker or model, but there was at least one that caused a lot of problems for linux users.

If the external drive is not attached permanently, then you don't need it in fstab, kde handles drive attach/remove by itself, I never add that to fstab, it may in fact be the cause of your issue, if I understand this right. Just let kde handle it.
Back to top
Display posts from previous:   
Page: 1, 2  Next
All times are GMT - 8 Hours