Page: Previous  1, 2

ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
The drive is Seagate and it was formatted using the Linux utility, I didn't trust the manufacturer's format and added junk.
It took a long time to format 2 Tb.
I used it fine in aptosid and that is why I am a bit baffled now.
Yes, it is practically permanently attached to the computer I use.
After commenting out the line in fstab, it works.
There is just a slight annoyance, if I want to use it, I have to click on it in Dolphin for it to mount.
No big deal, but it wasn't doing that before.
I use it a lot, and having to mount it every session is an extra step that I would rather avoid.
Anyway, I have downgraded this issue from urgent to priority=low :-)
The problem is not that the system doesn't find it, it is that it is rejecting a hard-typed mount point.
I have tried every change in the syntax but nothing works, if I omit the mount point altogether I get error too: ntfs-3g is not a mount point.
If, for example, I put a symlink in desktop to a file in that drive it will throw error not found, until I mount drive.
It was not doing that before.
The syntax I was using in aptosid was really simple, but it does not work in Debian.
UUID=xyz (that did not change, of course) /media/some_mountpoint ntfs3-g defaults 0 0
Why that throws error now I cannot understand.
I will do several tests in coming days to see what is going on, will even boot into Debian kernel, which I still keep.
Will post the outcome here, but it might take some time as I am really hard-pressed to tackle other issues.
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
Back to ground zero.
This time I installed a Debian GUI called Device Manager, straight from the Debian repo, nothing extraneous.
It failed too, I had to comment out the line it wrote to fstab and delete the folder it created in media, in order to get the drive to work again.
In fact, it created again the Giant_ folder, it automounted there.
This thing is proving to be a tough cookie.
FYI, here is my fstab, with the input from Device Manager commented out.
:: Code ::
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc   /proc   proc   defaults   0   0
#Entry for /dev/sda2 :
UUID=84e524f2-64c9-4f99-b730-47a5cc1437eb   /   ext4   errors=remount-ro   0   1
#Entry for /dev/sdb1 :
UUID=658BC7AE41BE5506   /media/Data   ntfs-3g   defaults   0   0
#Entry for /dev/sdc1 :
#UUID=66E700D429DAEEEE   /media/Giant   ntfs   defaults,nls=utf8,umask=0222   0   0
#Entry for /dev/sda1 :
UUID=10e8c831-efc1-44f0-9abf-ac73f6bb8dbb   none   swap   sw   0   0
/dev/sr0   /media/cdrom0   udf,iso9660   user,noauto   0   0

#/dev/sdc1   /media/Giant   ntfs-3g   defaults   0   0

Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4043
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Seagate snubs linux

It's very important to include all information when posting, ie, it's not 'an external hard drive', it's a seagate, model still unknown.

Here's the search, this took me a few seconds to find: seagate external drive problems linux

Generally NEVER assume that something is irrelevant when posting support stuff, the more technical data you provide, especially with hardware, the fewer steps to finding the cause or resolution, if any.

I don't buy seagate any more, they suck, and have for a few years, I now go with western digital, trying to avoid their caviar blue series, which also is very failure prone, being the low end of their lines. Hard drives and enclosures are not commodity items, even though they try to market them that way.

And on external enclosures, if you buy a name brand, try to google and find what real disk they have in it, there's always geek forums where someone has taken one apart, but that can change year to year, for example, there was a year where the wd enclosures in the 1.5 tb size were shipping with caviar black, but then they moved to caviar green, still a fine drive, but not the level of black.

I need to get in the habit of insisting on seeing an inxi -F from all people posting any support issues, it can radically lower support times by discovering what the person may have assumed to not matter.

I can't tell you more, I don't really use ext drives for always attached storage, gave up on them years ago, they all died on me, except the very last one I got, the western digital, before that, I had literally a 100 failure rate. I have suspected some issue in the linux kernel, like excessive queries or poorly written queries, and I still do, since all my external drives died, and that's just not realistic, even with today's low standards.
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
@ techadmin
I have never found somebody who gives free support and gives such detailed replies, sincerely.
I admire you.
Sorry for not giving more info, I promise that if I post a trouble ticket in the future it will have everything that is needed.
I just started setting up a new system on my production machine, and smxi-related stuff is new to me, also, I am quite worried because my livelihood depends on me setting up a stable system, which is also rolling.
I take very seriously your advice to move away from ntf-3g for critical stuff, I will have to set up drives differently, but that is someting that I will tackle later on, right now I don't even have my email on this machine.
I do have it in another one.
So, here is the info from lshw:
:: Code ::
*-scsi
          physical id: 1
          bus info: usb@1:1
          logical name: scsi2
          capabilities: emulated scsi-host
          configuration: driver=usb-storage
        *-disk
             description: SCSI Disk
             product: Desktop
             vendor: Seagate
             physical id: 0.0.0
             bus info: scsi@2:0.0.0
             logical name: /dev/sdc
             version: 0130
             serial: 2GHM3XJQ
             size: 1863GiB (2TB)
             capabilities: partitioned partitioned:dos
             configuration: ansiversion=4 signature=00ee1e02
           *-volume
                description: Windows NTFS volume
                physical id: 1
                bus info: scsi@2:0.0.0,1
                logical name: /dev/sdc1
                version: 3.1
                serial: 69f164b2-a6d7-42fd-88af-da1cf8bcb46e
                size: 1863GiB
                capacity: 1863GiB
                capabilities: primary ntfs initialized
                configuration: clustersize=4096 created=2010-11-26 17:43:26 filesystem=ntfs label=Giant state=clean


Inxi gave much less info, here is:
:: Code ::
root@papimalo:/home/ckosloff# inxi
CPU~Single core AMD Turion 64 Mobile ML-37 (-UP-) clocked at 800.000 Mhz Kernel~3.1.0-6.dmz.1-liquorix-amd64 x86_64 Up~10 min Mem~688.7/1881.1MB HDD~2640.5GB(1.0% used) Procs~184 Client~Shell inxi~1.7.27                                                                                   
root@papimalo:/home/ckosloff#

I don't know why inxi didn't spit out more, maybe some configuration option?
Anyway, don't worry too much about this, it is a minor issue.
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
One thing I forgot to mention:
As I build system, I also do full backups with Clonezilla.
Clonezilla now first tests drives for errors with fsck, then clones disk, then checks image for 'restorability'.
Everything went fine, in other words, the Debian live system Clonezilla uses, sees the drive and mounts it.
That is why I know that it is possible.
My last resort would be to have mounting script run on startup, but last time I tried that kde crashed so bad that I had to delete script from console.
I know the ideal thing would be to have a RAID system with FreeNAS, but the problem for that is $$$.
Back to top
SOLVED!
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
The solution could not be easier in KDE.
System settings -> Hardware -> Removable Devices -> Configure automatic handling of removable media -> check enable automatic handling of removable media.
Reboot, done!
Out of the box, no fstab, no ntfs-3g, just the Linux kernel handling of NTFS.
Round of applause to developers.
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
Forgot to mention, you must hit Apply to save settings, before rebooting.
Then you can reboot to test, everything should work, it's just a system setting.
My next step is to scrub fstab from all entries regarding removable media, and to see if I can mount my internal NTFS drive on boot without using ntfs-3g, I have read somewhere that you can set it as rw (read-write) without any need of ntfs-3g.
If so, will purge my system of ntfs-3g and the Device Manager GUI, not needed, the latter error-prone.
Will post results here.
Back to top
Display posts from previous:   
Page: Previous  1, 2
All times are GMT - 8 Hours