Page: 1, 2  Next

Long delays loading apps, open files, etc Kernel 2.6.36-1.dm
cowonjolt
Status: Interested
Joined: 03 Sep 2010
Posts: 13
Reply Quote
Have been running a Debian 2.6.32-5 kernel and installed the latest Liquorix yesterday and noticed immediately that there is an extensive delay when starting an application or opening a file... like 15 to 20 seconds delay. Am running Debian Sid OS with Kde Plasma desktop 4.5. Machine is a 2.6 Celeron w/2g mem, If for instance I start Dolphin the app appears immediately but starting a video or opening a file encounters the long delays. Any ideas appreciated.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4043
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
I expected to see some bug reports coming due to some major changes just enacted, looks like you're the first.

Please post specifics, which kernel exactly was it?
Back to top
cowonjolt
Status: Interested
Joined: 03 Sep 2010
Posts: 13
Reply Quote
kernel is > linux-image-2.6.36-1.dmz.4-liquorix-686/unknown uptodate 2.6.36-19

I think it might have to do with my Celeron processor because I got an error message during a wait that referred to a buffer overflow and another referring to attempting to access a duel core that failed. I checked my dpkg & syslogs but not finding anything that stands out yet. An example is that just now before my reply I decided to start Dolphin and check some files first before my reply...Dolphin started immediately and the up arrow took me straight where I wanted but upon cliking the var folder I got a good 10 second delay for it to open. I would first suspect my aging hardware but I don't experience the delay with the other kernels I have installed including the mepis version of 2.6.36 kernel I use with their 11.0 alpha repos... the mepis 2.6.36 is however crash happy which I have NOT experienced with this new Liquorix one. This delay issue is the only setback so far. It's probably not important but I'll mention I did try the openSUSE live cd with 2.6.37 kernel and experienced no delays running from the cd.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4043
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
that sounds like exactly the type of bug that initial testers / devs of the new stuff would never have tested for since they all run multi-core machines.

This type of undesired delay during action x or y seems to be the most typical bug/issue with these new kernel optimizations, I find them all the time too as soon as I depart from the behaviors that the average devs do, ie, as soon as I use my system for something they don't use it for.

Once damentz arrives he'll probably ask for some more information to help debug the issue.
Back to top
cowonjolt
Status: Interested
Joined: 03 Sep 2010
Posts: 13
Reply Quote
just read a post on ml forum from danum to stevo about delays in video thumbs in dolphin where he suggested this as a fix... a known problem in dbus, which is 1.2.24-3 in both unstable and sid, the problem is fixed by installing dbus and dbus-x11 from experimental, 1.4.0-2. I enabled experimental, updated and tried to install the newer dbus but the package is not found... started synaptic and checked also...not found. If no replies here I'll pm danum about it. Thanks, coj
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4043
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
You have to explicitly install experimental packages, they don't appear in the standard apt pool, like: apt-get install -t experimental <package>

However, I'm not very sold on that being the problem.

Unless of course dolphin is the only app it happens with, but looking for a second core in the error really seems to exclude that.
Back to top
cowonjolt
Status: Interested
Joined: 03 Sep 2010
Posts: 13
Reply Quote
to follow up ... it was in debian experimental not experimental snapshots. I did install the update but after testing I get the same initial delay with the newer dbus.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4043
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
yes, these delays are to me symptomatic of the various kernel tweaks/optimizations, I see artifacts from those all the time, especially on 2.6.36, which I'm considering myself just not using for a while until these tweaks get a bit more reliable and stable. There's a reason smxi offers previous kernels I consider stable, and why liquorix kernels offer their 'past' branch, though warning, the past branch contains some suspect optimizations which the smxi 2.6.35 does not contain.

I see the lags, by the way, on large nfs file transfers, the kernel simply forgets about them for a while, then suddenly remembers again.

I haven't tested the latest though, but I have to do production work on this desktop so I can't run kernels that might fail in a random way at a random time.

But the more testers who provide feedback on the current liquorix the better, that's how they get better and debugged.
Back to top
aus9
Status: Assistant
Joined: 21 Sep 2008
Posts: 358
Location: Australia
Reply Quote
hi

I am willing to test just let me know what logs you need etc

The following is a lie

:: Code ::
System:    Host sid Kernel 2.6.36-1.dmz.4-liquorix-686 i686 (32 bit) Distro sidux 2010-01 Ύπνος - xfce - (201006131622)
CPU:       Dual core Pentium E5200 (-MCP-) cache 2048 KB flags (lm sse sse2 sse3 ssse3) bmips 9975.8


it was once a sidux but all sidux removed using apt-get and its LXDE not XFCE but that was my original install cd.

2) I am getting a hang but only on running flashplayer online jigsaws which IMHO is unrelated to the kernel.

I can navigate thru the file manager normally but I have no KDE apps either.

3) Sometimes I have a hang with the idiot in front of the PC heh heh


cowonjolt

Just to eliminate an easy one, can you post your df stats pls in case one folder/partiton is full?
Back to top
cowonjolt
Status: Interested
Joined: 03 Sep 2010
Posts: 13
Reply Quote
aus9, right on the money... my /home partition is 95% full !. I'll do some much needed sorting and moving and try again at 50% or less. Thanks for pointing that out.
Back to top
Display posts from previous:   
Page: 1, 2  Next
All times are GMT - 8 Hours