Page: 1, 2  Next

X (kdm) dies often on bootup
reiner
Status: Contributor
Joined: 28 Jul 2009
Posts: 119
Location: Germany
Reply Quote
While this is not completely new but rarely happened on kernels before it seems to be more common now with the 2.6.36-0.dmz.2 kernel.
During the boot-process kdm dies. Logging in on a console as root and restarting it with /etc/initd.d./kdm restart brings it up again.
I am using the newest Nvidia-driver (260.19.12).

regards

Reiner
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 931
Reply Quote
Too many things broke in the 260.* series. I can't even boot up as my screen is not detected.

Check the nvnews forum for yourself -> www.nvnews.net/vbulletin/forumdisplay.php?forumid=14
Back to top
reiner
Status: Contributor
Joined: 28 Jul 2009
Posts: 119
Location: Germany
Reply Quote
Thanks for the info !

regards

Reiner
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4043
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
by the way, this could be simply an order priority, by chance kdm died today on boot, that never happens, but it did today, and I just logged in as root, restarted kdm, and it was fine.
Back to top
reiner
Status: Contributor
Joined: 28 Jul 2009
Posts: 119
Location: Germany
Reply Quote
Well, so it does here. But it might disappear. Too early to say for sure but I didn't have that since yesterday with the newest kernel.

regards

Reiner
Back to top
reiner
Status: Contributor
Joined: 28 Jul 2009
Posts: 119
Location: Germany
Reply Quote
Well,
with kernel 2.6.36-1.dmz.1-liquorix-amd64 I have it now constantly on each reboot.
I changed the start-order in rc5.d so that kdm is started as last task in that runlevel but that doesn't help.
The message that kdm writes into the syslog is: X server startup timeout, terminating.

Even as it currently is occuring on each boot I donot really think that the kernel itself is the problem. The message from kdm indicates that there might be some timing problem when the kernel is booting up and kdm is started the first time.
When started the second time via /etc/init.d/kdm restart it alway comes up and is starting X.
Does someone know how the value for the timeout in for X in kdm could be raised ? It might be able to cure the problem.

regards

Reiner
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 931
Reply Quote
Can you try 2.6.36-1.dmz.3 or newer? I recently fixed another scheduler related bug with Vincent here on the forums on the newest kernel.
Back to top
reiner
Status: Contributor
Joined: 28 Jul 2009
Posts: 119
Location: Germany
Reply Quote
Will do so today and post results then.

regards

Reiner
Back to top
reiner
Status: Contributor
Joined: 28 Jul 2009
Posts: 119
Location: Germany
Reply Quote
Hallo again,
unfortunately the new kernel didnot solve or improve on this issue. It still constantly fails to start X on boot-up and requires /etc/init.d/kdm restart. After that X-Windows just runs fine.

Could it be that it is caused by this:
    Debian Bug report logs - #524751
    KDM timeout is not sufficient for parallel boot

please see:
bugs.debian.org/cgi-bin/bugreport.cgi?bug=524751
I try to experiment with the timeout-parameter mentioned in there for kdmrc

regards

Reiner
Back to top
reiner
Status: Contributor
Joined: 28 Jul 2009
Posts: 119
Location: Germany
Reply Quote
Well,
I wrote, as suggested in that link, into /etc/kde/kdm/kdmrc:
:: Code ::
 [X-*-Core]
    ServerTimeout=120

and it works for me now.

It might well bee that this issue will be solved when kde 4.5.4 is available for debian. I will try then again without this parameter.


regards

Reiner
Back to top
Display posts from previous:   
Page: 1, 2  Next
All times are GMT - 8 Hours