Chaintech av710 Linux kernel 2.6.22 alsa 1.0.14
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4043
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
I read some interesting reviews about the chaintech av710, specifically about the wolfsen DAC output chip, which was supposed to have excellent sound quality. Considering that the chaintech only coast about US $25, this is an astounding deal, if you can get the stuff working.

:: Quote ::
For the longest time, computer audio seemed to be doomed. Creative was pretty much the only available card without spending hundreds. Turtle Beach and Hercules were players, but small ones, and they didn't have the greatest game support. Then, along came the M-Audio Revolution. Great, people thought, now we can have 24/192 support for under $100. Sure, it didn't have the greatest game support compared to Creative's offerings, but for the audiophile on a budget, this was as as close to heaven as you could get. And then, the Chaintech AV-710 came out. Envy24HT based chip, the same as the Revo, 24/192 support, 7.1 card, and all for $25. The Revo uses a Asahi-Kasei AK4381 DAC, whereas the AV-710 uses a Wolfson WM8728. (Note these both only apply to 2-channel mode. The surrounds use lesser DACs) The AK4381 has a 108dB SNR, opposed to the WM8728's 106dB SNR. I highly doubt you'll notice any difference between these two, but still, for the anal amongst us, (GUILTY!) the difference is there. They are both 24/192 capable chips, however. In any case, this card was an answer to prayer. Finally, high quality PC audio was available to the masses, and with a price tag like that, no one could ignore it. head-fi.org review

Getting the Chaintech av710 running on your linux box
Getting the output from the black rear surround speakers proved to be fairly hard, until I found this head-fi.org thread.

There is a sample asound.state file made by www.vandemar.org - that will save you a huge amount of headache.

Note that in Debian systems, this file is located here /var/lib/alsa/asound.state in your system, so you simply mv / rename your old one, and create a new one using that. In other systems, I think fedora etc, the file goes to /etc/asound.state

This is tested and working in 2.6.22.1 with Alsa 1.0.14

I will try to keep this thread up to date as new Alsa releases come out, and newer kernels, to see if it still works.

My base system is debian sid based sidux kept up to the latest sid packages.

To do this, simply create a new asound.state file with the contents of the above file, save in the appropriate location, run: alsactl restore

If you get no errors, it probably worked, start alsamixer ( the non gui version), if you see slider 1 master, slider 2 pcm, and both set to 48%, it's worked.

Make sure that the black output jack next to the optical output is working, that's the one with the wolfsen dac chip output.

This procedure is for stereo output only, to a power amplifier.

Also note this head-fi.org chaintech thread

More good stuff here: htpcnews.com/forums/index.php?showtopic=3616 (problem with site last I checked)

Buy the Chaintech at newegg

If you have a decent sound system, you will hear the difference between this output and motherboard sound no problem.
Back to top
LonelyToaster
Status: New User - Welcome
Joined: 29 Oct 2007
Posts: 1
Reply Quote
Thanks for the above guide - I just managed to get mine working, however I had another problem I had to correct.

When I did alsactl restore it appeared to not load some of the info from the file as my existing controls were in a different order with differents names from the file.

I'm currently using ubuntu gutsy 7.10 for reference.

To fix this I had to make alsa load from scratch with only that asound.state file... to do this:

1) Stop all processes using the driver module (try 'lsof /dev/snd/*' to help track down rogue processes that might be using the modules)

2) Stop alsa (not sure if this is needed here) 'sudo invoke-rc.d alsa-utils stop'

3) Stop the module 'sudo modprobe -r snd_ice1724'

4) Copy over the new asound.state file to /var/lib/alsa/asound.state (make a backup of the old one first just in case!)

5) Restart the module 'sudo modprobe snd_ice1724'

6) Restart alsa 'sudo invoke-rc.d alsa-utils start'

7) There may or may not be an error here... but if things work properly as techAdmin said the master and pcm volume controls will be on 48. Run alsamixer to check this and put the Surround/Center and LFE (this is the one you really want!) up to a decent volume and unmute them with 'm'

Hopefully that should fix any problems with ubuntu systems though there seem to be a million different problems that each require their own peculiar fix :S
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4043
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
To update this:

For true debian systems, no sudo, use su, root mode that is:

2) Stop alsa (not sure if this is needed here): /etc/init.d/alsa-utils stop

3) Stop the module: modprobe -r snd_ice1724 (or whatever sound chip is giving you problems)

5) Restart the module: modprobe snd_ice1724

6) Restart alsa: /etc/init.d/alsa-utils start

Otherwise things should work. With kde, if system sounds uses alsa, modprobe -r ... will turn off kde, so make sure it's not using it first. Or you can skip that step, I found that works fine for me on my system.
Back to top
Display posts from previous:   

All times are GMT - 8 Hours