regaining mime type control with mozilla-player and firefox
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4075
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
The title says it all.

So here's what I'm finding. As you've noticed already, which is probably why you are here now, when you install mozilla-mplayer, it grabs control over all mime type handling in Firefox. And since the firefox download manager gives you next to zero control over default mime type handling behaviors, you appear to be stuck.

Before I go on, I want to make VERY CLEAR that this problem is a direct result of bad decisions made by the Firefox developers. What should be in the default action download handler is a list of all mime types, and an option to add new ones, and so on. There isn't. Even when you set a default external application, half the time Firefox doesn't even show that.

But enough about Firefox and how lame they are getting in recent times.

So the problem is, you want to view embedded video on web pages as usual, probably using mozilla-mplayer, which works fine, but also takes over all other mime handling, which means stuff you don't want it to handle also is taken.

To undo this involves a bunch of VERY USER UNFRIENDLY [got that mozilla.com?] steps, none of which a normal user should be expected to know how to do. And none of which would be necessary if Firefox included a real mime type handler, which I think it used to have.

First, find the file:

/etc/mplayerplug-in.conf [or some other path, this is for debian based systems]

Change
#use-mimetypes=0
to
use-mimetypes=1

This will return control to the Firefox.

next, you may need to comment out the lines in

/etc/mplayerplug-in.types

that refer to the mime types you want firefox to handle:
application/x-ogg:ogg:Ogg Vorbis Media;
audio/ogg:ogg:Ogg Vorbis Audio;
application/ogg:ogg:Ogg Vorbis / Ogg Theora;
for example these three handle ogg format, if mplayer plugin insists on opening when you try to play an ogg file instead of your preferred media player, comment those out.

You'll also need to rename or delete this file to make firefox reset the default plugin handlers:

/home/<username>.mozilla/firefox/pluginreg.dat

Do this when firefox is closed.

Also, if you want to reset all the firefox defaults, delete or rename this file:

/home/<username>/.mozilla/<current user profile, usually something like: alkjr3to3e.default>/mimeTypes.rdf

Firefox will just make new versions of both when needed.

That's it. How's that for 'user friendly'. At some point the mozilla developers are going to have to wake up and stop maintaining that any advanced configuration is in any way remotely user friendly, let alone useable. Then they'll have to add back in the stuff they removed.

Remember, none of this would have been necessary if firefox had a built in real mime type handler. That lets you add OR remove mime types. The current version only lets you remove them, and doesn't even show most mime types it handles anyway. It's broken, that is. And has been broken for quite a while.

Unfortunately, the current crop of mozilla firefox developers have started using a fairly tiresome refrain of: that's not broken, that's a feature to avoid taking responsibility for these totally user unfriendly options.

And there is no extension that does this that I can find, the closest is about half way return, but does not fully work with mozilla-mplayer plugin, or anything else. But at least it does show the supposed mime type handlers.

Ok, hopefully this will answer this question for someone out there, who is having the same problems I've been having trying to create a workable multimedia experience on especially Linux firefoxes.

Again, please, mozilla developers, wake up and start pushing some limits, don't shut down all control of your browser. Learn how to use 'advanced' options in your gui configurations, don't cut out critical core functionality that is needed to run your damned browser day to day.

I know it's hard to admit that a decision is wrong, especially when it's this wrong, but at some point you have to make this stuff work again, so why not sooner than later?
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4075
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Fix for dialogue box:

:: Quote ::
Get Windows-like "save" dialog window in Firefox

As root, you'll need to edit a file in the components directory in Firefox/Thunderbird install folder. You'll need to navigate to the folder in /usr/lib that corresponds to your current version of Firefox and/or Thunderbird and then from there to to the components folder. For instance, if you're using Firefox version 1.5.0.7, simply navigate to /usr/lib/mozilla-firefox-1.5.0.7/components. The same goes for Thunderbird. The following steps apply to both Firefox and Thunderbird-

[note: in debian, the path will be /usr/lib/firefox/...]

Open up the nsFilePicker.js file with your favorite text editor. Now, find this set of lines:

compMgr.registerFactoryLocation(FILEPICKER_CID,
"FilePicker JS Component",
// *really long comment here*
"",
// *really long comment here*
fileSpec,
location,
type);


and change it so it looks like this:

compMgr.registerFactoryLocation(FILEPICKER_CID,
"FilePicker JS Component",
// *really long comment here*
FILEPICKER_CONTRACTID,
// *really long comment here*
fileSpec,
location,
type);


**IMPORTANT** Edit: To make this change take effect you have to reset the chrome registry in Firefox/Thunderbird.

The easiest way to do this is:

Firstly, make sure Firefox/Thunderbird is closed. Then, in Konqueror, navigate to the profile directory in your home folder (/home/yourusername/.mozilla/firefox/yourprofilename.default)

Once in your profile folder, delete the files xpti.dat and compreg.dat. These will be re-created once Firefox/Thunderbird are restarted.

Re-open Firefox and/or Thunderbird and test it out. Someone in the PCLinuxOS.com forum posted the info above: www.pclinuxos.com/forum/index.php?topic=10559.0

kanotix.com/PNphpBB2-viewtopic-t-21731.html
thanks craigevil
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4075
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
And one last one, getting Firefox to support mms protocol, yet another vile Microsoft creation.

:: Quote ::
(1.) Open Firefox, type "about:config" (no quotes) in the address window, and click enter.
(2.) Right click on the window and choose <New>, then <String> from the pop-up menu that appears.
(3.) In the first pop-up box, enter: "network.protocol-handler.app.mms" (no quotes, and it might just be easier to cut 'n paste this into the box).
(4.) In the next pop-up box enter the path to Kaffeine (e.g. "/usr/bin/kaffeine").
(5.) Now, click in the main window again but choose <New> <Boolean>
(6.) In the first pop-up box, enter: "network.protocol-handler.external.mms"
(7.) In the second pop-up select <True>.

and that should do it. Why do we need to do this cr#p just to get a browser to do its job correctly? I don't know, ask the whiz kids over at Firefox, I'm sure they can rationalize this for you the same as they rationalize away all their other stupid gtk inspired idiocies.

and more here, to do rtsp protocol junk.

:: Quote ::
For rtps the procedure is the same:
Firefox --> about:config --> rightclick --> new --> string --> network.protocol-handler.app.rtsp --> /usr/bin/X11/realplay

Firefox --> about:config --> rightlick --> new --> boolean --> network.protocol-handler.external.rtsp --> true

And some on kplayer and mms here
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4075
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
:: Quote ::
All of that is supported by KPlayer. Embedding in Konqueror and KMLDonkey has been supported since 0.4, and rtsp:, mms: and pnm: protocols since 0.5.

Have you installed from source or some kind of binary package?

You can look for a mms.protocol file under the global services directory, like /usr/share/services or similar. If it was installed correctly, it should have a line like exec=kplayer '%u'. Also make sure that there is no local mms.protocol under ~/.kde/share/services

For the embedding part, check for a kplayerpart.desktop file under the same global services directory, and also libkplayerpart.la and libkplayerpart.so files under the KDE lib directory, like /usr/lib/kde3 or similar. Of course you should also have KPlayer at the top of the list on the Embedding tab in File Associations for each MIME type you want it to play in Konqueror. kde-apps.org

Read more on embedded kplayer here

What's that you say? Am I giving up on Linux Firefox? Yes, I'm getting very close, I think that their obsession with making lots of money via their windows and google deals is making their Linux development increasingly hopeless.

Konqueror already has radically superior, in every way pretty much, mime type handling, so maybe it's time to start spending some debugging time with a browser that there is actually some hope for, not one that loses more and more core features every release.
Back to top
Display posts from previous:   

All times are GMT - 8 Hours