Firefox :: Linux desktop switching bug, full : partial crash
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4076
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Firefox crashes on desktop switching in kde

SOLUTION
This package: gtk2-engine-gtk-qt was the direct cause of the issues on my debian sid based system. However, I also found during the debugging procedure that Firefox from debian was substantially less stable than the gzipped firefox package direct from Mozilla, so I moved to the standard firefox.

The problematic nature of this package, which is supposed to make gtk applications like firefox work more smoothly with qt + kde was confirmed to me by the Kanotix developers, who had discovered the same thing over the last year.

So if you are experiencing this issue, remove this package and just use the standard kde stuff to run your gtk packages.

By the way, the solution listed below, just adding a theme to firefox, did in fact work one time, but I couldn't get it to work again, same type of gtk errors on startup. Removing the qt gtk engine solved the issues for me.

History of bug
I found one comment at kubuntu, still unresolved.

:: Code ::
Distro: kanotix 200504: fully dist-upgraded to latest xorg and kde, newest kernel.
kde: 6 desktops, hidden transparent taskbar top left, non-hiding tranparent middle, non-hidden transparent left.
KDE is set to show windows from current desktop only.
Include list of firefox extensions used.

I have had the firefox crashing issue on 3 different machines, all kanotix debian sid, all with kde 3.5. Note that below the kubuntu user first saw the issue with kde 3.4 move to 3.5. Was stable in 3.4 that is. Some machines are worse than others, seems to depend on how much desktop eye candy is run, and on certain extensions.

I'm using the latest adblock plus, and have had failures on firefox installs with only allinone mouse gestures and adblock plus. I've also had failures with only allinone mousegestures installed, though it takes longer for the crash to happen.

When it happens, the crash is ALWAYS caused by desktop switching. I have never had firefox crash, no matter what extension, how many tabs, whatever, as long as I don't switch desktops. It appears to be some conflict between gtk and qt windowing, but it's very hard to say for sure.

Replacing the debian firefox with the mozilla.com gzip download made firefox significantly more stable, by a factor of several times, but I've still managed to make it crash.

If you have experience with this, and have not found a resolution, please post a detailed response in this thread. Include which kde version you are running, which distro, which distro version number, how many desktops, configuration of desktops, aka:
all same color backgrounds, image backgrounds, different backgrounds each desktop, panels [taskbars] default position or custom, transparent, hiding, etc. Anything you've done differently. Also if you have this issue on gnome too I'd like to hear about it.

I have been unable to find any meaningful documentation on this issue, but its very annoying.

A very cryptic one at gnome.org. Next in thread offered this:
:: Quote ::
gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders

Seemed to fix the problem. I'll have to add that command to my RPM packages.

and ximian mono had this:
:: Quote ::
I've seen this sort of a trace with someone who had a gtk+ theme that didn't have some of the necessary icons. You might try stracing this and seeing which file(s) it's failing to open.


and more from mozillazine

:: Quote ::
I (kinda) figured it out - it was a permissions issue. I don't remember the exact message, but running firefox (or thunderbird) trunk [freshly untarred] in a terminal window produced an error message regarding permissions. I su'd and ran it as root, and it worked fine; thereafter, they both run fine as normal users.


Note: the Firefox console error output when you open it with sux <password> firefox is this:

:: Code ::
(Gecko:2057): Gdk-CRITICAL **: gdk_pixbuf_get_from_drawable: assertion `gdk_window_is_viewable (src)' failed

(Gecko:2057): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_n_channels: assertion `pixbuf != NULL' failed

(Gecko:2057): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_bits_per_sample: assertion `pixbuf != NULL' failed

(Gecko:2057): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion `pixbuf != NULL' failed

(Gecko:2057): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion `pixbuf != NULL' failed

(Gecko:2057): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_rowstride: assertion `pixbuf != NULL' failed

(Gecko:2057): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

The above fix did not change that. This error repeats for each new open window tab, by the way. The above is for the blank default opening, in my case on a blank window.

Possible solution: remove gtk or install a custom theme for firefox

:: Quote ::
i kinda solved it... i completely removed gtk2-engine-gtk-qt and now i stll have the kde appearence in my gtk apps and everything works now.

It may be useful to you to know that this isn't a Mepis-specific issue. I am currently using Kubuntu 5.10 with Firefox 1.5 . The trouble appears to be something in the way Firefox handles themes, and someone in an Ubuntu forum pointed out that if you install and use a Firefox theme, it fixes the problem. I found that if you do this you don't have to remove gtk2-engine-gtk-qt . You can go back and reinstall it if you removed it, and Firefox will work without a hitch. mepis lovers forums

Back to top
Display posts from previous:   

All times are GMT - 8 Hours