Page: 1, 2  Next

[RESOLVED] Full Preemption causing problems
mhalano
Status: Interested
Joined: 31 Dec 2022
Posts: 10
Reply Quote
I saw in kernel 6.1.0-1.2 dynamic preemption was disabled, instead using full preemption instead. I don't know why this was done but I got a couple of problems with that: First my Firefox stop loading tabs correctly. I have plenty of tabs open but unloaded and Firefox couldn't even load the pinned tabs. Also I was playing a game on Steam (Death Stranding Director's Cut) and the load time was impossible. I could solve both cases when I started my machine using the native kernel (I'm Ubuntu 22.10 user) since this kernel uses dynamic preemption. I also don't have this problem forever, so I won't think is related to kernel version, but I will start kernel 6.1.0-1.1 that still dynamic preemptive and I will let you know.
Back to top
mhalano
Status: Interested
Joined: 31 Dec 2022
Posts: 10
Reply Quote
I booted my machine with kernel 6.1-1.1 (that has dynamic preemption) and Firefox and the game both loaded in an acceptable time.
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 1034
Reply Quote
Interesting, disable dynamic preemption shouldn't make a difference, it just removes the indirection that allows for you to choose between full, voluntary, and no kernel preemption. Disabling dynamic preemption was more of an optimization and to prevent distributions from switching preemption without the users knowledge.

I can restore it for the next release since it's the optimization is not something you can really measure.
Back to top
mhalano
Status: Interested
Joined: 31 Dec 2022
Posts: 10
Reply Quote
I think that is a good idea. Ubuntu default kernel uses dynamic preemption instead of full preemption.
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 1034
Reply Quote
Did the latest release resolve your issue?
Back to top
mhalano
Status: Interested
Joined: 31 Dec 2022
Posts: 10
Reply Quote
Happy new year everyone!

Today I tested and everything (Firefox and game loading) worked as expected. Thank you.
Back to top
mhalano
Status: Interested
Joined: 31 Dec 2022
Posts: 10
Reply Quote
I enabled manually full preemption (via a kernel cmd line parameter) and made some changes, like close most of the tabs of my browser (more than 4.9k tabs). Firefox is now responding correctly. The game loads a little slow, but may could be my system for some reason. If you don't mind, I will use full preemption enabled for sometime to check if everything is ok. As far as I could research, full preemption should help in the responsiveness of the system.
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 1034
Reply Quote
Just to be clear, Liquorix defaults to full preemption. Make sure when you're testing you know what type of preemption you're on:

:: Code ::
$ journalctl -k | grep -Po -i 'Dynamic Preempt.*'
Dynamic Preempt: full


You can reduce the default and responsiveness of your system with preempt=voluntary or preempt=none, but you won't increase it since the default is full

The configuration I change is effectively a no-op, as in nothing should have changed for you. The only thing I can think of is the dynamic preempt code that was synced from mainline into Project-C could have been buggy and only works correctly when CONFIG_PREEMPT_DYNAMIC is enabled in the config.
Back to top
mhalano
Status: Interested
Joined: 31 Dec 2022
Posts: 10
Reply Quote
I set with `preempt=full` in kernel cmd line. So that's do nothing since that's already the configuration. Now I wonder why dynamic preemption is different from a regular preemption since both are full, but one work and the other doesn't.
Back to top
mhalano
Status: Interested
Joined: 31 Dec 2022
Posts: 10
Reply Quote
The dynamic preemption is the possibility to define preemption on boot via parameter. Strange that option is necessary for responsiveness.
Back to top
Display posts from previous:   
Page: 1, 2  Next
All times are GMT - 8 Hours