Tray icons not displaying in 5.18.0-10.1 and 5.18.0-9.1
GodlessHeathen
Status: New User - Welcome
Joined: 07 Jul 2022
Posts: 1
Reply Quote
I started using Liquorix with kernel 5.18.0-7.4 and after upgrading to 9.1 I noticed that tray icons for apps are no longer displaying. I upgraded to 10.1 and the tray icons are still not displaying. So I've downgraded back to 7.4.

I have 3 apps that load upon boot and remain in the background and have tray icons but no longer display with the 2 newest kernels. Same goes for any apps manually loaded after boot, such as Steam.

I'm using Linux Mint 20.3

inxi -bxx:
:: Code ::
System:
  Host: me Kernel: 5.18.0-7.4-liquorix-amd64 x86_64 bits: 64 compiler: N/A
  Desktop: Cinnamon 5.2.7 wm: muffin dm: LightDM Distro: Linux Mint 20.3 Una
  base: Ubuntu 20.04 focal
Machine:
  Type: Desktop System: ASUS product: N/A v: N/A
  serial: <superuser/root required>
  Mobo: ASUSTeK model: TUF GAMING B550-PLUS v: Rev X.0x
  serial: <superuser/root required> UEFI: American Megatrends v: 1202
  date: 10/22/2020
CPU:
  6-Core: AMD Ryzen 5 3600XT type: MT MCP arch: Zen speed: 2196 MHz
  min/max: 2200/3800 MHz
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: eVga.com. driver: nvidia
  v: 470.129.06 bus ID: 08:00.0 chip ID: 10de:1b81
  Display: x11 server: X.Org 1.20.13 driver: nvidia
  resolution: 2560x1080~60Hz
  OpenGL: renderer: NVIDIA GeForce GTX 1070/PCIe/SSE2
  v: 4.6.0 NVIDIA 470.129.06 direct render: Yes
Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
  port: f000 bus ID: 07:00.0 chip ID: 10ec:8125
  Device-2: Realtek 802.11ac NIC type: USB driver: rtw_8822bu bus ID: 3-3:3
  chip ID: 0bda:b812
Drives:
  Local Storage: total: 2.09 TiB used: 1.51 TiB (72.1%)
Info:
  Processes: 366 Uptime: 43m Memory: 31.27 GiB used: 3.38 GiB (10.8%)
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.4.0 alt: 9
  clang: 10.0.0-4ubuntu1 Shell: bash v: 5.0.17 running in: gnome-terminal
  inxi: 3.0.38

Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4073
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Since you are using nvidia non free, it's not any free driver issue, so it can't really be related to liquorix except for latest liquorix triggering an issue in the non free nvidia driver.
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 975
Reply Quote
Since 5.18.0.7.4, the only other change I've made is enabling O3 optimizations: github.com/damentz/liquorix-package/releases/tag/5.18-7

Most likely Cinnamon has a race condition where things are loaded out of order, and the order things load is implicit and depends on the scheduling behavior of the kernel. What's not helping is the out-of-tree binary driver for nvidia, but I don't think it's the cause. You can always verify by switching back to nouveau (although the process is arduous and error prone to flip back and forth).

I recommend you submit an issue with the Cinnamon team, it's most likely something in their code that's causing this issue. And remember, you may be able to work around the issue by force reloading Cinnamon's interface, although I don't know what kill + code execution invocation will look like. On KDE for example, when turning on and off monitors, the desktop sometimes forgets what's going on, so killing and re-executing plasma-desktop gets me back to normal.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4073
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
damentz, technically the process to flip band forth from free to non free graphics driver was supposed to be handled seamlessly in sgfxi, but I largely dropped development of that except for driver updates, but if I get super bored one day, I may try to fix it, though I don't run any nvidia systems anymore so it's a bit harder.

I know where the failure is in sgfxi, it's just not updating the grub config then running update-grub as it should, but it's actually quite easy to do this switch, I just haven't felt like spending the time to make it work. And that would only apply to debian/apt based systems anyway.

But its' actually quite easy to do if it's scripted, it's only about 5 or 6 steps roughly if it's not scripted, but it's hard to get people to understand those steps I found.

I used to test sgfxi by switching endlessly between free and non free drivers, it was a core feature, but it just needs updating.

I don't really want to support sgfxi or its users, but it might be worth one day just fixing that failure I think, I think I have enough debuggers running in there, and fake data switches, where I can maybe emulate nvidia, not sure, but it's much easier if I run nvidia, but I'm not buying anymore nvidia cards so I'd have to be able to figure the issue out by just reading the code and ideally having someone who still has a current nvidia card, or at least, 470.xx driver legacy series or current test it.

I have to say though, when I downloaded to get a text file the latest nvidia 515.xx driver, I was shocked and dismayed to see it coming in at over 300 MiB in size, that's absurd, I don't even want to know what they are doing there, it's like 3x larger than the entire linux kernel.
Back to top
Display posts from previous:   

All times are GMT - 8 Hours