Correct config for sgfxi for Ubuntu with Liquorix kernel and Intel UHD Graphics 620
andreas1107
Status: Curious
Joined: 27 May 2022
Posts: 5
Reply Quote
Hi,

I recently ran sgfxi (4.26.73) to try to optimise graphics performance. The script ran OK and changed my xorg.conf from empty/nothing to:

:: Code ::

Section "Device"
        Driver  "intel"
        #BusID "PCI:0:2:0"
        Identifier "Device0"
EndSection

Section "Extensions"
#       Option      "Composite" "disable"
#       Option      "RENDER"    "disable"
EndSection


I tried to also install smxi and run sgfxi via smxi -kiwdt as described on the site but it says my Ubuntu distro is not supported by smxi.

However since the script ran, some of my apps don't work. For example, Steam or Monero-gui. Another thing I notice is my desktop background has a bit of green random marks on it every time I boot up (but if I change desktop background, these marks disappear).

Has anyone had this experience? Is there any way to troubleshoot / improve what the script does to optimise it for this laptop?

Thanks!
Andreas


Output from sgfxi --debugger: https://nc.nl.tab.digital/s/FZSBcaZp3accTXn

:: Code ::

inxi -F
System:
  Host: andreas-ThinkPad-T490s Kernel: 5.17.0-5.1-liquorix-amd64 arch: x86_64
    bits: 64 Desktop: GNOME v: 3.36.9 Distro: Ubuntu 20.04.3 LTS (Focal Fossa)
Machine:
  Type: Laptop System: LENOVO product: 20NX002RUK v: ThinkPad T490s
    serial: <superuser required>
  Mobo: LENOVO model: 20NX002RUK v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: N2JET84W (1.62 )
    date: 01/03/2020
Battery:
  ID-1: BAT0 charge: 26.5 Wh (44.8%) condition: 59.2/57.0 Wh (103.9%)
    volts: 11.6 min: 11.6
CPU:
  Info: quad core model: Intel Core i7-8565U bits: 64 type: MT MCP cache:
    L2: 1024 KiB
  Speed (MHz): avg: 3806 min/max: 400/2001 cores: 1: 2120 2: 4042 3: 4098
    4: 4277 5: 4246 6: 4126 7: 4212 8: 3331
Graphics:
  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 1.20.11 with: Xwayland driver: X:
    loaded: intel gpu: i915 resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2)
    v: 4.6 Mesa 22.1.0 - kisak-mesa PPA
Audio:
  Device-1: Intel Cannon Point-LP High Definition Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.17.0-5.1-liquorix-amd64 running: yes
  Sound Server-2: PulseAudio v: 13.99.1 running: yes
Network:
  Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi
  IF: wlp0s20f3 state: up mac: dc:fb:48:34:44:6e
  Device-2: Intel Ethernet I219-V driver: e1000e
  IF: enp0s31f6 state: down mac: 98:fa:9b:86:52:98
Drives:
  Local Storage: total: 238.47 GiB used: 207.12 GiB (86.9%)
  ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 238.47 GiB
Partition:
  ID-1: / size: 231.49 GiB used: 206.7 GiB (89.3%) fs: ext4 dev: /dev/dm-1
  ID-2: /boot size: 703.1 MiB used: 430.6 MiB (61.2%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 511 MiB used: 5.2 MiB (1.0%) fs: vfat
    dev: /dev/nvme0n1p1
Swap:
  ID-1: swap-1 type: file size: 4 GiB used: 1018.4 MiB (24.9%)
    file: /swapfile
  ID-2: swap-2 type: partition size: 976 MiB used: 0 KiB (0.0%)
    dev: /dev/dm-2
Sensors:
  System Temperatures: cpu: 40.0 C pch: 40.0 C mobo: N/A
  Fan Speeds (RPM): fan-1: 0
Info:
  Processes: 355 Uptime: 3h 49m Memory: 7.59 GiB used: 3.77 GiB (49.7%)
  Shell: Bash inxi: 3.3.16

Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4070
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Just delete the xorg.conf file sgfxi created, you shouldn't have run sgfxi for intel anyway, that was useless.

sgfxi didn't really do anything, beyond maybe installing a missing intel xorg driver, so just delete the xorg.conf and restart x and it should be what it was before.

The moral here is not to use tools that you don't actually understand, the fact it was used for intel really had little point.

Note that also on ubuntu, sgfxi never gets tested, and I really would discourage use of sgfxi in general except to install nvidia drivers onto debian at this point, that's the only place that it gets any work or testing anymore.
Back to top
andreas1107
Status: Curious
Joined: 27 May 2022
Posts: 5
Reply Quote
Doing things I don't actually understand.. Story of my life. :-)
Hopefully this post can be helpful to anyone else on Ubuntu googling around for better gaming experience.

Removing xorg.conf worked, green marks are gone and apps start as normal. Thank you!
Back to top
Display posts from previous:   

All times are GMT - 8 Hours