Page: Previous  1, 2

Status: Curious
Joined: 26 Dec 2021
Posts: 6
Reply Quote
I figured it out. When installing a lowlatency kernel, Ubuntu puts a 09_lowlatency into /etc/grub.d. This disables the default 10_linux and only scans for lowlatency kernels. Mind you, there is no warning message that this takes place. Pretty dumb.

Can't tell for sure, but it looks like the 09_lowlatency script scans for lowlatency kernels by looking for "lowlatency" in the kernel filename. This might explain why the liquorix kernels don't register as low latency.

In case someone reaches this thread, my fix was to disable 09_lowlatency (chmod -x) and enable 10_linux (chmod +x), then update-grub. Clearly you need to have some non-lowlatency kernels installed for this to work. I suppose that upon removing all lowlatency kernels Ubuntu switches back to a generic kernel - that's what it did on my machine (at least Ubuntu doesn't let you completely remove all kernels....).

Been running a hefty Mixbus project at 48kHz with 10ms latency on this XPS 13 laptop for about an hour now; zero xruns. Totally impossible even at >30ms with the lowlatency kernel. Thanks Liquorix devs.[/b]
Back to top
Display posts from previous:   
Page: Previous  1, 2
All times are GMT - 8 Hours