Page: 1, 2  Next

Bullseye and Liquorix
ovitus
Status: New User - Welcome
Joined: 19 Aug 2021
Posts: 1
Reply Quote
I upgraded from Buster to Bullseye and changed the repository:
deb liquorix.net/debian bullseye main
deb-src liquorix.net/debian bullseye main

I tried installing the kernel but was met with a dependency error:

The following packages have unmet dependencies:
linux-headers-liquorix-amd64 : Depends: linux-headers-5.13.0-12.1-liquorix-amd64 (= 5.13-7.1~bullseye) but 5.13-7.1~buster is to be installed
linux-image-liquorix-amd64 : Depends: linux-image-5.13.0-12.1-liquorix-amd64 (= 5.13-7.1~bullseye) but 5.13-7.1~buster is to be installed
E: Unable to correct problems, you have held broken packages.

Is the the Liquorix kernel not ready for Debian 11 yet? I can change the repository back to Buster and install that, but that's not the OS version I'm currently on and could cause issues.
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 942
Reply Quote
It looks like I didn't properly update the symlinks for what testing, stable, and oldstable correspond to. I fixed that and also kicked out another build in-case that has any consequence.

But now looking closer at your post, I think you did something weird with apt-get. What happens when you run the standard command on the website? sudo apt-get install linux-image-liquorix-amd64 linux-headers-liquorix-amd64

Also the line below I think also means other issue are going on:
E: Unable to correct problems, you have held broken packages.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4051
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
That you have held packages error can be slightly deceiving, sometimes, I think usually, something else actually has held it.

To verify:
:: Code ::
dpkg -l | grep ^hi

if a package is listed, that needs to be explicitly unheld.
:: Code ::
sudo echo "package_name install"| sudo dpkg --set-selections


There's also a newer syntax for this which I'd never seen before:
:: Code ::
sudo apt-mark unhold $(apt-mark showhold)


that seems a bit more intuitive, I know for myself, I've never been able to remember the dpkg --set-selections thing without looking it up.
Back to top
kernel 5.14.x-xx.x start x failed
TuxNuX
Status: New User - Welcome
Joined: 11 Jan 2021
Posts: 4
Reply Quote
I am using MX 21 based Debian 11(Bullseye) and since the 5.14.x-xx.x kernels cannot start X, black screen and blinking cursor at the top left
Last post I got was "returned failure: plymouth FAILED!"
no problem with the 5.13.0-16.2-liquorix-amd64 kernel good work
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 942
Reply Quote
Hi TuxNux,

Can you boot with loglevel=7 added to your kernel parameters? This will reveal which kernel operation is possibly failing at boot.

Also, provide the output of inxi -b so we can better understand what type of system you have.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4051
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Sounds like graphics driver issue, user has to note what graphics they are using, if non free nvidia, would be a driver failure, that's usually what the blinking cursor means.
Back to top
TuxNuX
Status: New User - Welcome
Joined: 11 Jan 2021
Posts: 4
Reply Quote
I did as you told me

kernel log:
https://pastebin.com/9h23xVnP
inxi:
https://zupimages.net/up/21/38/ojxy.png

I good looked the start with loglevel 7
Back to top
TuxNuX
Status: New User - Welcome
Joined: 11 Jan 2021
Posts: 4
Reply Quote
I use the proprietary driver nvidia 460.91
I have this problem that since the versions of the kernel 5.14, never had this problem with the versions 5.13
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4051
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
If you're going to use proprietary nvidia, you have to learn how to do it, it's not a liquorix issue, educate yourself.

You can only sometimes use the current nvidia stable driver on latest kernels, you have to wait for their latest stable to support the next kernels, this isn't a liquorix issue.

Pick ONE:
1. your distro stable kernels running distro packaged and supported nvidia driver [BEST CHOICE FOR FROZEN POOL DISTROS]
2. Latest Liquorix not running nvidia {BEST CHOICE FOR LATEST LIQUORIX]
3. Latest Liquorix with LATEST nvidia driver for your card, but only latest liquorix that is supported by that nvidia driver. {WORKS, BUT NOT BEST CHOICE, since it's a pain keeping track of when a new kernel breaks nvidia driver]

Latest Liquorix AND out of date and obsolete nvidia [your setup] is NOT one of the choices.

MX and mint need to do a better job educating their users, though it's also not their problem, this issue has existed literally since the first nvidia linux driver and linux kernels met.

Second of all, you need to say when you are running a derived distro like MX, that can matter.

Third of all, you aren't even using the current nvidia driver, 470.74, you were trying to run the 460 series, no idea where you even get that, if it's a distro packaged driver, then you MUST use the distro packaged kernel, period, it's not the distro's fault if you don't do that, nor is it a liquorix issue.

If you are going to use non free modules it's your responsibility as a linux user to learn what that means, and how to deal with it, it's not other people's job to hold every single user's hand who has the same exact problem year after year, decade after decade, learn your system!!

Switch to amd video cards if you want to use latest liquorix reliably, use the amdgpu driver, and stop worrying about this game, which has never, and will never, end. Or intel gpu, on laptops.

GNU/Linux is NOT windows, or OSX, it requires learning some basics, if you don't like learning, then linux isn't for you, no matter how distros try to sell themselves, this applies in particular if you are trying to mix things that do not mix well, but if you stick with distro defaults, which they support, then you are going to have a much easier time in general, until you learn enough to do more advanced things.
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 942
Reply Quote
:: TuxNuX wrote ::
I use the proprietary driver nvidia 460.91
I have this problem that since the versions of the kernel 5.14, never had this problem with the versions 5.13


Yes, you can search online for nvidia 460.91 5.14 and find out very quickly it's incompatible with 5.14 and you must upgrade.

I don't want to repeat techAdmin, but there's a 4th choice:

4. Switch to a rolling release distribution based on Arch (Manjaro, EndeavourOS). The Arch Linux community very quickly patches DKMS based drivers to run on the latest versions of Linux. On anything Debian/Ubuntu based, there's no solution besides installing the driver directly from nvidia's website or using a custom script such as sgfxi. But ideally, you'd want proper distribution packaged drivers when they work since it makes everything seamless (which is why ideally you'd want to run something Arch based).

And last, this is a critique for MX Linux, since their users typically install custom kernels, they stand to gain a lot by packaging updated nvidia graphics drivers in their repository. You should suggest this to the team and see if you get positive feedback. It does mean more work for someone, but it's long overdue and a completely missing facet of the Debian ecosystem.

At least on Ubuntu you have the graphics driver PPA [1], but looking at it now, it's STILL out of date despite the purpose of providing the latest stable drivers from nvidia. The latest stable is 470.74 as of 5 days ago, but the latest packaged is 470.63. On Arch Linux, they packaged the updated driver same day. [2]

[1] launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
[2] github.com/archlinux/svntogit-packages/commits/packages/nvidia-utils/trunk
Back to top
Display posts from previous:   
Page: 1, 2  Next
All times are GMT - 8 Hours