[SOLVED] sgfxi hangs
DeepDayze
Status: Contributor
Joined: 21 May 2009
Posts: 115
Reply Quote
Hello:

The latest version of sgfxi seems to hang and not produce any logs when trying to update the nvidia driver. As a result the install does not run and now system can't reach the desktop as there was an Xorg update on Sid. Tried the debug option and no log was produced but output was showing "Using Perl 5.32" an htop showed some perl -e thing running some find files search and appears to be hung at that point.

Is the latest update of sgfxi broken and how can I downgrade it?

< Edited by DeepDayze :: Jan 7, 21, 15:52 >

Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4029
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Open up /var/log/sgfxi/sgfxi.log and paste the contents here.

that will show me where it hangs.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4029
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
As I feared, this is a Kate code editor bug, it's been doing this more and more recently, it just randomly iinserts characters that were in the desktop clipboard into the code I'm working on, with bash, which is very permissive of error, it doesn't cause a visible runtime error, but I've been having this issue with pinxi too, more and more, and it's almost certainly a Kate code editor bug.

Found the randomly inserted string and removed it.
Back to top
DeepDayze
Status: Contributor
Joined: 21 May 2009
Posts: 115
Reply Quote
Okay good you found it and now sgfxi works properly again. Thanks and marking this solved!
Back to top
Display posts from previous:   

All times are GMT - 8 Hours