Page: Previous  1, 2, 3  Next

NoXPhasma
Status: Interested
Joined: 21 Nov 2019
Posts: 14
Reply Quote
No, that was the first I tried, I installed linux-tools-common, but it won't work and tells me to get the correct one for this kernel:

:: Code ::
$ sudo perf stat -a sleep 5         
WARNING: perf not found for kernel 5.4.0-1.1

  You may need to install the following packages for this specific kernel:
    linux-tools-5.4.0-1.1-liquorix-amd64
    linux-cloud-tools-5.4.0-1.1-liquorix-amd64

  You may also want to install one of the following packages to keep up to date:
    linux-tools-liquorix-amd64
    linux-cloud-tools-liquorix-amd64

Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 796
Reply Quote
Try installing the perf tools for a different kernel and use that. You have many options to choose from: packages.ubuntu.com/search?searchon=contents&keywords=perf&mode=exactfilename&suite=disco&arch=any
Back to top
NoXPhasma
Status: Interested
Joined: 21 Nov 2019
Posts: 14
Reply Quote
I've done that as well, the latest available is for 5.3:

:: Code ::
$ sudo apt install linux-hwe-edge-tools-5.3.0-24
[sudo] Passwort für noxp:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden NEUEN Pakete werden installiert:
  linux-hwe-edge-tools-5.3.0-24
0 aktualisiert, 1 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 5.450 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 24,9 MB Plattenplatz zusätzlich benutzt.
Holen:1 http://ubuntu.unitedcolo.de/ubuntu bionic-updates/main amd64 linux-hwe-edge-tools-5.3.0-24 amd64 5.3.0-24.26~18.04.2 [5.450 kB]
Es wurden 5.450 kB in 0 s geholt (12,7 MB/s).           
Vormals nicht ausgewähltes Paket linux-hwe-edge-tools-5.3.0-24 wird gewählt.
(Lese Datenbank ... 436822 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../linux-hwe-edge-tools-5.3.0-24_5.3.0-24.26~18.04.2_amd64.deb ...
Entpacken von linux-hwe-edge-tools-5.3.0-24 (5.3.0-24.26~18.04.2) ...
linux-hwe-edge-tools-5.3.0-24 (5.3.0-24.26~18.04.2) wird eingerichtet ...

$ which perf
/usr/bin/perf

$ sudo perf stat -a sleep 5
WARNING: perf not found for kernel 5.4.0-1.1

  You may need to install the following packages for this specific kernel:
    linux-tools-5.4.0-1.1-liquorix-amd64
    linux-cloud-tools-5.4.0-1.1-liquorix-amd64

  You may also want to install one of the following packages to keep up to date:
    linux-tools-liquorix-amd64
    linux-cloud-tools-liquorix-amd64


Same outcome, it really wants the correct perf tool for the currently running Kernel and won't work without that.
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 796
Reply Quote
Ah, you can try doing this instead. Download the source code for the latest patch used in current Liquorix here (subject to change with each release): github.com/zen-kernel/zen-kernel/archive/v5.4.5-lqx1.tar.gz

Unpack it and run:
:: Code ::
cd zen-kernel-5.4.5-lqx1/tools/perf
make -j16
sudo ./perf stat -a sleep 1

Back to top
NoXPhasma
Status: Interested
Joined: 21 Nov 2019
Posts: 14
Reply Quote
This actually works, I've done it on both kernels, however for me it doesn't show any big difference.

5.4.0-1.1-liquorix-amd64:

:: Code ::
$ sudo ./perf stat -a sleep 1

 Performance counter stats for 'system wide':

         16.008,34 msec cpu-clock                 #   15,993 CPUs utilized         
             3.654      context-switches          #    0,228 K/sec                 
               186      cpu-migrations            #    0,012 K/sec                 
             7.232      page-faults               #    0,452 K/sec                 
       737.332.970      cycles                    #    0,046 GHz                   
       170.467.457      stalled-cycles-frontend   #   23,12% frontend cycles idle   
       139.960.899      stalled-cycles-backend    #   18,98% backend cycles idle   
       452.328.941      instructions              #    0,61  insn per cycle         
                                                  #    0,38  stalled cycles per insn
        94.777.932      branches                  #    5,921 M/sec                 
         2.715.336      branch-misses             #    2,86% of all branches       

       1,000956967 seconds time elapsed


5.4.0-5.1-liquorix-amd64:

:: Code ::
$ sudo ./perf stat -a sleep 1

 Performance counter stats for 'system wide':

         16.015,01 msec cpu-clock                 #   15,991 CPUs utilized         
             3.276      context-switches          #    0,205 K/sec                 
               277      cpu-migrations            #    0,017 K/sec                 
             7.184      page-faults               #    0,449 K/sec                 
       648.996.315      cycles                    #    0,041 GHz                   
       126.113.892      stalled-cycles-frontend   #   19,43% frontend cycles idle   
       139.262.101      stalled-cycles-backend    #   21,46% backend cycles idle   
       423.957.872      instructions              #    0,65  insn per cycle         
                                                  #    0,33  stalled cycles per insn
        88.334.396      branches                  #    5,516 M/sec                 
         2.546.830      branch-misses             #    2,88% of all branches       

       1,001521783 seconds time elapsed


I've also made a screenshot of conky, which shows the CPU usage, which was in idle, just the desktop and a terminal window. With the other Kernel the CPU usage is absolutely flat and I've never seen conky using >3% CPU before. imgur.com/a/ocgRLAo
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 796
Reply Quote
Hmm, ya, the stat output on both kernels looks within the margin of error. Could you show the output of this command on both kernels?
:: Code ::
sudo ./perf record -g -a sleep 5 && sudo ./perf report --percent-limit 2

Back to top
NoXPhasma
Status: Interested
Joined: 21 Nov 2019
Posts: 14
Reply Quote
Sure, here is the output of both kernels: imgur.com/a/MjJ0WO6

Also here is a comparison between the load and how it's visible on my screen with conky and gnome-system-monitor: imgur.com/a/uSgod2D
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 796
Reply Quote
Well that was highly unexpected, all your CPU time is spend in the applications. Or I suppose, it is expected since you said the applications had higher CPU usage.

I'm not sure where to go from here, I think that the tick rate is the culprit. However, that doesn't mean that we should reduce it. Remember, at a periodic tick of 250hz, time accounting was much more coarse. At 1000hz tickless idle, we're gathering a lot more data. It could be that we're capturing data that was previously unaccounted for.

That or of course, the applications are simply spinning faster, which is the most likely explanation. Why they're not spinning faster on my system is a mystery. Perhaps it's the version of your distribution? Linux Mint 19.3 is 18.04, maybe things would change if you ran a newer distribution like 19.10.
Back to top
NoXPhasma
Status: Interested
Joined: 21 Nov 2019
Posts: 14
Reply Quote
:: damentz wrote ::
Linux Mint 19.3 is 18.04, maybe things would change if you ran a newer distribution like 19.10.


Maybe, but I will not find out, as I'm not in the mood to switch to Ubuntu, nor do I have the resources to install a different distribution next to this one. Next time I will upgrade will be on LM20 release, which will not happen before may.

I also need to run some benchmarks, because it feels like the system would also run slower. However, this could be (most probably is) imagination, we'll see. Anyway, it's late here and I need to sleep. I will report back tomorrow, have a nice evening.
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 796
Reply Quote
Ok, no problem.

I have a few more suggestions for when you get some time.

1) Install / enable irqbalance if you haven't already. That'll help distribute interrupts to all your different cores, reducing general CPU usage.

2) Add mitigations=off to your default grub command line. A mitigation may be currently affecting performance in some unusual way.

3) Try updating your BIOS[1]. You're on version 1201, while the latest is 5220. It's 18 updates newer than what you're running and might include some fixes that affect your current situation... which leads to

4) Can you show me the output of journalctl -k | grep -i clocksource? One thing on my mind is the clock source doesn't like being polled at 1000hz. That might indicate that you're running hpet instead of tsc, which is known to have higher latency per time request. If you're on tsc, then that's something we can easily rule out.

[1] www.asus.com/us/Motherboards/PRIME-X370-PRO/HelpDesk_BIOS/
Back to top
Display posts from previous:   
Page: Previous  1, 2, 3  Next
All times are GMT - 8 Hours