sgfxi - error 245 during installation
ACKEP
Status: New User - Welcome
Joined: 09 Apr 2018
Posts: 4
Reply Quote
OS Debian 7.4.0
Video NVIDIA GT218 (GeForce 210)

Error 245 during installation

In /var/log/sgfx.log
./nvidia-installer: unrecognized option "--install-libglvnd"

Previously, on this system with this video card, there were no such errors. Please help.

P.S. I executed the command sgfxi --debugger
File name sgfxi-cm111-2018-04-09-161000-root.tar.gz
Looks like the Perl ftp upload worked!
Back to top
ACKEP
Status: New User - Welcome
Joined: 09 Apr 2018
Posts: 4
Reply Quote
Fix the error by setting B_ALLOW_AUTO_UPDATE='false' and B_GLVN='false'
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3882
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
there are flags to switch off libglv, -g.

I just checked, and I'd forgotten to update the actual help text, it said it turns it ON, but it really turns it OFF. That's fixed.

Newer nvidia cards mostly need -g and -u to not be used, so I have sgfxi default to those ON,, true, and those switches will turn the libglvnd and unified memory flags OFF if used.

I'm not sure what card or kernel you used, since you posted no details, but I believe most current kernels and cards want the defaults, and the overrides of -g and -u will solve some other cases.

There was no easy way to fix this issue, I've never seen nvidia do something like this before, not sure what happened or why.

I tried it both ways, -g and -u switching ON the features, but most cards want them on, which means most cards would default fail, so I made those switch the features off. There's sadly no easy way to tell users this.

I'll take a look at the debugger data to see if I can get any clues.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3882
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
By the way, I have a geforce 210 and as far as I remember, though I need to double check, it does not require the -g or -u flags to be active, but I will double check that. This is also a function of kernel version, by the way. The claim was something like 4.11 or 4.12 needed those flags active, but I found that 4.9 also needs them active or install fails. -g and -u deactivate the flags internally, to be clear.

I never tested this with older kernels, so if you are using an older kernel, that's the problem, and the flags have to be used, -g in your case, since you already verified that disabling that works.
Back to top
ACKEP
Status: New User - Welcome
Joined: 09 Apr 2018
Posts: 4
Reply Quote
Thank you very much for the detailed answer!

Using this script I installed more than a hundred systems with GeForce 210 and Debian 7. There were no problems. But last week, I had to reinstall one of these systems. And faced with this problem. I tried to use the old version of the script and the driver from the working system, but the result was the same. Rather, something has changed in the Debian. But now I know how to fix it. Thank you again!
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3882
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
which option set worked, and what has changed? what kernel is it?
Back to top
ACKEP
Status: New User - Welcome
Joined: 09 Apr 2018
Posts: 4
Reply Quote
I did not check the functionality of the script with options "-g" or "-u". I set the parameters B_ALLOW_AUTO_UPDATE='false' and B_GLVN='false' directly in the script and it worked. Now I can't check "-g" or "-u" - I gave the computer. Next time will definitely check it out. Kernel 3.2.0-5-686-pae. Previous installations were on 3.2.0-4-686-pae.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3882
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Oh, good, that is a serious corner case, 3.2 is a very old kernel, I was wondering.

So in your case you certainly want to use -g, and maybe -u, that depends, the best strategy is to try it first with the minimum, which you did, no options, that fails, then try it with -g, which works, since you already confirmed that.
Back to top
Display posts from previous:   

All times are GMT - 8 Hours