[SOLVED]4.13.0-10.1-liquorix-686 is the last kernel that my system will boot
dark-D
Status: Contributor
Joined: 27 May 2010
Posts: 68
Location: shadows
Reply Quote
hello damentz,
i didn't want to bother you with my old thinkpad troubles, because i was going to buy a new thinkpad or a desktop, but with the stubbornness of manufactures to reduce the price of a EOL platform for the holidays, i have to wait for an 8th gen quad core refresh laptop at the same price as the dual cores one, or that the inflated prices of ram & ssds and a 19 months old gpu architecture (1000th series from nvidia) to be refreshed, so that i don't waste my resources on old tech. long story short, i have to use my old trusted, one leg in the grave, thinkpad r61i for a little while. if the problems are due to my old laptop, feel free to ignore this thread, as i don't want to waste your time debugging a 10 years old laptop. so here it is, i cannot boot from 4.13-10 onwards, as i recall 4.13-13 or 4.13.14 didn't boot with the same error as i get from the 4.14-4: https://postimg.org/image/md0mcdqyt/
this is my inxi -F, i use a custom antix install, which is basically debian sid:
:: Code ::

System:    Host: hell Kernel: 4.13.0-10.1-liquorix-686 i686 bits: 32
           Desktop: Fluxbox 1.3.7 Distro: blackbox
Machine:   Device: laptop System: LENOVO product: 89329WU v: ThinkPad R61/R61i serial: N/A
           Mobo: LENOVO model: 89329WU serial: N/A
           BIOS: LENOVO v: 7OETC3WW (2.23 ) date: 05/12/2009
Battery    BAT0: charge: 17.9 Wh 99.1% condition: 18.1/51.8 Wh (35%)
CPU:       Single core Intel Core2 Duo T5250 (-UP-) cache: 2048 KB
           speed/max: 1495/1500 MHz
Graphics:  Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
           Display Server: X.org 1.19.5 driver: intel tty size: 90x30
Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.13.0-10.1-liquorix-686
Network:   Card-1: Intel PRO/Wireless 3945ABG [Golan] Network Connection
           driver: iwl3945
           IF: wlan0 state: down mac: 00:1b:77:6f:fd:47
           Card-2: Broadcom Limited NetLink BCM5787M Gigabit Ethernet PCIE driver: tg3
           IF: ens4 state: up speed: 100 Mbps duplex: full mac: c8:3a:35:fd:29:58
Drives:    HDD Total Size: 120.0GB (55.8% used)
           ID-1: /dev/sda model: HITACHI_HTS54161 size: 120.0GB
Partition: ID-1: / size: 2.0G used: 1.8G (92%) fs: ext4 dev: /dev/sda1
Sensors:   System Temperatures: cpu: 70.0C mobo: 44.0C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 96 Uptime: 37 min Memory: 369.7/992.3MB Init: systemd runlevel: 5
           Client: Shell (bash) inxi: 2.3.51

also when i installed the 4.14-4 kernel i got an error about the tg3 driver, my network adapter driver, so i guess even if i manage to boot i will not have ethernet, i didn't get the error on the 4.13 kernels.
:: Code ::
root@hell:/home/soul# apt-get install linux-image-4.14.0-4.1-liquorix-686
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  libx265-130
Use 'apt autoremove' to remove it.
Suggested packages:
  linux-doc-4.14 crda
Recommended packages:
  firmware-linux-free
The following NEW packages will be installed:
  linux-image-4.14.0-4.1-liquorix-686
0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
Need to get 46.4 MB of archives.
After this operation, 170 MB of additional disk space will be used.
Get:1 https://liquorix.net/debian sid/main i386 linux-image-4.14.0-4.1-liquorix-686 i386 4.14-5 [46.4 MB]
Fetched 46.4 MB in 9s (4,680 kB/s)                                                       
Preconfiguring packages ...
Selecting previously unselected package linux-image-4.14.0-4.1-liquorix-686.
(Reading database ... 43535 files and directories currently installed.)
Preparing to unpack .../linux-image-4.14.0-4.1-liquorix-686_4.14-5_i386.deb ...
Unpacking linux-image-4.14.0-4.1-liquorix-686 (4.14-5) ...
Setting up linux-image-4.14.0-4.1-liquorix-686 (4.14-5) ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-4.14.0-4.1-liquorix-686
W: Possible missing firmware /lib/firmware/tigon/tg3_tso5.bin for module tg3
W: Possible missing firmware /lib/firmware/tigon/tg3_tso.bin for module tg3
W: Possible missing firmware /lib/firmware/tigon/tg3.bin for module tg3
/etc/kernel/postinst.d/zz-update-grub:
Failed to check for container: Input/output error
Generating grub configuration file ...
using custom appearance settings
Found background image: black.tga
Found linux image: /boot/vmlinuz-4.14.0-4.1-liquorix-686
Found initrd image: /boot/initrd.img-4.14.0-4.1-liquorix-686
Found linux image: /boot/vmlinuz-4.13.0-10.1-liquorix-686
Found initrd image: /boot/initrd.img-4.13.0-10.1-liquorix-686
Found memtest86+ image: /boot/memtest86+.bin
Found memtest86+ multiboot image: /boot/memtest86+_multiboot.bin
done


some other things i noticed with the latest kernels are noise output of the kernel or the intel acpi even if i have the quiet flag active on my boot option, which other users reported. and a general laggyness of the system or high cpu usage compared to older versions of the kernel. liquorix would run my old laptop as if it was new.
i have not submitted a bug report for so long that i don't remember what is needed. please ask me for additional info if it's needed.
remember fell free to ignore this post if it is from discontinued support in the kernel or because it's old af.
i am happy to use it as it is for the time being, until i upgrade. thank you for your hard work on the kernel.

< Edited by dark-D :: Dec 7, 17, 15:31 >

Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 737
Reply Quote
Just some notes on stuff I spotted by looking at your system.

This is your CPU: https://ark.intel.com/products/30786/Intel-Core2-Duo-Processor-T5250-2M-Cache-1_50-GHz-667-MHz-FSB

It's actually a dual core processor, but inxi is reporting that only one core is active. Do you have the second core disabled in the BIOS?

And then two, have you tried running the 64-bit kernel? As less users are running 32-bit, the number of 32-bit only bugs tend to increase since no one tests the actual runtime of 32-bit. I would try running 64-bit since I haven't seen any reports of any bfq for the specific error you have (bfq_bfqq_resume_state).

Also, Ubuntu has already dropped support for installing on to 32-bit systems since 17.10: www.omgubuntu.co.uk/2017/09/ubuntu-17-10-32-bit-builds-dropped

Basically what I'm trying to say is 32-bit is available for the systems it works on, but I'm not sure if it's worth any effort to debug one-off errors that only exist on 32-bit, since a 64-bit kernel is used on 90%+ of system installations, and is growing.

And wow!
:: Code ::
Sensors:   System Temperatures: cpu: 70.0C mobo: 44.0C
           Fan Speeds (in rpm): cpu: 0


Maybe you should take apart that laptop and apply some newer thermal paste - looks like your system is having trouble handling the heat produced by your CPU. I have a similar laptop, the Inspiron 1420 that Ars Technica reviewed in 2008 - I've already upgraded the CPU with the best CPU the motherboard can take (T9500: https://ark.intel.com/products/33918/Intel-Core2-Duo-Processor-T9500-6M-Cache-2_60-GHz-800-MHz-FSB), and it idles around 35*C. That's probably something worth looking at since old mid range processors can be bought for pretty cheap, and especially worthwhile if you already have a low end chip in your laptop.
Back to top
dark-D
Status: Contributor
Joined: 27 May 2010
Posts: 68
Location: shadows
Reply Quote
thanks for the quick reply. only after i started the thread, i realized that i shouldn't have posted it.

as i explained, the laptop is on it's death bed, the fan is broken so it's passively cooled, that is the reason for the high temperatures, also sometimes when the cpu overheats, when i reboot the laptop, one core is turned off.

i am aware that they want to faze out the 32-bit architecture, i was only using a 32 bit install because of the lower ram usage and for the fact that i have this system installed for many years. when i'll change my computer i will use an 64 bit install.

i'll wait for a viable option to become available, so i can purchase a new computer.
thanks again for the help and sorry if i caused any trouble. you can close this thread.
Back to top
stevenpusser
Status: Interested
Joined: 14 Jan 2017
Posts: 47
Reply Quote
Could the tg3 firmware warnings be related to the 4.14 dropping of the firmware tree, or because the 4.14 kernels aren't creating a folder for themselves in /lib/firmware like the previous ones? Since those are just warnings, not errors, perhaps they are just triggered and can be ignored, and the firmware will be loaded from /lib/firmware. I have 4.9, 4.13. and 4.14 kernels installed, not tg3 but my Skylake 520 GPU and Qualcomm wi-fi doen't have any trouble loading the firmware they need. I get this

:: Code ::
locate tg3_tso5.bin

/lib/firmware/4.13.0-16.1-liquorix-amd64/tigon/tg3_tso5.bin
/lib/firmware/4.9.0-22.1-liquorix-amd64/tigon/tg3_tso5.bin
/lib/firmware/tigon/tg3_tso5.bin
[/code]

Since there's also other 4.14 kernels besides Liquorix available for antiX, try installing one of those to see if they boot or give the same firmware warning.

Speaking of warnings, /debian/compat should be bumped up to 9 to match the minimum version of debhelper in the build-depends, and get rid of that warning that level 7 is deprecated.
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 737
Reply Quote
stevenpusser,

Thanks for the notification about the compat file, I just bumped it to 9 for future releases.

And regarding the missing firmware, I did recently synchronize the /debian/templates/image.plain.bug/control files with linux-siduction per commit: https://github.com/damentz/liquorix-package/commit/d24f3f12f192ea3cda40b51058c18cb374137108.

Maybe this firmware list is providing more or less correct firmware suggestions?
Back to top
Display posts from previous:   

All times are GMT - 8 Hours