[SOLVED] X aceleration (intel i915) craps out on 4.13 kernels
wildstar84
Status: Interested
Joined: 31 May 2017
Posts: 32
Location: Texas
Reply Quote
Each v4.13 kernel I've tried runs fine for a while (a few hours), then eventually X performance starts to choke at random times with this error in Xorg.0.log:

[199016.980] (EE) intel(0): Failed to submit rendering commands (No such file or directory), disabling acceleration.

This necessitates restarting X to fix (very annoying).

All prev. kernels work fine thru 4.12.0-14.3 and never exhibit this issue.

inxi -F:

:: Code ::

System:    Host: roadrunner64 Kernel: 4.12.0-14.3-liquorix-amd64 x86_64
           bits: 64
           Desktop: AfterStep 2.2.12
           Distro: antiX-16.2_x64-base Berta Cáceres 15 June 2017
Machine:   Device: laptop System: Hewlett-Packard product: HP EliteBook 8440p serial: N/A
           Mobo: Hewlett-Packard model: 172A v: KBC Version 30.31 serial: N/A
           BIOS: Hewlett-Packard v: 68CCU Ver. F.11 date: 11/25/2010
Battery    BAT0: charge: 27.3 Wh 100.0% condition: 27.3/27.3 Wh (100%)
CPU:       Dual core Intel Core i5 M 520 (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 2400 MHz 1: 1466 MHz 2: 1599 MHz 3: 1999 MHz
           4: 1199 MHz
Graphics:  Card: Intel Core Processor Integrated Graphics Controller
           Display Server: X.Org 1.19.5 driver: intel
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: Mesa DRI Intel Ironlake Mobile
           version: 2.1 Mesa 17.2.4
Audio:     Card Intel 5 Series/3400 Series High Def. Audio
           driver: snd_hda_intel
           Sound: ALSA v: k4.12.0-14.3-liquorix-amd64
Network:   Card-1: Intel 82577LM Gigabit Network Connection driver: e1000e
           IF: eth0 state: up speed: 100 Mbps duplex: full
           mac: b4:99:ba:e2:cb:7c
           Card-2: Intel Centrino Advanced-N 6200
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 1063.1GB (3.6% used)
           ID-1: /dev/sda model: TOSHIBA_MQ01ABD1 size: 1000.2GB
           ID-2: USB /dev/sdb model: Cruzer_Glide size: 62.9GB
Partition: ID-1: / size: 32G used: 7.9G (27%) fs: ext4 dev: /dev/sdb1
           ID-2: /home size: 27G used: 8.3G (34%) fs: ext4 dev: /dev/sdb2
Sensors:   System Temperatures: cpu: 50.0C mobo: 0.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 170 Uptime: 6:28 Memory: 853.0/7777.3MB
           Client: Shell (bash) inxi: 2.3.43


xorg.conf:

:: Code ::

"ExaNoComposite" "true"
   Identifier  "Card0"
   Driver      "intel"
   BusID       "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Laptop"
   Option "BackingStore" "true"
   DefaultColorDepth 24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   Modes "1600x900"
   EndSubSection
EndSection

Section "Screen"
   Identifier "Screen1"
   Device     "Card0"
   Monitor    "External"
   Option "BackingStore" "true"
   DefaultColorDepth 24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "DRI"
    Mode 0666
EndSection

Section "Extensions"
  Option "Composite" "Enable"
EndSection
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   Screen      1  "Screen1" 0 0
EndSection

Section "Files"
   ModulePath   "/usr/lib/xorg/modules"
   FontPath     "/usr/share/fonts/X11/misc"
   FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath     "/usr/share/fonts/X11/Type1"
   FontPath     "/usr/share/fonts/X11/100dpi"
   FontPath     "/usr/share/fonts/truetype"
   FontPath     "built-ins"
EndSection

Section "Module"
   Load  "glx"
  Load "bitmap"
  Load "freetype"
  Load "vbe"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Laptop"
   VendorName   "HP"
   ModelName    "Monitor Model"
EndSection

Section "Monitor"
   Identifier   "External"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
   Option "Monitor-eDP1" "Laptop"
   Option "Monitor-VGA1" "External"
   Option "Monitor-HDMI1" "External"
   Option "Monitor-DP1" "External"
   Option "AccelMethod" "SNA"
   Option "DRI" "3"
        Option     "Backlight"             "intel_backlight" # -OR- "dell_backlight" (default)
        Option     "Tiling"                "true"
        Option     "TripleBuffer"          "true"
        Option     "XvMC"    "true"
   Identifier  "Card0"
   Driver      "intel"
   BusID       "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Laptop"
   Option "BackingStore" "true"
   DefaultColorDepth 24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   Modes "1600x900"
   EndSubSection
EndSection

Section "Screen"
   Identifier "Screen1"
   Device     "Card0"
   Monitor    "External"
   Option "BackingStore" "true"
   DefaultColorDepth 24
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Section "DRI"
    Mode 0666
EndSection

Section "Extensions"
  Option "Composite" "Enable"
EndSection


Any ideas / suggestions?

Thanks in advance,

Jim
Back to top
stevenpusser
Status: Interested
Joined: 14 Jan 2017
Posts: 47
Reply Quote
Is this with the regular Liquorix kernel built on gcc 6 or 7 (for 4.13) or one that's built on antiX 16's native gcc-4.9?
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 737
Reply Quote
Some observations I want to make right off the bat.

1) Have you tested all the custom intel options that you've enabled for your GPU? I found that the defaults tend to work very well unless you really know what you're turning on.

For instance, one option I feel you'll benefit from turning off is BackingStore - this is a an Xorg software optimization that has no place with proper GPU acceleration. It actually ends up reducing performance and unpredictable behavior the longer your X session runs. It has no place on a modern desktop, especially if you use compositing. It'll only interfere with 2d acceleration, especially using something as highly optimized as SNA acceleration with intel graphics.

2) You're forcing on a lot of options that X is better off configuring itself. In your case, you're probably better off removing your xorg.conf file entirely, creating an /etc/X11/xorg.conf.d/ folder, creating a file called 50-intel.conf, and putting something like the following inside:

:: Code ::
Section "Device"
    Identifier  "Card0"
    Driver      "intel"
    # Option "AccelMethod" "SNA" # default according to intel man page
    Option "DRI" "3"
    Option "Backlight" "intel_backlight" # -OR- "dell_backlight" (default)
    # Option "TripleBuffer" "true"  # default according to intel man page
EndSection


The rest of your monitor configuration should be set and remembered by your desktop's RandR tool. It looks like you're using something very lightweight, however, so you may want to look for an alternative or steal another desktops display tools (xfce, lxde, etc)
Back to top
wildstar84
Status: Interested
Joined: 31 May 2017
Posts: 32
Location: Texas
Reply Quote
stevenpusser: I assume 6.7? - I installed the binary deb & headers from liquorix direct (deb http: //liquorix.net/debian/ sid main).

damentz: I followed your advice: removing xorg.conf and adding your 50-intel.conf file as instructed and added the line: Option "BackingStore" "false" to it since the log still showed that that was set to "true" by default (it now shows false), plus I installed the latest kernel (4.12.0-14.3-liquorix-amd64), and X ran well, but lasted a/b an hour before again cradering acceleration again with that error. Thanks though for taking the time to look thru all my configs! I've been tweeking that xorg.conf file since pbly. the XFree86 dayz not realizing that it had likely acumulated some cruft! Anyway, it still looks like a v4.13-ish issue (I just went back to 4.12 after X dogged up again, but with the new settings, as it has never failed me).

The only other files I have in xorg.conf.d are: 60-ibm_scrollpoint.conf, 61-microsoft_wheelmouse.conf, and 62-synaptics.conf. Checking the log, the only difference in libraries loaded (after removing xorg.conf) was "libvbe" is no longer loaded.

Jim
Back to top
wildstar84
Status: Interested
Joined: 31 May 2017
Posts: 32
Location: Texas
Reply Quote
UPDATE: This is not a Liquorix-specific issue, but a v4.13* issue! I tried booting my distro's new v4.13 kernel (4.13.4-antix.1-amd64-smp) to test and it FAILS the exact same way there too (NEVER an issue w/any previous kernels <4.13 (with all other libraries and software the same versions)! Still, if anyone has any ideas for a patch/fix/workaround, I'd be very appreciative! Here's a link that seems to discuss this issue along w/some patches (that I haven't tried):

https://bugs.freedesktop.org/show_bug.cgi?id=103509

Jim

Xorg.0.log (post-failure):

:: Code ::

[    12.837]
X.Org X Server 1.19.5
Release Date: 2017-10-12
[    12.837] X Protocol Version 11, Revision 0
[    12.837] Build Operating System: Linux 4.14.0-rc4-debug-00260-ga9ead0e01cab x86_64 Debian
[    12.837] Current Operating System: Linux roadrunner64 4.12.0-14.3-liquorix-amd64 #1 ZEN SMP PREEMPT liquorix 4.12-11 (2017-10-14) x86_64
[    12.837] Kernel command line: audit=0  BOOT_IMAGE=/boot/vmlinuz-4.12.0-14.3-liquorix-amd64 root=UUID=3c8f3af2-7dc6-4eab-bb59-4d546e357409 ro zswap.zpool=zsmalloc quiet nosplash cgroup_disable=cpuset,cpu,cpuacct,blkio,memory ipv6.disable=1 libahci.ignore_sss=1 i915.fastboot=1
[    12.837] Build Date: 16 October 2017  05:46:34PM
[    12.837] xorg-server 2:1.19.5-1.0nosystemd1 (https://www.debian.org/support)
[    12.837] Current version of pixman: 0.34.0
[    12.837]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    12.837] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    12.837] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Nov 23 01:27:52 2017
[    12.874] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    12.874] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    12.886] (==) No Layout section.  Using the first Screen section.
[    12.886] (==) No screen section available. Using defaults.
[    12.886] (**) |-->Screen "Default Screen Section" (0)
[    12.886] (**) |   |-->Monitor "<default monitor>"
[    12.886] (==) No device specified for screen "Default Screen Section".
   Using the first device section listed.
[    12.886] (**) |   |-->Device "Card0"
[    12.886] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[    12.886] (==) Automatically adding devices
[    12.886] (==) Automatically enabling devices
[    12.886] (==) Automatically adding GPU devices
[    12.891] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    12.912] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    12.912]    Entry deleted from font path.
[    12.915] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    12.915]    Entry deleted from font path.
[    12.943] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    12.943]    Entry deleted from font path.
[    12.943] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   built-ins
[    12.943] (==) ModulePath set to "/usr/lib/xorg/modules"
[    12.943] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    12.944] (II) Loader magic: 0x55877289dd40
[    12.944] (II) Module ABI versions:
[    12.944]    X.Org ANSI C Emulation: 0.4
[    12.944]    X.Org Video Driver: 23.0
[    12.944]    X.Org XInput driver : 24.1
[    12.944]    X.Org Server Extension : 10.0
[    12.946] (II) xfree86: Adding drm device (/dev/dri/card0)
[    12.962] (--) PCI:*(0:0:2:0) 8086:0046:103c:172a rev 2, Mem @ 0xd0000000/4194304, 0xc0000000/268435456, I/O @ 0x00005058/8, BIOS @ 0x????????/131072
[    12.963] (II) LoadModule: "glx"
[    12.965] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    13.028] (II) Module glx: vendor="X.Org Foundation"
[    13.028]    compiled for 1.19.5, module version = 1.0.0
[    13.028]    ABI class: X.Org Server Extension, version 10.0
[    13.028] (II) LoadModule: "intel"
[    13.057] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    13.082] (II) Module intel: vendor="X.Org Foundation"
[    13.082]    compiled for 1.19.0, module version = 2.99.917
[    13.082]    Module class: X.Org Video Driver
[    13.082]    ABI class: X.Org Video Driver, version 23.0
[    13.082] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
   i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
   915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
   Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
   GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    13.082] (II) intel: Driver for Intel(R) HD Graphics
[    13.082] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[    13.082] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[    13.082] (++) using VT number 7

[    13.152] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20170403
[    13.152] (II) intel(0): SNA compiled: xserver-xorg-video-intel 2:2.99.917+git20161206-1 (Timo Aaltonen <tjaalton@debian.org>)
[    13.152] (II) intel(0): SNA compiled for use with valgrind
[    13.161] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics
[    13.161] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2; using a maximum of 2 threads
[    13.161] (II) intel(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[    13.161] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[    13.161] (==) intel(0): RGB weight 888
[    13.161] (==) intel(0): Default visual is TrueColor
[    13.161] (**) intel(0): Option "Backlight" "intel_backlight"
[    13.161] (**) intel(0): Option "DRI" "3"
[    13.161] (II) intel(0): Output eDP1 has no monitor section
[    13.161] (**) intel(0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
[    13.161] (II) intel(0): Enabled output eDP1
[    13.161] (II) intel(0): Output VGA1 has no monitor section
[    13.162] (II) intel(0): Enabled output VGA1
[    13.162] (II) intel(0): Output HDMI1 has no monitor section
[    13.162] (II) intel(0): Enabled output HDMI1
[    13.162] (II) intel(0): Output DP1 has no monitor section
[    13.162] (II) intel(0): Enabled output DP1
[    13.162] (II) intel(0): Output HDMI2 has no monitor section
[    13.162] (II) intel(0): Enabled output HDMI2
[    13.162] (II) intel(0): Output HDMI3 has no monitor section
[    13.162] (II) intel(0): Enabled output HDMI3
[    13.162] (II) intel(0): Output DP2 has no monitor section
[    13.162] (II) intel(0): Enabled output DP2
[    13.162] (II) intel(0): Output DP3 has no monitor section
[    13.162] (II) intel(0): Enabled output DP3
[    13.163] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[    13.163] (II) intel(0): Output VIRTUAL1 has no monitor section
[    13.163] (II) intel(0): Enabled output VIRTUAL1
[    13.163] (--) intel(0): Output eDP1 using initial mode 1600x900 on pipe 0
[    13.163] (--) intel(0): Output HDMI1 using initial mode 1920x1080 on pipe 1
[    13.163] (==) intel(0): TearFree disabled
[    13.163] (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
[    13.163] (==) intel(0): DPI set to (96, 96)
[    13.163] (II) Loading sub module "dri3"
[    13.163] (II) LoadModule: "dri3"
[    13.163] (II) Module "dri3" already built-in
[    13.163] (II) Loading sub module "dri2"
[    13.163] (II) LoadModule: "dri2"
[    13.163] (II) Module "dri2" already built-in
[    13.163] (II) Loading sub module "present"
[    13.163] (II) LoadModule: "present"
[    13.163] (II) Module "present" already built-in
[    13.163] (==) Depth 24 pixmap format is 32 bpp
[    13.266] (II) intel(0): SNA initialized with Ironlake (gen5) backend
[    13.266] (**) intel(0): Option "BackingStore" "false"
[    13.266] (**) intel(0): Backing store disabled
[    13.266] (++) intel(0): Silken mouse disabled
[    13.273] (II) intel(0): HW Cursor enabled
[    13.273] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    13.277] (==) intel(0): DPMS enabled
[    13.277] (==) intel(0): Display hotplug detection enabled
[    13.277] (II) intel(0): [XvMC] xvmc_vld driver initialized.
[    13.277] (II) intel(0): [DRI2] Setup complete
[    13.277] (II) intel(0): [DRI2]   DRI driver: i965
[    13.277] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[    13.277] (II) intel(0): direct rendering: DRI2 DRI3 enabled
[    13.277] (II) intel(0): hardware support for Present enabled
[    13.277] (--) RandR disabled
[    13.285] (II) SELinux: Disabled on system
[    13.473] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[    13.473] (II) AIGLX: enabled GLX_ARB_create_context
[    13.473] (II) AIGLX: enabled GLX_ARB_create_context_profile
[    13.473] (II) AIGLX: enabled GLX_EXT_create_context_es{,2}_profile
[    13.473] (II) AIGLX: enabled GLX_INTEL_swap_event
[    13.473] (II) AIGLX: enabled GLX_SGI_swap_control
[    13.473] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[    13.473] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[    13.473] (II) AIGLX: enabled GLX_EXT_fbconfig_packed_float
[    13.473] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[    13.473] (II) AIGLX: Loaded and initialized i965
[    13.473] (II) GLX: Initialized DRI2 GL provider for screen 0
[    13.493] (II) intel(0): switch to mode 1600x900@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[    13.494] (II) intel(0): switch to mode 1920x1080@60.0 on HDMI1 using pipe 1, position (0, 0), rotation normal, reflection none
[    13.498] (II) intel(0): Setting screen physical size to 508 x 285
[    13.708] (II) config/udev: Adding input device Power Button (/dev/input/event3)
[    13.709] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[    13.709] (II) LoadModule: "evdev"
[    13.709] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[    13.720] (II) Module evdev: vendor="X.Org Foundation"
[    13.720]    compiled for 1.19.1, module version = 2.10.5
[    13.720]    Module class: X.Org XInput Driver
[    13.720]    ABI class: X.Org XInput driver, version 24.1
[    13.720] (II) Using input driver 'evdev' for 'Power Button'
[    13.720] (**) Power Button: always reports core events
[    13.720] (**) evdev: Power Button: Device: "/dev/input/event3"
[    13.720] (--) evdev: Power Button: Vendor 0 Product 0x1
[    13.720] (--) evdev: Power Button: Found keys
[    13.720] (II) evdev: Power Button: Configuring as keyboard
[    13.720] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input10/event3"
[    13.720] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[    13.720] (**) Option "xkb_rules" "evdev"
[    13.720] (**) Option "xkb_model" "pc105"
[    13.720] (**) Option "xkb_layout" "us"
[    13.720] (**) Option "xkb_variant" "basic"
[    13.720] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    13.744] (II) config/udev: Adding input device Video Bus (/dev/input/event4)
[    13.744] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[    13.744] (II) Using input driver 'evdev' for 'Video Bus'
[    13.744] (**) Video Bus: always reports core events
[    13.744] (**) evdev: Video Bus: Device: "/dev/input/event4"
[    13.744] (--) evdev: Video Bus: Vendor 0 Product 0x6
[    13.744] (--) evdev: Video Bus: Found keys
[    13.744] (II) evdev: Video Bus: Configuring as keyboard
[    13.744] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:01/input/input12/event4"
[    13.744] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[    13.744] (**) Option "xkb_rules" "evdev"
[    13.744] (**) Option "xkb_model" "pc105"
[    13.744] (**) Option "xkb_layout" "us"
[    13.744] (**) Option "xkb_variant" "basic"
[    13.744] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    13.744] (II) config/udev: Adding input device Lid Switch (/dev/input/event2)
[    13.744] (II) No input driver specified, ignoring this device.
[    13.744] (II) This device may have been added with another device file.
[    13.744] (II) config/udev: Adding input device Sleep Button (/dev/input/event1)
[    13.745] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[    13.745] (II) Using input driver 'evdev' for 'Sleep Button'
[    13.745] (**) Sleep Button: always reports core events
[    13.745] (**) evdev: Sleep Button: Device: "/dev/input/event1"
[    13.745] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[    13.745] (--) evdev: Sleep Button: Found keys
[    13.745] (II) evdev: Sleep Button: Configuring as keyboard
[    13.745] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input8/event1"
[    13.745] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 8)
[    13.745] (**) Option "xkb_rules" "evdev"
[    13.745] (**) Option "xkb_model" "pc105"
[    13.745] (**) Option "xkb_layout" "us"
[    13.745] (**) Option "xkb_variant" "basic"
[    13.745] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    13.746] (II) config/udev: Adding input device HID 04b3:3108 (/dev/input/event5)
[    13.746] (**) HID 04b3:3108: Applying InputClass "evdev pointer catchall"
[    13.746] (**) HID 04b3:3108: Applying InputClass "ScrollPoint"
[    13.746] (II) Using input driver 'evdev' for 'HID 04b3:3108'
[    13.746] (**) HID 04b3:3108: always reports core events
[    13.746] (**) evdev: HID 04b3:3108: Device: "/dev/input/event5"
[    13.798] (--) evdev: HID 04b3:3108: Vendor 0x4b3 Product 0x3108
[    13.798] (--) evdev: HID 04b3:3108: Found 3 mouse buttons
[    13.798] (--) evdev: HID 04b3:3108: Found scroll wheel(s)
[    13.798] (--) evdev: HID 04b3:3108: Found relative axes
[    13.798] (--) evdev: HID 04b3:3108: Found x and y relative axes
[    13.798] (II) evdev: HID 04b3:3108: Configuring as mouse
[    13.798] (II) evdev: HID 04b3:3108: Adding scrollwheel support
[    13.798] (**) Option "VertScrollDelta" "40"
[    13.798] (**) Option "HorizScrollDelta" "40"
[    13.798] (**) evdev: HID 04b3:3108: YAxisMapping: buttons 4 and 5
[    13.798] (**) evdev: HID 04b3:3108: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    13.798] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4.2/1-1.4.2:1.0/0003:04B3:3108.0001/input/input13/event5"
[    13.798] (II) XINPUT: Adding extended input device "HID 04b3:3108" (type: MOUSE, id 9)
[    13.798] (II) evdev: HID 04b3:3108: initialized for relative axes.
[    13.798] (**) HID 04b3:3108: (accel) keeping acceleration scheme 1
[    13.798] (**) Option "AccelerationProfile" "2"
[    13.798] (**) HID 04b3:3108: (accel) acceleration profile 2
[    13.798] (**) HID 04b3:3108: (accel) acceleration factor: 2.000
[    13.798] (**) HID 04b3:3108: (accel) acceleration threshold: 4
[    13.799] (II) config/udev: Adding input device HID 04b3:3108 (/dev/input/mouse0)
[    13.799] (**) HID 04b3:3108: Applying InputClass "ScrollPoint"
[    13.799] (II) No input driver specified, ignoring this device.
[    13.799] (II) This device may have been added with another device file.
[    13.800] (II) config/udev: Adding input device HDA Intel MID Mic (/dev/input/event9)
[    13.800] (II) No input driver specified, ignoring this device.
[    13.800] (II) This device may have been added with another device file.
[    13.801] (II) config/udev: Adding input device HDA Intel MID Line (/dev/input/event10)
[    13.801] (II) No input driver specified, ignoring this device.
[    13.801] (II) This device may have been added with another device file.
[    13.802] (II) config/udev: Adding input device HDA Intel MID Headphone (/dev/input/event11)
[    13.802] (II) No input driver specified, ignoring this device.
[    13.802] (II) This device may have been added with another device file.
[    13.802] (II) config/udev: Adding input device HDA Intel MID Dock Headphone (/dev/input/event12)
[    13.802] (II) No input driver specified, ignoring this device.
[    13.802] (II) This device may have been added with another device file.
[    13.803] (II) config/udev: Adding input device HDA Intel MID HDMI/DP,pcm=3 (/dev/input/event13)
[    13.803] (II) No input driver specified, ignoring this device.
[    13.803] (II) This device may have been added with another device file.
[    13.804] (II) config/udev: Adding input device HDA Intel MID HDMI/DP,pcm=7 (/dev/input/event14)
[    13.804] (II) No input driver specified, ignoring this device.
[    13.804] (II) This device may have been added with another device file.
[    13.805] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[    13.805] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    13.805] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[    13.805] (**) AT Translated Set 2 keyboard: always reports core events
[    13.805] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[    13.805] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[    13.805] (--) evdev: AT Translated Set 2 keyboard: Found keys
[    13.805] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[    13.805] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input3/event0"
[    13.805] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 10)
[    13.805] (**) Option "xkb_rules" "evdev"
[    13.805] (**) Option "xkb_model" "pc105"
[    13.805] (**) Option "xkb_layout" "us"
[    13.805] (**) Option "xkb_variant" "basic"
[    13.805] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    13.806] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/event6)
[    13.806] (**) PS/2 Generic Mouse: Applying InputClass "evdev pointer catchall"
[    13.807] (II) Using input driver 'evdev' for 'PS/2 Generic Mouse'
[    13.807] (**) PS/2 Generic Mouse: always reports core events
[    13.807] (**) evdev: PS/2 Generic Mouse: Device: "/dev/input/event6"
[    13.807] (--) evdev: PS/2 Generic Mouse: Vendor 0x2 Product 0x1
[    13.807] (--) evdev: PS/2 Generic Mouse: Found 3 mouse buttons
[    13.807] (--) evdev: PS/2 Generic Mouse: Found relative axes
[    13.807] (--) evdev: PS/2 Generic Mouse: Found x and y relative axes
[    13.807] (II) evdev: PS/2 Generic Mouse: Configuring as mouse
[    13.807] (**) evdev: PS/2 Generic Mouse: YAxisMapping: buttons 4 and 5
[    13.807] (**) evdev: PS/2 Generic Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    13.807] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input11/event6"
[    13.807] (II) XINPUT: Adding extended input device "PS/2 Generic Mouse" (type: MOUSE, id 11)
[    13.807] (II) evdev: PS/2 Generic Mouse: initialized for relative axes.
[    13.807] (**) PS/2 Generic Mouse: (accel) keeping acceleration scheme 1
[    13.807] (**) PS/2 Generic Mouse: (accel) acceleration profile 0
[    13.807] (**) PS/2 Generic Mouse: (accel) acceleration factor: 2.000
[    13.807] (**) PS/2 Generic Mouse: (accel) acceleration threshold: 4
[    13.808] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/mouse1)
[    13.808] (II) No input driver specified, ignoring this device.
[    13.808] (II) This device may have been added with another device file.
[    13.808] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event7)
[    13.808] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[    13.808] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Multitouch Touchpad"
[    13.808] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[    13.808] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
[    13.808] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Touchpad"
[    13.808] (II) LoadModule: "synaptics"
[    13.808] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[    13.812] (II) Module synaptics: vendor="X.Org Foundation"
[    13.812]    compiled for 1.19.0, module version = 1.9.0
[    13.813]    Module class: X.Org XInput Driver
[    13.813]    ABI class: X.Org XInput driver, version 24.1
[    13.813] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
[    13.813] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    13.813] (**) Option "Device" "/dev/input/event7"
[    13.822] (II) synaptics: SynPS/2 Synaptics TouchPad: ignoring touch events for semi-multitouch device
[    13.822] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5482 (res 59)
[    13.822] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4558 (res 116)
[    13.822] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
[    13.822] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
[    13.822] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right double triple
[    13.822] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
[    13.822] (**) Option "VertEdgeScroll" "1"
[    13.822] (**) Option "HorizEdgeScroll" "1"
[    13.822] (**) Option "CornerCoasting" "1"
[    13.822] (**) Option "RBCornerButton" "9"
[    13.822] (**) Option "LBCornerButton" "8"
[    13.822] (**) Option "TapButton1" "1"
[    13.822] (**) Option "TapButton2" "2"
[    13.822] (**) Option "TapButton3" "3"
[    13.822] (**) Option "CircularScrolling" "1"
[    13.822] (**) Option "CircScrollTrigger" "7"
[    13.822] (**) Option "MinSpeed" "0.5"
[    13.822] (**) Option "MaxSpeed" "1.0"
[    13.822] (**) Option "AccelFactor" "0.075"
[    13.822] (**) Option "CoastingSpeed" "8"
[    13.822] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    13.822] (**) SynPS/2 Synaptics TouchPad: always reports core events
[    13.834] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/input/input16/event7"
[    13.834] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 12)
[    13.834] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.0
[    13.834] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MaxSpeed is now 2.00
[    13.834] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) AccelFactor is now 0.075
[    13.834] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
[    13.834] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
[    13.834] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[    13.834] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[    13.834] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[    13.835] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse2)
[    13.835] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
[    13.835] (II) config/udev: Adding input device ST LIS3LV02DL Accelerometer (/dev/input/event8)
[    13.835] (II) No input driver specified, ignoring this device.
[    13.835] (II) This device may have been added with another device file.
[    13.836] (II) config/udev: Adding input device HP WMI hotkeys (/dev/input/event15)
[    13.836] (**) HP WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[    13.836] (II) Using input driver 'evdev' for 'HP WMI hotkeys'
[    13.836] (**) HP WMI hotkeys: always reports core events
[    13.836] (**) evdev: HP WMI hotkeys: Device: "/dev/input/event15"
[    13.836] (--) evdev: HP WMI hotkeys: Vendor 0 Product 0
[    13.836] (--) evdev: HP WMI hotkeys: Found keys
[    13.836] (II) evdev: HP WMI hotkeys: Configuring as keyboard
[    13.836] (**) Option "config_info" "udev:/sys/devices/virtual/input/input24/event15"
[    13.836] (II) XINPUT: Adding extended input device "HP WMI hotkeys" (type: KEYBOARD, id 13)
[    13.836] (**) Option "xkb_rules" "evdev"
[    13.836] (**) Option "xkb_model" "pc105"
[    13.836] (**) Option "xkb_layout" "us"
[    13.836] (**) Option "xkb_variant" "basic"
[    13.836] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    15.167] (II) intel(0): EDID vendor "AUO", prod id 4670
[    15.167] (II) intel(0): Printing DDC gathered Modelines:
[    15.167] (II) intel(0): Modeline "1600x900"x0.0  107.80  1600 1648 1868 1970  900 904 908 912 -hsync -vsync (54.7 kHz eP)
[    15.167] (II) intel(0): Modeline "1600x900"x0.0   71.87  1600 1648 1868 1970  900 904 908 912 -hsync -vsync (36.5 kHz e)
[    15.331] (II) Quirked EDID physical size to 0x0 cm
[    16.462] (II) config/udev: removing device HID 04b3:3108
[    16.477] (II) evdev: HID 04b3:3108: Close
[    16.477] (II) UnloadModule: "evdev"
[    16.484] (II) config/udev: Adding input device HID 04b3:3108 (/dev/input/mouse0)
[    16.484] (**) HID 04b3:3108: Applying InputClass "ScrollPoint"
[    16.484] (II) No input driver specified, ignoring this device.
[    16.484] (II) This device may have been added with another device file.
[    16.558] (II) config/udev: Adding input device HID 04b3:3108 (/dev/input/event5)
[    16.558] (**) HID 04b3:3108: Applying InputClass "evdev pointer catchall"
[    16.558] (**) HID 04b3:3108: Applying InputClass "ScrollPoint"
[    16.558] (II) Using input driver 'evdev' for 'HID 04b3:3108'
[    16.558] (**) HID 04b3:3108: always reports core events
[    16.558] (**) evdev: HID 04b3:3108: Device: "/dev/input/event5"
[    16.603] (--) evdev: HID 04b3:3108: Vendor 0x4b3 Product 0x3108
[    16.603] (--) evdev: HID 04b3:3108: Found 3 mouse buttons
[    16.603] (--) evdev: HID 04b3:3108: Found scroll wheel(s)
[    16.603] (--) evdev: HID 04b3:3108: Found relative axes
[    16.603] (--) evdev: HID 04b3:3108: Found x and y relative axes
[    16.603] (II) evdev: HID 04b3:3108: Configuring as mouse
[    16.603] (II) evdev: HID 04b3:3108: Adding scrollwheel support
[    16.603] (**) Option "VertScrollDelta" "40"
[    16.603] (**) Option "HorizScrollDelta" "40"
[    16.603] (**) evdev: HID 04b3:3108: YAxisMapping: buttons 4 and 5
[    16.603] (**) evdev: HID 04b3:3108: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[    16.603] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4.2/1-1.4.2:1.0/0003:04B3:3108.0001/input/input26/event5"
[    16.603] (II) XINPUT: Adding extended input device "HID 04b3:3108" (type: MOUSE, id 9)
[    16.603] (II) evdev: HID 04b3:3108: initialized for relative axes.
[    16.603] (**) HID 04b3:3108: (accel) keeping acceleration scheme 1
[    16.603] (**) Option "AccelerationProfile" "2"
[    16.603] (**) HID 04b3:3108: (accel) acceleration profile 2
[    16.603] (**) HID 04b3:3108: (accel) acceleration factor: 2.000
[    16.603] (**) HID 04b3:3108: (accel) acceleration threshold: 4
[    21.372] (II) AIGLX: Suspending AIGLX clients for VT switch
[    39.885] (II) AIGLX: Resuming AIGLX clients after VT switch
[    39.885] (II) intel(0): switch to mode 1600x900@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[    39.926] (II) intel(0): switch to mode 1920x1080@60.0 on HDMI1 using pipe 1, position (0, 0), rotation normal, reflection none
[    40.097] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[9016.980] (EE) intel(0): Failed to submit rendering commands (No such file or directory), disabling acceleration.

Back to top
[SOLVED] X aceleration (intel i915) craps out on 4.13 kernels
wildstar84
Status: Interested
Joined: 31 May 2017
Posts: 32
Location: Texas
Reply Quote
This is SOLVED by either switching from the xserver-xorg-video-intel driver ("intel") to the kernel "modesetting" driver ("modesetting") -OR- upgrading to (the since-released) latest (v2:2.99.917+git20171229-1) version of the "intel" driver.

However, the "modesetting" driver has it's own quirks (much slower 2D rendering in certain situations, occ. pbms recognizing my laptop's screen - black screen upon resume, do NOT use "i915.fastboot=1, etc.).

NOTE: Since doing this, xserver-xorg-video-intel has had an upgrade release (v2:2.99.917+git20171229-1 in Debian Testing/Buster) in late December (after a several-year hiatus), that seems to have completely RESOLVED this! I've done some video stress-testing with it and it's now working superbly with v4.15.* kernels! Therefore, one should either upgrade to this latest version OR use the "modesetting" driver for this hardware.

One other note: One should turn OFF "BackingStore" for "intel" (Option "BackingStore" "false") but turn ON for the "modesetting" driver for best results! This was learnt by T&E.

Much googling shows that the "modesetting" driver is better for "modern" Intel hardware, but the old "intel" driver is better for "old" hardware. Observation tells me that my "Ironlake"/"Ivybridge" gear is now considered "old".

inxi:
:: Code ::
Graphics:
  Card-1: Intel Core Processor Integrated Graphics driver: i915 v: kernel
  Display Server: X.Org 1.19.6 driver: intel resolution: 1600x900~60Hz
  OpenGL: renderer: Mesa DRI Intel Ironlake Mobile v: 2.1 Mesa 17.3.8

Back to top
Display posts from previous:   

All times are GMT - 8 Hours