Need help with NFS mount [SOLVED]
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 254
Location: South Florida
Reply Quote
I am pretty sure that my /etc/exports is correct, it only states:
:: Code ::
/home/ckosloff notosh(insecure,rw)

In mi case crosshair is the server and notosh the client.
Crosshair is hard-wired and notosh is wireless, both are in same network.
I read the Debian reference handbook for NFS but still cannot get it right.
I did start service by
:: Code ::
service nfs-kernel-server start

The problem is when I attempt mount in notosh as root:
:: Code ::
mount -t nfs -o rw,nosuid crosshair.attlocal.net:/home/ckosloff /home/ckosloff/crosshair

Terminal goes into an endless loop and does not create mount.
I have to stop process with Ctl+C.
What am I missing?
Please help.

< Edited by ckosloff :: Feb 8, 16, 16:39 >

Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3787
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
crosshair.attlocal.net try replacing that with the server IP and see if it connects.

Also try getting rid of: -o rw,nosuid

which shouldn't be necessary, wasn't last I tried.

do these tries one at a time, first one, then do the next, and see.
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 254
Location: South Florida
Reply Quote
Thank you so much for the reply, I was really desperate.
The good news is I SOLVED IT!, but did not have time to tell you.
Here 's the scoop: there is a file liblockfile1 in testing repo, related to NFS.
As all stupid newbs, I installed that file in both machines, with the results mentioned above.
I did several tries, including IP addresses in both machines.
I was about to bang my head against the wall, when suddenly it dawned on me that the liblockfile1 might be the culprit, hint: lock :)
So I purged both files, rebooted both machines, got rid of the -o rw,nosuid (not necessary because the rw option was already in the export), then service nfs-kernel-server stop, then start, and that did the trick.
Granted, it is always safer to use internal IPs.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3787
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Using the domain is fine, I just suggested testing with IP to get rid of any possible networking issues with name resolving etc.

Good to know you fixed it, and found the cause, which is even better. Things starting to work without you knowing why doesn't usually help much.
Back to top
Display posts from previous:   

All times are GMT - 8 Hours