linux-headers-liquorix-amd64 have held broken packages
Status: New User - Welcome
Joined: 24 Mar 2015
Posts: 1
Reply Quote
Hello there:

:: Code ::
~$ sudo apt-get install linux-headers-liquorix-amd64
[sudo] password for marius:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 linux-headers-liquorix-amd64 : Depends: linux-headers-3.19-2.dmz.1-liquorix-amd64 (= 3.19-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have:

:: Code ::
~$ cat /etc/debian_version
~$ cat /etc/apt/sources.list

# deb cdrom:[Debian GNU/Linux 7.8.0 _Wheezy_ - Official amd64 NETINST Binary-1 20150110-14:41]/ wheezy main

# deb cdrom:[Debian GNU/Linux 7.8.0 _Wheezy_ - Official amd64 NETINST Binary-1 20150110-14:41]/ wheezy main

deb wheezy main contrib non-free
deb-src wheezy main contrib non-free

deb wheezy/updates main contrib non-free
deb-src wheezy/updates main contrib non-free

# wheezy-updates, previously known as 'volatile'
deb wheezy-updates main contrib non-free
deb-src wheezy-updates main contrib non-free

deb-src sid main
deb sid main

Any ideas?


Kind regards,
Back to top
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3956
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
3.19-2.dmz.2 is the current version.

Try running apt-get update again, then try the whole thing again.

If you still see issues, there may be an issue with the metapackage.

Also show, after running apt-get update again, and if you have issues still:
:: Code ::
apt-cache policy linux-headers-liquorix-amd64

apt-cache show linux-headers-liquorix-amd64

The show in particular will show if there is an actual problem in the dependencies of the metapackage, the policy will show what versions are actually in apt repos.

Also show inxi -r
to make sure we have all the repos, if there are further issues.
Back to top
Status: Interested
Joined: 04 Jul 2011
Posts: 15
Reply Quote
The OP has Debian Wheezy, so does not have the gcc-4.9 that the header package depends on. However, the MEPIS community repository does have Wheezy-compatible backports of the kernels in the testing repo:
Back to top
Status: Curious
Joined: 27 Jan 2017
Posts: 6
Reply Quote
I ran into this same issue on Ubuntu Xenial 16.04 and the Liquorix 4.9 builds, and had to install gcc-6 to resolve it.
Back to top
Display posts from previous:   

All times are GMT - 8 Hours