nVidia driver installs on Debian 3.16 but not Liquorix 3.16-7
Mono
Status: Contributor
Joined: 21 Jun 2012
Posts: 95
Reply Quote
Here is the log. I couldn't find an attach option and the code boxes don't use scroll bars so this is gonna be a loooooooooooong post.

EDIT: Well, that didn't work either. Pastebin:

pastebin.com/QSveRNBE
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 851
Reply Quote
I think the 3.16 kernel package for liquorix was based off of a really old kernel version from Siduction. If you want to use DKMS in debian without any issues, you'll need to upgrade to kernel 3.17 or higher.

Version 3.17 is in the past repository and 3.18 is in the current main repository.
Back to top
Mono
Status: Contributor
Joined: 21 Jun 2012
Posts: 95
Reply Quote
I was using sgfxi without DKMS.
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 851
Reply Quote
Right, I missed that.

However, you pointed out that the Debian 3.16 kernel can load the nvidia module but the Liquorix kernel cannot. I would suggest upgrading to the latest kernel on the main repository (currently 3.18.2), or installing the latest from the past repository (3.17.7).
Back to top
Mono
Status: Contributor
Joined: 21 Jun 2012
Posts: 95
Reply Quote
I installed Liquorix 3.18 and it still failed. Log:

pastebin.com/xdZVdvg9
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3990
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
I'm suspecting there is something else going on, everything works until it tries to actually load the module, which seems to build fine.

Make sure to note any possible irregular features of your system.

This type of failure however should be dealt with on nvidia forums I think:
devtalk.nvidia.com/default/board/98/

unless it's truly specific to liquorix, but even then it may be some corner case that is a bug in nvidia that only liquorix triggers.

Post: inxi -bplxxx
as well so we can confirm what you are actually running
Back to top
Mono
Status: Contributor
Joined: 21 Jun 2012
Posts: 95
Reply Quote
:: Code ::
~$ inxi -bplxxx
System:    Host: ronin Kernel: 3.16.0-4-amd64 x86_64 (64 bit gcc: 4.8.3)
           Desktop: Xfce 4.10.2 (Gtk 2.24.18) info: xfce4-panel dm: lightdm Distro: Debian GNU/Linux 8
Machine:   Mobo: ASUSTeK model: M5A99FX PRO R2.0 v: Rev 1.xx Bios: American Megatrends v: 2301 date: 01/06/2014
CPU:       Octa core AMD FX-8350 Eight-Core (-MCP-) speed/max: 1400/4000 MHz
Graphics:  Card: NVIDIA G73 [GeForce 7600 GS] bus-ID: 01:00.0 chip-ID: 10de:0392
           Display Server: X.Org 1.16.2.901 driver: nvidia Resolution: 1280x1024@60.02hz
           GLX Renderer: GeForce 7600 GS/PCIe/SSE2 GLX Version: 2.1.2 NVIDIA 304.125 Direct Rendering: Yes
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: a000 bus-ID: 0a:00.0 chip-ID: 10ec:8168
Drives:    HDD Total Size: 534.3GB (3.3% used)
Partition: ID-1: / size: 20G used: 8.2G (46%) fs: ext4 dev: /dev/sdd5 label: root
           ID-2: /boot size: 190M used: 52M (30%) fs: ext4 dev: /dev/sdd1 label: boot
           ID-3: /var size: 9.5G used: 1.9G (21%) fs: ext4 dev: /dev/sdd6 label: var
           ID-4: /home size: 198G used: 3.4G (2%) fs: ext4 dev: /dev/sdd4 label: N/A
           ID-5: swap-1 size: 3.15GB used: 0.00GB (0%) fs: swap dev: /dev/sdd3 label: N/A
Info:      Processes: 221 Uptime: 49 min Memory: 1229.2/7906.0MB
           Init: systemd v: 215 runlevel: 5 default: 2 Gcc sys: 4.9.1 alt: 4.4/4.6/4.8
           Client: Shell (bash 4.3.301 running in xfce4-terminal) inxi: 2.2.16


I have to use the iommu=pt kernel command option (bug or something with this chipset) to get my soundcard to work on this motherboard, but I was experiencing these problems before that.
Back to top
Display posts from previous:   

All times are GMT - 8 Hours