switch to systemd killed smxi command
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 284
Location: South Florida
Reply Quote
A recent upgrade in testing branch switched my systems from sysvinit to systemd, with the result of rendering the smxi command unusable.
Init 3 kills the UI alright but does not give a prompt.
Looks like Debian is moving to systemd so adjustments will need to be made in smxi.
For systemd the concept of runlevels is obsolete so giving the option in smxi to select default runlevel will also to be changed.
Back to top
sedonix
Status: Contributor
Joined: 09 Sep 2008
Posts: 56
Location: Sedona, AZ
Reply Quote
Here on sid, I have had systemd for awhile. Never even thought about or noticed a problem with smxi/sgfxi. I don't even think about run levels. I just do ctl+alt+F1 to a prompt, root, pswd to a prompt and away I go. I have never done it differently or noticed a problem. Are we on the same page?
Back to top
sedonix
Status: Contributor
Joined: 09 Sep 2008
Posts: 56
Location: Sedona, AZ
Reply Quote
Hold the phone! I double checked my I386 & amd64, both on the same computer and all is OK. I then checked my I386 laptop and sure enough, there is the problem per ckosloff. All are up to date with sid and using systemd.
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 284
Location: South Florida
Reply Quote
That is what I am doing Ctl + Alt + F1 to shut down desktop.
Please note that this does NOT shutdown desktop completely, I think that it only moves it to the background.
After that I still have to use command smxi to shutdown desktop.
Probably it is a mask for something like sytemctl stop lightdm.service or similar.
Then I can use smxi, have not tried yet to restart desktop from smxi, I do know that after running it Ctl + Alt + F7 won't work.
I could try systemctl start lightdm.service.
I still think that option to set default runlevel in miscellaneous tweaks should be removed.
Later.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3986
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
smxi has systemd support, but reading this, I think that it only supports the case of starting with systemd, not an upgrade bringing in systemd.

I'll take a look at it, may need a second post du check and reset init type globals.
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 284
Location: South Florida
Reply Quote
:: malik125 wrote ::
Then I can use smxi, have not tried yet to restart desktop from smxi, I do know that after running it Ctl + Alt + F7 won't work.
I could try systemctl start lightdm.service.

I always do a full reboot after smxi, which you will need after a kernel upgrade anyway, just type 'reboot' after exiting smxi.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3986
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
if a new kernel was installed, and if you do NOT use the kernel metapackages, then smxi, and sgfxi, always ask you if you want to reboot.

I believe though I'm not certain that it may or may not ask you if you used metapackages, I think it tries to detect it, though if it's a debian kernel where the standard kernel version doesn't change, like a stable patched kernel, then smxi won't know.

The actual topic of this thread was about the switch to systemd DURING The smxi upgrade, the fact that smxi then tried to use sysv to reboot or start the desktop, that issue was always valud because smxi does not reset its internal values for systemd after the upgrade, I never got around to doing that, lazy, but if you then restart smxi, it will of course correctly detect that it's systemd running the system and use the appropriate commands for systemd.

inxi, smxi, and sgfxi all got sysv/systemd support at about the same time, and inxi and sgfxi also got upstart support as built ins.
Back to top
Display posts from previous:   

All times are GMT - 8 Hours