ERROR:(197) wget error for 173.14.39
kmathern
Status: Interested
Joined: 11 Jan 2010
Posts: 13
Reply Quote
When sgfxi tries to install the 173.14.14 driver it errors out with the following error:
:: Code ::
ERROR: (197) The graphics driver installer: NVIDIA-Linux-x86-173.14.39-pkg0.run failed to download - wget error.
Here's a dropbox link to the sgfxi.log dl.dropboxusercontent.com/u/18456966/sgfxi.log-173%2C14%2C39-download-failed

It's trying to download NVIDIA-Linux-x86-173.14.39-pkg0.run from: ftp://download.nvidia.com/XFree86/Linux-x86/173.14.39/NVIDIA-Linux-x86-173.14.39-pkg0.run, which doesn't seem to be at that location according to the wget --spider command
:: Code ::
wget --spider ftp://download.nvidia.com/XFree86/Linux-x86/173.14.39/NVIDIA-Linux-x86-173.14.39-pkg0.run
--2014-01-08 08:50:04--  ftp://download.nvidia.com/XFree86/Linux-x86/173.14.39/NVIDIA-Linux-x86-173.14.39-pkg0.run
           => 'NVIDIA-Linux-x86-173.14.39-pkg0.run'
Resolving download.nvidia.com (download.nvidia.com)... 199.2.204.160, 199.2.204.150
Connecting to download.nvidia.com (download.nvidia.com)|199.2.204.160|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD (1) /XFree86/Linux-x86/173.14.39 ...
No such directory 'XFree86/Linux-x86/173.14.39'.


I do find the 32bit 173xx driver at this http url: us.download.nvidia.com/XFree86/Linux-x86/173.14.39/NVIDIA-Linux-x86-173.14.39-pkg0.run
:: Code ::

wget --spider http://us.download.nvidia.com/XFree86/Linux-x86/173.14.39/NVIDIA-Linux-x86-173.14.39-pkg0.run
Spider mode enabled. Check if remote file exists.
--2014-01-08 09:07:46--  http://us.download.nvidia.com/XFree86/Linux-x86/173.14.39/NVIDIA-Linux-x86-173.14.39-pkg0.run
Resolving us.download.nvidia.com (us.download.nvidia.com)... 63.216.54.169, 63.216.54.168
Connecting to us.download.nvidia.com (us.download.nvidia.com)|63.216.54.169|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 15134997 (14M) [application/octet-stream]
Remote file exists.

and the 64bit version here: us.download.nvidia.com/XFree86/Linux-x86_64/173.14.39/NVIDIA-Linux-x86_64-173.14.39-pkg0.run
:: Code ::
wget --spider http://us.download.nvidia.com/XFree86/Linux-x86_64/173.14.39/NVIDIA-Linux-x86_64-173.14.39-pkg0.run
Spider mode enabled. Check if remote file exists.
--2014-01-08 09:12:00--  http://us.download.nvidia.com/XFree86/Linux-x86_64/173.14.39/NVIDIA-Linux-x86_64-173.14.39-pkg0.run
Resolving us.download.nvidia.com (us.download.nvidia.com)... 63.216.54.185, 63.216.54.169
Connecting to us.download.nvidia.com (us.download.nvidia.com)|63.216.54.185|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 16657522 (16M) [application/octet-stream]
Remote file exists.

Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4075
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Nvidia uses 3 download locations, and sometimes they forget to distribute certain drivers to all of them. Or it's intentional, I can't say.

I didn't test it when I added the driver, sorry.

It's now downloading as expected from us.download.nvidia.com in sgfxi.

sgfxi has built in tests to assign the right download location, but usually it's not necessary to use a different one than default.

sgfxi is updated and works now.
Back to top
Display posts from previous:   

All times are GMT - 8 Hours