Default run levels [SOLVED]
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
I recently had to reinstall a computer and followed the drill, netinst testing CD, no Debian desktop environment, installed smxi and took it from there.
Video issues solved, sorry to disrupt your constructive rock conversation in chat room :-).
I had to solve the brutal way, your friends at siduction were not very forthcoming, but I learned (I take everything phylosophically).
I noted that default run levels used to have an option aptosid defaults, which you appropriately renamed.
I need to know what number run level should I choose to get that, init 3 no longer shuts down the desktop, I have to use smxi for that.
Run level 5 should restart X, right?
On another note, neither init 3 (on other computers that I setup previously) or smxi closed appropriately X, when in console smxi most of the time prompts me to select option 1 Shutdown...
Thanks.

< Edited by ckosloff :: Sep 11, 13, 5:08 >

Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4076
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
runlevels are set however you want them, debian defaults to everything runlevel 2. smxi has the run level tool that re-adjusts runlevels to be a more reasonable 2 for everything BUT the desktop, which starts at 3 or 5.

I have no idea, nor will I ever have any idea, why debian chose this silly default when they could trivially have made user systems much easier to debug and fix with graphics issues by having runlevel 2 (or 3/5 as in redhat type defaults) always open to console/terminal, and the user x desktop always starting in 3 or 5.

Back in the days when I helped support a lot of debian users via sidux etc, this always caused issues, trying to solve a failed driver issue when you can't easily even access terminal/console is not fun, particularly not for new uers, that's why I added the runlevel changing tool in smxi misc tweaks.

Changes in the core system since then may at one point break that tool, I don't know, I havne't tried it in a long time.
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
:: techAdmin wrote ::

Changes in the core system since then may at one point break that tool, I don't know, I havne't tried it in a long time.

I am now using the testing branch, jessie or Debian 8, whatever you want to call it, and very pleased with it.
Solved dual monitor and video problems that haunted me for years.
So this question is basically a curiosity, as root I cannot shut down desktop with either runlevel 2 or 3, I am constrained to use the smxi command, option 1.
It works, but not elegant, so my question is: when the option "aptosid defaults" was available I could shut down desktop with option 3, what number should I select in smxi now to get this behavior?
Let me clarify that I reloaded the whole system from scratch with the netinst CD for testing, and loaded everything with external monitor unplugged, when all drivers installed, I plugged in monitor and KDE installed it without a glitch.
My experience shows that loading system on a laptop with external monitor plugged in tends to fuse them and then you just have a clone and all sorts of problems.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4076
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
I believe I covered the question. I don't remember anything about the various options to shut down, but they are all largely irrelevant since the actuality is that in debian everything is in runlevel 2, and until you use the feature to change those runlevels to something like 2/3 or 3/5 (which was the default if I remember for sidux etc as well), everything will keep being in runlevel 2, ie, you can't start your system without the desktop also starting.

If you do not want this, then use 2/3 or 3/5 runlevels.

It's largely irrelevant what the options are called, if you run debian, all you need is for the desktop to start in 3, ei, not 2 or 1.

I don't actually understand the question to be honest, if you want to shut down your desktop, or leave it to go to console, the options are the same as they always have been:

logout, then hit ctrl + alt + F1, login as root, and shutdown your login manager, like: service kdm stop

this will kill the desktop and leave you logged in console.

If you change the desktop start runlevel to 3, then you can also type 2 at grub and boot that way into console.

Sometimes it's useful to explain what you are actually trying to do, then ways to do that can be shown. I don't see any particular issue with smxi here however, using ctrl + alt + F1 (actually F1-F6 on most systems, ie, you can run 6 consoles and move between them, which I do a lot) to get out of X has always been a unix standard method, so if that's what you are asking, that's how you do it. If you want your desktop session state saved, you logout, then do the ctrl alt f1 thing.
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
:: techAdmin wrote ::
I believe I covered the question. I don't remember anything about the various options to shut down...

Here is what I wanted to know: I wanted the "aptosid defaults" under another name.
I tried to fool around with run levels, and when attempting to load Debian defaults, smxi warned me that I was missing files, one of them was sysrv.conf or something like that.
I accepted the install of three files and then set runlevel to 5, which I believe is now option 4 in smxi.
If you have all files installed then runlevel 5 is what gives the "aptosid defaults".
I can shut down desktop with init 3 and restart it with init 5.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4076
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Illl have to look at it, but I have removed everything related to aptosid from my memory so don't expect me to remember anything about that.

However, within smxi, there are certain texts and options that show only if you have those sources present, so you would/should see no options related to aptosid if you have none of their sources.

if you run debian, you will see 'debian-defaults' as theoption, for example, how could you see defaults for a distro that you have no sources for? at least that's the thinking.

So if you're looking for identical smxi outputs with a different base system, you will look a long time, since that's a feature of smxi to show different outputs for different systems.

in this case, for example, debian defaults restores, well, debian defaults.
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
I don't have any aptosid sources, and not looking for them.
I just wanted to replicate that behavior and I did: init 3 to shut down desktop, init 5 to launch desktop, init 6 to restart.
It wasn't working like that for me, but I solved by installing the packages smxi prompted me for and setting run level to 5.
This issue is [SOLVED].
Back to top
Display posts from previous:   

All times are GMT - 8 Hours