inxi bsd alpha now out and somewhat running!
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4073
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
inxi bsd is under way, still in alpha state.
is the download location.

for debian kfreebsd:
debian gnu/kfreebsd is totally untested at this point, so no idea if that logic works, that's basically just inxi plus the latest patch versions for bsd that aren't live yet in regular inxi. inxi itself will detect if it's a bsd environment, or should, but for systems without gnu tools like freebsd etc, there's other changes required, so the bsd branch is the right one there.

To update inxi to latest version of bsd branch, do this command:
inxi -! 15
IMPORTANT: inxi bsd does NOT run in linux!!

<update: as of 1.8.37 version, inxi bsd and linux are the same logic, so both will run in the other system type. The bsd branch however will have the latest updates, as time permits, and only once those are reasonably stable will they be found in the trunk/inxi branch, the current stable that is, which you'll see by a version number bump

The bsd branches can be tracked by looking at the patch number, not the main version number. Once enough patches are added to that branch, it becomes the new current stable inxi again.>

To update inxi to latest version of debian kfreebsd branch, do this command:
inxi -! 16
This does run in linux, for now anyway. So you can actually use that for the latest inxi version, it's currently ahead of regular inxi versions, but that won't last for too long.

this will download the latest inxi and let you know the version info etc, all automatically. If you are root it will also install man1 file for inxi into /usr/share/man/man1 which seems to be the same path in freebsd, but only if that directory exists. The first time you download inxi it won't install the man page, but if you update it as root again with -! 15 (on bsds) or -U ( on linuxes) it will then also grab the man file.

In freebsd, these are now working, to some degree:

inxi -r (shows repo/ports data)
inxi -f (shows cpu flags)
inxi -C (shows cpu data, now also has flags, I believe no bogomips data is available in bsd systems)
inxi -Sxx (system info, various, desktop output is untested)
inxi -Ixx (General info, most of it works now, just got memory working right, it needed hw.physmem for the real memory amount, not, oddly, Real Memory, which appears to not correspond to anything about real memory: who would figure?) <update: the memory issue has been corrected, and should now be correct. I am using hw.physmem for that data>
inxi -G ( graphics info, shows some, if you have the recommends for xorg installed, will show more)
inxi -p (works partially, partitions)
inxi -b (basic output format)
inxi -i (wan ip, part of it works, but not all, doesn't show lan IP of ethernet id)
inxi -t (c works, sorts cpu, -m doesn't sort memory of ps aux)
inxi -M (I'm told it works but I don't have root access on the box so I can't use dmidecode, but I have seen the output and it was right. So far it works and should keep working)

if lm-sensors are installable on bsds, -s probably works. Update: lm-sensors is not available, and the latest branches show that information to the user.

Does not work:
inxi -R (md raid data, how do you get that information?)
-A (audio)
-o (unmounted partitions)
-l (partition labels)
-u (partition UUID)
-d (optical drive data)

inxi -D (hard drive data)
-n / -N (networking data, doesn't work yet)

All the non hardware functions work, like -c (color options), -h/-H/--help options. --recommends works, will be fine tuned for bsd systems later.
-U works, all the alternate -! update options work.
-V/--version works.

And most important, inxi -xx@ 14 works, which uploads debugger data to my server, which I sorely need for bsds.

So far only tested on freebsd, but it's looking good for pcbsd as well.

And that's that.

Let me know if you get to it if anything works on openbsd, but objectively I'd target freebsd first, then pcbsd, then openbsd, then netbsd last.

I squelched most of the errors today so it's actually somewhat running but the main system info lines don't work yet, I'll see about that data, pciconf is a good one and I hope it's on more bsds than fewer.

No bug reports will be accepted since I know things barely work, but feel free to show: inxi -v7 -rtcm output if you want.

And upload inxi -xx@ 14 data as well, I'm adding more stuff to that as I discover the tools and methods.

:: Code ::
./inxi -rfv7 -tcm -z
System:    Host: diabolus Kernel: 9.1-RELEASE amd64 (64 bit)
           Console: tty 0 Distro: FreeBSD 9.1-RELEASE
Machine:   No /sys/class/dmi, using dmidecode: you must be root to run dmidecode
CPU:       Octa core AMD FX-8150 (SMP) cache: unknown  bmips: N/A clocked at 3612 MHz
           CPU Flags: abm aesni apic avx clflush cmov cmp cr8 cx16 cx8 de extapic ffxsr fma4
           fpu fxsr htt ibs lahf lm lwp mas mca mce mmx mmx+ mon msr mtrr nodeid nx osvw osxsave
           pae page1gb pat pclmulqdq pge popcnt prefetch pse pse36 rdtscp sep skinit sse sse2 sse3
           sse4.1 sse4.2 sse4a ssse3 svm syscall topology tsc vme wdt xop xsave
Graphics:  Card: Failed to Detect Video Card!
  1.7.7 driver: nvidia tty size: 164x58 Advanced Data: N/A out of X
Network:   Card: Failed to Detect Network Card!
           WAN IP: <filter> IF: fwe0 ip: N/A ip-v6: N/A
Drives:    Optical: No optical drives detected.
Partition: ID: / size: 52G used: 968M (2%) fs: ufs dev: /dev/ada1p2
           label: N/A uuid: N/A
           ID: /threetb size: 4.3T used: 207k (0%) fs: zfs dev: N/A
           label: N/A uuid: N/A
           ID: /threetb/data size: 5.9T used: 1.6T (27%) fs: zfs dev: N/A
           label: N/A uuid: N/A
           ID: /twotb size: 1.8T used: 32k (0%) fs: zfs dev: N/A
           label: N/A uuid: N/A
           ID: /twotb/data size: 1.9T used: 100G (5%) fs: zfs dev: N/A
           label: N/A uuid: N/A
           ID: /usr size: 1.9T used: 25G (1%) fs: zfs dev: N/A
           label: N/A uuid: N/A
           ID: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/md0
           label: N/A uuid: N/A
RAID:      No RAID data available - /proc/mdstat is missing - is md_mod kernel module loaded?
Unmounted: ID: N/A size: N/A label: N/A uuid: N/A
Sensors:   None detected - is lm-sensors installed and configured?
Repos:     Active BSD repo servers in file: /etc/portsnap.conf
Processes: CPU - % used - top  5 active
           1: cpu: 704.5% daemon: ~idle~ pid: 11 mem: 0.12MB (0.0%)
           2: cpu: 64.4% command: git-svn (started by: perl) pid: 48476 mem: 3038.53MB (9.3%)
           3: cpu: 2.4% command: tmux: pid: 2046 mem: 7.78MB (0.0%)
           4: cpu: 2.1% daemon: ~kernel~ pid: 0 mem: 5.08MB (0.0%)
           5: cpu: 0.6% command: top pid: 66490 mem: 2.17MB (0.0%)
           Memory - MB / % used - top  5 active
           1: mem: 2.66MB (0.0%) command: postgres pid: 1793 cpu: 0.0%
           2: mem: 2.58MB (0.0%) command: postgres: pid: 1796 cpu: 0.0%
           3: mem: 2.54MB (0.0%) command: postgres: pid: 1797 cpu: 0.0%
           4: mem: 2.53MB (0.0%) command: postgres: pid: 1798 cpu: 0.0%
           5: mem: 2.88MB (0.0%) command: postgres: pid: 1799 cpu: 0.0%
Info:      Processes: 93 Uptime: 10 days Memory: 28074.2/32678.3MB Gcc sys: 4.2.1
           Client: Shell (bash 4.2.42 running in tty 0) inxi: 1.8.36-15-bsd

note the -bsd id, if you have gnu/kfreebsd debian it would show -dgbsd
Back to top
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4073
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Update: thanks to some suggestions from nox, inxi 1.8.37 is the single stable release for bsd/linux systems, one inxi to do it all, heh.

The development branches continue to be branches/bsd and branches/gnubsd, but I don't see a lot of use for the gnubsd at this point, but I'll watch to see if anything goes on.

Once you've installed 1.8.37, you can update to current trunk safely with -U, and if you want to see the latest bsd features being worked on, use (for real bsds) inxi -! 15 or inxi -! 16 for gnubsd, debian's kfreebsd that is, though currently there's no difference between the two versions anymore.

So 1.8.37 or newer will support, to whatever degree is done, linux and bsd.

Coming soon, inxi -m, for ram data, that uses a feature just integrated into -M for dmidecode information. -m will require root to run it for output, and of course will require dmidecode to be installed.

Sadly, I can't get the actual manufacturer data from dmidecode for ram, that would be nice, and the speed will reflect the lowest speed of all the ram you have installed. But this -m option is not done yet, it's just closer to arriving.
Back to top
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4073
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
1.8.38 ( and current bsd branch patched versions as of today)

-p should now have full output. zfs raid devices filtered out, zfs raid slices listed, as slices of raid device. Untested for other raid types in bsd, if you have for example gmirror please post the output here, and of df -hT so I can see what that syntax is, if different. If it's the same, it should get identified.

Now shows labels/uuid with -u/-l if gpart list returns data for the drives. I have found no way to list zfs data in terms of labels.

Null CPU / Memory handled, this can happen on servers where you do not have root, and can't use sysctl / /var/run/dmesg.boot due to permissions issues.

better null value for Raid/Sensors for bsd now, shows that inxi does not yet support that.

New options: -! 31 - turns OFF host: in System line; -! 32 - Turns ON host name if disabled via config file.

Fixed bug that crept in that would have broken remotely mounted file system identification in partitions.

Fixed csh version numbering issue.
Back to top
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4073
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
1.8.40 (and newer current bsd patch versions)

-R now shows zfs raid component state of failed or spare like it does with mdraid.
Back to top
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4073
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
bsd branch: 1.8.42-4 and newer:

added 'not supported for bsd yet' notifications to -o unmounted partitions, -D hard disk data, basic and long form.

These will also be signposts for progress, along with the missing pci type card data for network, graphics, audio.
Back to top
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4073
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
1.8.44 and newer bsd branch version inxi now more or less supports the pci card options -A, -G, -N/-n/-i. the networking stuff is more or less complete.

This leaves -o, -D, -d as to do. If you notice a pattern there you'd be right, those are all related to disk use, which is harder to do in bsds than linux, and doesn't work quite as neatly as in linux, but we'll get there by chipping away at it.

The -n/-i stuff was surprisingly easy, though tedious, to get implemented.

I'm still looking to find a way to determine what compiler / version was used to compile the bsd kernel for the -C option line.

I have not tested the other graphics parts of -G but assume they work more or less the same as they do in gnu/linux.

-A, -N have no usb type support yet but otherwise it seems to work as expected.

-R is now complete for zfs raid, more or less.
Back to top
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4073
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Version 2.2.9

Massively improved BSD support.

features now supported, usually, or at least with good error handling when not:

-d -optical disk - advanced output features not available
-D - hard disk - advanced output features not available
-I memory, used and total
-r ports servers, for freebsd, openbsd, dragonfly bsd.
-C improved core count, cpu count, cpu speed, max speed/min spped in some cases (freebsds mostly). This can still be improved, since freebsd lists both package (phy cpu) and core counts but I'm not using that at this point.
-f and -C cpu flags now should be much better across BSDs, though may not work in all cases, but it's better.

Too many glitches to note.

For pci card output, that's -N,-G,-A, you need either pciconf or lspci.

there are bsd ports of lspci, so if the system doesn't have pciconf, just add lspci. There's also lsusb support possible if your os has that in its ports.

-m support, based on dmidecode, was working out of the box.

Still not working: -s and -o. I don't see any practical way to get those working though if I get enough datasets from bsd users maybe I'll see something I missed.

2.2.9 is a bit beyond my original feature set that 2.0.0 was supposed to have complete, but better late than never.

Still poorly if at all handled are zfs and hammer file systems in both -D and -p/-P outputs, I assume the same issue appears with btrfs so that's not particularly a bsd thing, just a file system thing.
Back to top
Display posts from previous:   

All times are GMT - 8 Hours