Comments on new install of Debian testing
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
I just started my KDE desktop after following instructions in thread, it is a bit outdated, as techadmin warned.
I burned the nightly build of the testing distro using the burniso aptosid script (based on wodim).
I had to give it several tries because....I am working on a battered laptop with a broken battery which I reverse-inherited from my son, who moved to better things.
Advanced options was not working for me, the business card CD was freezing, it finally went through with "expert install", which gave me all the choices outlined in thread.
I found the description of screens unnecessary, because Debian selects defaults extremely accurately, and explains everything very clearly on the screens.
I did uncheck desktop manager and used only targeted drivers.
Installation finished uneventfully.
I had no graphics and no desktop environment.
But here is where the smxi magic helped me.
I installed from the console and went through all the screens.
WOW!!
I installed everything (including Liquorix) I needed without bloat, cleaned up, and here I am in a full-blown KDE.
THANKS TECHADMIN!! (ckosloff tips hat).
I don't know what the heck the aptosid guys were thinking when they disaffected you.
I suggest that you remove aptosid sources from smxi.
I did not install them because I really cannot figure out why slh pulls kernels like two or three times per week, and I fear that he is experimenting on users.
These packages did not install:
1) java-plugins, probably because Java removed from testing repo.
2) rbxi, maybe already installed.
3) apache2-configuration.
4) komba2, not available in testing, might have to pin that one.
Will be back later with more questions.
In the meantime, let me bask in the relief I feel after getting a stable rolling distro, which is also easy to manage.
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
Few things I need to add.
First, is that I partitioned HDD before installing, with Gparted Live.
This gives a much simpler and error-free installation IMHO.
I just had to select sda2, which was already formatted to ext 4, mount as root, and set the bootable flag, the installer does that effortlessly.
sda1 was already set as swap, they were already formatted, but I let Debian do the reformat, maybe an unnecessary step since Gparted Live also uses Debian.
The business card expert install is really VERY easy, the only important thing is to uncheck DM, otherwise Debian will install Gnome, and only install targeted drivers.
I got just one error, the Nepomuk service was not installed properly, but I already knew that I had to install virtuoso-minimal, thanks to slh.
Hey, there must be some good in him.
I could never get desktop effects to work in aptosid, but with Liquorix and targeted drivers they were there out of the box.
Java has its problems, I finally got it to work in iceweasel but don't know exactly how, just looked at packages in synaptic (which I installed from console), and installed those that looked good to me.
I got rid of two myths: that aptitude is bad and that Debian installer is difficult.
Maybe three, I installed lots of packages while in X, and restarted computer afterwards, did not learn yet how to close X in Debian native.
But that is the matter of another post.
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
I have to correct something.
In business card install, Advanced Options does work.
You have to select that, then expert install.
BTW, Advanced Options also offers the choice of alternative desktop environments, i.e. KDE, LXDE, XFCE, but I did not select any of those because I was going to do that at a later stage with smxi.
I read something from techadmin warning about metapackages installed if that option is selected, so I decided to go with smxi.
I guess that wraps it up for installing with business card and smxi.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4043
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Debian's desktop metapackages are a disaster, and end up often installing all of the desktop package group, not a pleasant experience to clean it up after.

What I did in smxi desktop package installer was pick apart each package group and select the ones that are required for a barebones desktops, then add if it seemed a good idea also an extras group with stuff many users, but not all, will want.

Theere is another option on the base debian business card install, when you get to the section on packages to install, that is always checked, the base system, and that should also be unchecked, since it includes stuff you may not want or need.

Also worth noting is that debian apt default now is a totally silly item to install always recommends by default, which is just plain stupid, they are recommends, not dependencies.

smxi turns this off when it runs, but if you use apt without it and have not set an apt config file manually to not do that, it will do that. That's a bad clutter generator too.

That's a tweak I thought of adding to smxi a long time ago as well, edit updating the apt config file, but the bottom line, each such feature then requires permanent ongoing support to maintain. Such as the now defunct java installer you discovered, for example. Still I think works in squeeze, not sure.
Back to top
ckosloff
Status: Contributor
Joined: 21 Dec 2011
Posts: 292
Location: South Florida
Reply Quote
You are totally right regarding apt defaults.
Those recommends do not always exist, I am talking for my experience on Sid.
So if you attempt to install a recommended package you get error not found.
Also, yes, if you go that route you will have endless clutter, with those that do exist.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4043
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
for new preferences, do this:

:: Code ::

echo '// auto-remove breaks on meta packages
APT::Get::AutomaticRemove "0";
APT::Get::HideAutoRemove "1";

// Recommends are as of now still abused in many packages
APT::Install-Recommends "0";
APT::Install-Suggests "0";
Debug::pkgAutoRemove "0";
' > /etc/apt/apt.d/80ckosloff


the 80 in the file name is the priority of the preference, and the letters after it can be anything, I used your nick in this case.

This will turn off installing recommends, and turn off autoremove. I'm not positive if you want to turn off autoremove, that does have utility, but you definitely want the recommends off.

Note that you should always end a config file with a newline, sometimes they care, sometimes not, so easier to just do it.
Back to top
Display posts from previous:   

All times are GMT - 8 Hours