updating grub2 checks
Status: Assistant
Joined: 21 Sep 2008
Posts: 358
Location: Australia
Reply Quote
If you run smxi or manually or automatically update a new kernel or get newer grub2 packages


please check before rebooting that any command using root powers of

:: Code ::

has no errors BEFORE doing a reboot please


My issues

PART 1 Did a software only update no kernel update

I did have an error against sda2 on first attempt which is my second linux backup

2) Todays smxi showed a newer grub2 and I got an error that said roughly....Bootloader conf not recognised and I needed to set root ID as a kernel parameter (as UUID) and set boot device ID to install or update the bootloader

a) so I checked my /boot/grub/device.map and its id was a match to the specified pathway

:: Quote ::

--------contents------as an example----I have only one drive
(hd0) /dev/disk/by-id/ata-WDC_WD800JD-00LSA0_WD-WMAM9X402976

b) I ran fdisk /dev/sda and checked a bootable flag was against my bootable partition ......as I have tinycore on my second partition

c) I inspected the contents of my /boot/grub/grub.cfg and it already specified by-UUID

altho you can have a by-label as well ....in your 40_custom

d) ran update-grub and rebooted now ok


I then did a new run of smxi and updated the kernel and got a new grub2 error talking about a bad mkintrd issue and in particular the smxi running of smxi showed

:: Quote ::

generating grub.cfg
found background image: /pathway/etc
found linux image: /pathway/etc
found initrd image: /pathway/etc
[645.146983 ext3-fs (sda2) error write access unavailable - can not proceed

When smxi had finished I run


got an error but this time I knew I had not completely fixed my sda2 earlier issue so ran

e2fsck -f /dev/sda2

all good

rebooted ok
Back to top
Display posts from previous:   

All times are GMT - 8 Hours