Why no Speedstep on Centrino CPUs?
ak_tone
Status: New User - Welcome
Joined: 16 Sep 2010
Posts: 2
Reply Quote
Hi damentz,

is there any reason why centrino speedstepping is disabled in your kernel config? I tried out your kernel 35 on my Ubuntu Lucid Laptop with a 1,6GHz Centrino CPU and was surprised by the much better responsiveness of the system, but the (very loud) fan of my laptop didn't spin down after boot time as always, just because the frequency didn't step down. Then I looked into your config and saw that speedstepping for centrinos was commented out there. Is this on purpose? That would be very sad, because then I couldn't use your kernel or I have to compile it on my own (which I wanted to prevent)
Thanks
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 914
Reply Quote
:: Code ::
Intel Enhanced SpeedStep (deprecated) (X86_SPEEDSTEP_CENTRINO)

CONFIG_X86_SPEEDSTEP_CENTRINO:

This is deprecated and this functionality is now merged into
acpi_cpufreq (X86_ACPI_CPUFREQ). Use that driver instead of
speedstep_centrino.
This adds the CPUFreq driver for Enhanced SpeedStep enabled
mobile CPUs. This means Intel Pentium M (Centrino) CPUs
or 64bit enabled Intel Xeons.

To compile this driver as a module, choose M here: the
module will be called speedstep-centrino.

For details, take a look at <file:Documentation/cpu-freq/>.

If in doubt, say N.


You cannot use acpi-cpufreq?
Back to top
ak_tone
Status: New User - Welcome
Joined: 16 Sep 2010
Posts: 2
Reply Quote
ok, that was the info i needed. but i had to manually add it to /etc/modules to load at bootup, is this normal? the default ubuntu kernel seems either to use the deprecated module, or loads acpi_cpufrequ automatically. but interestingly within the ubuntu kernel-config the centrino-speedstep option is still on.
thanks for your help
Back to top
Display posts from previous:   

All times are GMT - 8 Hours