2.6.35-0.dmz.2-liquorix-686 - pointer icon is invisible
kolchak
Status: New User - Welcome
Joined: 06 Aug 2010
Posts: 1
Reply Quote
Greetings! I've used Linux for a while, but I'm new to changing out kernels & such, so please bear with me.

I recently did a fresh install of Debian squeeze with a minimal XFCE desktop on Thinkpad X40; everything worked well. Having seen Liquorix mentioned quite a bit in the crunchbang forums, I thought I'd give it a try.

I installed linux-image-2.6.35-0.dmz.2-liquorix-686 (and linux-headers...) via synaptic, and rebooted. It seems that with the new kernel, the pointer icon becomes invisible. I switched back & forth a couple of times between Liquorix & the stock kernel, and it happened every time with Liquorix.

Any suggestions on what I can do? Suggestions that are anatomically possible, that is... ;)

Thanks!
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 746
Reply Quote
Could you post your specs?

inxi -F should be good enough for what I'm looking for. You can get the script from techpatterns.com/inxi

For example:

:: Code ::
damentz@damentz64:~$ inxi -F
System:    Host damentz64 Kernel 2.6.35-0.dmz.4-liquorix-amd64 x86_64 (64 bit) Distro Debian GNU/Linux squeeze/sid
CPU:       Dual core Intel Core i5 M 520 (-HT-MCP-) cache 3072 KB flags (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips 9577.62
           Clock Speeds: (1) 1199.00 MHz (2) 1199.00 MHz (3) 1199.00 MHz (4) 1199.00 MHz
Graphics:  Card nVidia GT216 [GeForce GT 330M] X.Org 1.7.7 Res: 3040x900@50.0hz
           GLX Renderer GeForce GT 330M/PCI/SSE2 GLX Version 3.3.0 NVIDIA 256.44 Direct Rendering Yes
Audio:     Card-1 nVidia High Definition Audio Controller driver HDA Intel BusID: 01:00.1
           Card-2 Intel 5 Series/3400 Series Chipset High Definition Audiodriver HDA Intel BusID: 00:1b.0
           Sound: Advanced Linux Sound Architecture Version 1.0.23
Network:   Card-1 Marvell 88E8057 PCI-E Gigabit Ethernet Controller driver sky2 v: 1.28 at port a000 BusID: 04:00.0
           Card-2 Atheros AR9285 Wireless Network Adapter (PCI-Express) driver ath_pci v: svn BusID: 02:00.0
Disks:     HDD Total Size: 750.2GB (57.9% used) 1: /dev/sda WDC_WD7500BPVT 750.2GB
Partition: ID:/ size: 24G used: 12G (52%) fs: ext4 ID:/boot size: 251M used: 43M (18%) fs: ext3
           ID:/home size: 664G used: 394G (60%) fs: ext4 ID:swap-1 size: 0.90GB used: 0.00GB (0%) fs: swap
Sensors:   System Temperatures: cpu: 46.0C mobo: 46.0C gpu: 0.0:46C                                                                   
           Fan Speeds (in rpm): cpu: N/A                                                                                               
Info:      Processes 186 Uptime 8 min Memory 581.5/3884.7MB Runlevel 5 Client Shell inxi 1.4.12


In the meantime, I'm suspecting that your graphics card is radeon. Try booting with nomodeset in your kernel parameters.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3905
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
damentz, that was my suspicion as well, re the radeon card.
Back to top
The Garage
Status: Curious
Joined: 08 Jun 2009
Posts: 7
Reply Quote
Same "mouse pointer invisible" problem for me using 2.6.35-3.
Intel video.

Interestingly enough, when I connected to the laptop with the mouse pointer problem from my desktop using krdc for vnc the mouse pointer was visible on the remote machine!

I tried the nomodeset fix not knowing if it would work on intel, but still no mouse pointer.

Works fine with 2.6.33.something....

Here's my inxi -F

:: Code ::
~$ inxi -F
System:    Host garage-laptop Kernel 2.6.35-3.dmz.1-liquorix-686 i686 (32 bit) Distro sidux 2008-01 ??? - kde-full - (200804120009)
CPU:       Single core Intel Pentium M (-UP-) cache 2048 KB flags (sse sse2) bmips 2992.97 clocked at 1500.00 MHz
Graphics:  Card Intel 82852/855GM Integrated Graphics Device X.Org 1.7.7 Res: 1280x768@60.0hz
           GLX Renderer Mesa DRI Intel 852GM/855GM GEM 20091221 2009Q4 x86/MMX/SSE2 GLX Version 1.3 Mesa 7.7.1 Direct Rendering Yes
Audio:     Card Intel 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller driver Intel ICH at ports 1c00 18c0 BusID: 00:1f.5
           Sound: Advanced Linux Sound Architecture Version 1.0.23
Network:   Card-1 Realtek RTL-8139/8139C/8139C+ driver 8139too v: 0.9.28 at port 3000 BusID: 02:00.0
           Card-2 Intel PRO/Wireless 2200BG [Calexico2] Network Connection driver ipw2200 v: 1.2.2kmprq BusID: 02:06.0
Disks:     HDD Total Size: 80.0GB (12.7% used) 1: /dev/sda ST9808210A 80.0GB
Partition: ID:/ size: 9.9G used: 5.8G (62%) fs: ext3 ID:/home size: 63G used: 3.8G (7%) fs: ext3
           ID:swap-1 size: 1.07GB used: 0.00GB (0%) fs: swap
Info:      Processes 123 Uptime 4 min Memory 120.5/469.1MB Runlevel 5 Client Shell inxi 1.4.14

Back to top
sedonix
Status: Contributor
Joined: 09 Sep 2008
Posts: 56
Location: Sedona, AZ
Reply Quote
Gentleman, I brought this problem to your attention in another thread a week ago and was ignored. You have no respect for your elders(:
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 746
Reply Quote
The DRM stack in Liquorix is the same code provided through the vanilla kernel. I tried long ago to backport DRM commits to the stable kernel... the result is a mess that's impossible to maintain. Thus, all my kernels now just use what's given upstream.

There must be some an incompatibility with the userspace you're providing the kernel to do its job drawing the mouse pointer.
Back to top
Display posts from previous:   

All times are GMT - 8 Hours