Blank tty terminals
sqlpython
Status: New User - Welcome
Joined: 30 Jul 2010
Posts: 3
Reply Quote
Config
Dell Inspiron 1501 amd64 notebook
AMD Athlon(tm) 64 X2 Dual-Core Processor
2 gb memory
Hardware Class: graphics card
Model: "ATI Radeon XPRESS 200M 5975 (PCIE)"
Vendor: pci 0x1002 "ATI Technologies Inc"
all amd64
2.6.34-52 liquorix-amd64
****************
......... When switching to a tty terminal via Ctrl-Alt-(F1 thru F6) from the KDE Desktop the tty terminal is Blank, no matter what tty terminal Number I choose.
Same results if I change to a tty via the konsole command chvt (n) n being 1-6.
..Always a Blank terminal..
......On the same machine the harddrive is partitioned and I have installed Mepis 8.5 and Kubuntu 9.10 along with the Debian Squeeze(liquorix Kernel)... The other Distros will change to a tty but occasionally the kubuntu 9.10 will lock when returning to the KDE Desktop and the Mepis 8.5 shows a bit of Screen Scamble which disappears when returning to the KDE Desktop.. but in both installs the ttys are accessible with MEPIS and Kubuntu.
Mepis is 2.6.31-1 amd64
Kubuntu is 2.6.31-22 amd64

... My video card runs the xorg-server-video-radeon 1:6.13.1-2 as there is not a specific driver for the ATI Radeon XPRESS 200M..
...Looking for a Work Around..
Thank You
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4033
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
radeon drivers have had this problem for years, I myself also noted the return of the dreaded blank vt issue on my radeon xorg driven ati 7500 laptop.

Basically the suckiness of the fglrx driver is found as well in the ati generated xorg code, ati, remember, donated the original radeon code, and currently funds the development of the radeon series of new xorg drivers, and of course writes the fglrx code.

However, I did note that the blanks screen issue was fixed for a while, but of course, regressed in recent xorg/kernel releases.
Back to top
sqlpython
Status: New User - Welcome
Joined: 30 Jul 2010
Posts: 3
Reply Quote
Thanks for the reply........
So, it appears the work around is don't use a KDE 4.xx with Debian. Use Lenny.......
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 914
Reply Quote
Join the #radeon channel on irc.freenode.net and try to get some help with your TTY switching. The developers on that channel are pretty helpful and surprisingly responsive.
Back to top
sqlpython
Status: New User - Welcome
Joined: 30 Jul 2010
Posts: 3
Reply Quote
Thanks for that lead.
I will try the channel and report back.
I did try to install a fglrx proprietary drive by compiling it to the headers. Also created a small xorg.conf... but it never worked correctly..
Back to top
Display posts from previous:   

All times are GMT - 8 Hours