Page: Previous  1, 2

Tomasu
Status: Interested
Joined: 23 May 2010
Posts: 10
Reply Quote
Not yet. I only reboot when I need to. I'll post again when I do.
Back to top
vrkalak
Status: New User - Welcome
Joined: 04 Aug 2010
Posts: 1
Location: Santa Fe, NM, US
Reply Quote
I just today, upgraded my Debian install from the 2.6.34 vanilla Kernel to the 2.6.35 Liquorix Kernel.

I generally don't shut-down or re-boot my PC. (except, for after the Kernel install)

So, I've booted once, with the new Liquorix 2.6.35 Kernel . . . I'll let you know how it goes. So far, no problems.
Back to top
Tomasu
Status: Interested
Joined: 23 May 2010
Posts: 10
Reply Quote
I've just booted into the latest 2.6.35 liquorix, it boots. But it seems to boot slower. kdm took longer to start, kde took WAY longer to start, and all the apps after took even longer..

Something is up with the disk/io settings in this kernel I think. it seems to be performing far worse than previous kernels.

Also it doesn't seem to want to use my wifi anymore:

ath5k 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
ath5k 0000:02:00.0: setting latency timer to 64
ath5k 0000:02:00.0: registered as 'phy0'
ath: EEPROM regdomain: 0x67
ath: EEPROM indicates we should expect a direct regpair map
ath: Country alpha2 being used: 00
ath: Regpair used: 0x67
ath5k phy0: can't register ieee80211 hw
ath5k 0000:02:00.0: PCI INT A disabled
ath5k: probe of 0000:02:00.0 failed with error -2

append: it seems wifi is broken with debian's 2.6.35-trunk as well at the moment. but peformance has improved. Its not as good as it could be, I hear .36 will have much improved writeback and whatnot.
Back to top
sedonix
Status: Contributor
Joined: 09 Sep 2008
Posts: 56
Location: Sedona, AZ
Reply Quote
Meant to post earlier. Given up using liquorix on my 32/386 laptop. These are absolute and follow the kernel each and every time. 2.6.34, eth0 does not exist, tries to rename in ascending order forever, wireless fine. 2.6.35, ghost cursor, invisible but there. Same sid on 64/AMD without these anomalies!
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 914
Reply Quote
:: Tomasu wrote ::
I've just booted into the latest 2.6.35 liquorix, it boots. But it seems to boot slower. kdm took longer to start, kde took WAY longer to start, and all the apps after took even longer..

Something is up with the disk/io settings in this kernel I think. it seems to be performing far worse than previous kernels.

Also it doesn't seem to want to use my wifi anymore:

ath5k 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
ath5k 0000:02:00.0: setting latency timer to 64
ath5k 0000:02:00.0: registered as 'phy0'
ath: EEPROM regdomain: 0x67
ath: EEPROM indicates we should expect a direct regpair map
ath: Country alpha2 being used: 00
ath: Regpair used: 0x67
ath5k phy0: can't register ieee80211 hw
ath5k 0000:02:00.0: PCI INT A disabled
ath5k: probe of 0000:02:00.0 failed with error -2

append: it seems wifi is broken with debian's 2.6.35-trunk as well at the moment. but peformance has improved. Its not as good as it could be, I hear .36 will have much improved writeback and whatnot.


Can you try two things for me? First, append elevator=cfq to your kernel boot line. Then two, blacklist ath5k and use ath_pci (madwifi) instead.

Let me know what results you get... I'm especially interested the cfq results - maybe bfq isn't necessary with all the recenty mm updates?
Back to top
Tomasu
Status: Interested
Joined: 23 May 2010
Posts: 10
Reply Quote
:: damentz wrote ::
:: Tomasu wrote ::
I've just booted into the latest 2.6.35 liquorix, it boots. But it seems to boot slower. kdm took longer to start, kde took WAY longer to start, and all the apps after took even longer..

Something is up with the disk/io settings in this kernel I think. it seems to be performing far worse than previous kernels.

Also it doesn't seem to want to use my wifi anymore:

ath5k 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
ath5k 0000:02:00.0: setting latency timer to 64
ath5k 0000:02:00.0: registered as 'phy0'
ath: EEPROM regdomain: 0x67
ath: EEPROM indicates we should expect a direct regpair map
ath: Country alpha2 being used: 00
ath: Regpair used: 0x67
ath5k phy0: can't register ieee80211 hw
ath5k 0000:02:00.0: PCI INT A disabled
ath5k: probe of 0000:02:00.0 failed with error -2

append: it seems wifi is broken with debian's 2.6.35-trunk as well at the moment. but peformance has improved. Its not as good as it could be, I hear .36 will have much improved writeback and whatnot.


Can you try two things for me? First, append elevator=cfq to your kernel boot line. Then two, blacklist ath5k and use ath_pci (madwifi) instead.

Let me know what results you get... I'm especially interested the cfq results - maybe bfq isn't necessary with all the recenty mm updates?


I can give that all a go. but the last time I tried madwifi, it just didn't work period (as you'll see I said earlier in this thread). Also my wifi works after I remove, and reinsert the module. It seems to be some odd 2.6.35 problem as I'm running the stock debian .35 kernel right now and I have to do the same thing.
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 914
Reply Quote
Were you able to test the CFQ boot parameter, Tomasu? I'm getting excellent results here with BFQ, so I need to know if CFQ really is the culprit or not.
Back to top
Tomasu
Status: Interested
Joined: 23 May 2010
Posts: 10
Reply Quote
:: damentz wrote ::
Were you able to test the CFQ boot parameter, Tomasu? I'm getting excellent results here with BFQ, so I need to know if CFQ really is the culprit or not.
elevator=cfq causes an oops on boot. I tried several times to capture the oops, but it always scrolled off screen, and I was un-able to scroll back to it, the machine hard locked.
Back to top
Display posts from previous:   
Page: Previous  1, 2
All times are GMT - 8 Hours