Page: Previous  1, 2

deach
Status: Contributor
Joined: 08 Sep 2008
Posts: 66
Reply Quote
:: Quote ::
:: Code ::
# update-alternatives --install /usr/bin/x-www-browser \     
> /usr/bin/firefox                                                           
update-alternatives: --install needs <link> <name> <path> <priority>         
Yielded that response........

:: Code ::
# update-alternatives --install /usr/bin/x-www-browser \
> /opt/firefox/firefox                                                 
update-alternatives: --install needs <link> <name> <path> <priority>   

Usage: update-alternatives [<option> ...] <command>


I tried both ways looks like I'm missing something......Any further help?? Thanks Craigevil.



Ok redid it adding the 100 priority after and still the same.......(missed that the first time)
:: Code ::
root@siduxbox:/home/kb9klc# update-alternatives --install /usr/bin/x-www-browser \                                                                       
> /opt/firefox/firefox 100                                                   
update-alternatives: --install needs <link> <name> <path> <priority>         

Usage: update-alternatives [<option> ...] <command>


I've tried both ways and it's still not coming up in the list. (meaning I used both "/opt/firefox/firefox/ and /usr/bin/firefox"
Both came out the same way.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4076
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
You forgot one of the arguments (note, www-browser is for console/terminal default browser, like links2):

:: Code ::
update-alternatives: --install needs <link> <name> <path> <priority>

<link> is the symlink pointing to /etc/alternatives/<name>.
  (e.g. /usr/bin/pager)
<name> is the master name for this link group.
  (e.g. pager)
<path> is the location of one of the alternative target files.
  (e.g. /usr/bin/less)
<priority> is an integer; options with higher numbers have higher priority in
  automatic mode.


:: Code ::
update-alternatives --install  /usr/bin/x-www-browser x-www-browser /opt/firefox/firefox 100
update-alternatives: using /opt/firefox/firefox to provide /usr/bin/x-www-browser (x-www-browser) in auto mode.

Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4076
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Also note that the icon file name changed from mozicon50.xpm to mozicon128.xpm in firefox 3.6, which makes the firefox.desktop require an update. I added all the information from this thread to the main thread re update-alternatives and the firefox.desktop thing.
Back to top
deach
Status: Contributor
Joined: 08 Sep 2008
Posts: 66
Reply Quote
:: Code ::
# update-alternatives --config x-www-browser
There are 4 choices for the alternative x-www-browser (providing /usr/bin/x-www-browser).

  Selection    Path                  Priority   Status
------------------------------------------------------------
* 0            /opt/firefox/firefox   100       auto mode
  1            /opt/firefox/firefox   100       manual mode
  2            /usr/bin/iceweasel     70        manual mode
  3            /usr/bin/konqueror     100       manual mode
  4            /usr/bin/opera         90        manual mode

Press enter to keep the current choice[*], or type selection number:


ok this is what I have now and although the pages appear to be *look??* ok now I am still getting that address in the address bar......
:: Code ::
file:///var/tmp/kdecache-kb9klc/krun/2664.0.82970607.html


The address should be
:: Code ::
http://www.katu.com/news/82970607.html


I just am not sure why it's loading from some type of KDE cache rather than going to the actual site. I have rechecked the instructions from the entire process and I believe I have it correctly. Again this happen when I'm in kopete chatting and click on a link someone sends me.......
Back to top
deach
Status: Contributor
Joined: 08 Sep 2008
Posts: 66
Reply Quote
EDIT: Ok got it working all now I think. I had to change in settings >file associations >applications> x-mimearchive from /opt/firefox/firefox to firefox %u" Actually I've changed them all to that for now in settings......I'll see how that goes. If you think this isn't the right thing to do, let me know or a different work around. Again Thanks Alot.




For the record it appears to be ok when running pidgin. I have the link working correctly in icedove so kopete would be the only thing.....I know that's kind of petty but........Any other ideas and thanks for all the help already I really appreciate it. I gotta be honest though so far other than that, it's working flawlessly.....Again THANKS!!
Back to top
Display posts from previous:   
Page: Previous  1, 2
All times are GMT - 8 Hours