Keys sticking -- seems to be an xorg problem
mdmarmer
Status: Interested
Joined: 21 Mar 2009
Posts: 21
Reply Quote
I am frequently seeing a problem with keys sticking. The key keeps repeating and the only fix I have found so far is to logout of X and back in again. This has occurred with liquorix and mepis kernels, in 2 different installs. It's a desktop with 9-pin (old style) keyboard. I've tried a different keyboard and have also cleaned the contacts. I googled this and found some folks suggest unplugging all usb devices or entering "xset r rate 1000 50" at the start of each session. I should also look in dmesg for the source of the bug -- haven't done this yet.

The problem just started recently and seems to occur mostly in xchat -- but maybe that's where I do a lot of typing.

Has anyone else experienced a similar problem or able to suggest a solution?

TIA.

Mike
Back to top
eriefisher
Status: Contributor
Joined: 21 Jun 2008
Posts: 59
Reply Quote
I have been seeing the same thing on my laptop for a while now with the same kernels you mention and a sidux kernel. For me the only out is a power button reboot.

I have yet to find a reason or a solution for this. The key seems random and may not occur for several weeks and then all of a sudden it will happen 3 or 4 times.????
Back to top
Change keyboard driver in xorg.conf
mdmarmer
Status: Interested
Joined: 21 Mar 2009
Posts: 21
Reply Quote
Change keyboard driver in xorg.conf from "keyboard" to "evdev"
That fixes it

Mike
Back to top
eriefisher
Status: Contributor
Joined: 21 Jun 2008
Posts: 59
Reply Quote
I have tried this solution but with evdev I get no keyboard at all in X. Is there something else that needs to be done as well?
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3912
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Try to simply replace your xorg.conf with a new one.

To do this, first: mv /etc/X11/xorg.conf /etc/X11/xorg.conf-full

then: X -configure
then: mv /root/xorg.conf-new /etc/X11/xorg.conf

then start x again.

See if that works.

Note that if you use nvidia drivers, you may need to add modelines with the nvidia-settings tool as well as of course redoing your xorg.conf with a sgfxi -c driver reinstall.
Back to top
eriefisher
Status: Contributor
Joined: 21 Jun 2008
Posts: 59
Reply Quote
Ok, after creating a new xorg.conf and starting X the touchpad was not detected. I could move the cursor but no tap or scroll. I check the new xorg.conf and there is no mention of the touchpad.

I added the section for the touchpad from the original xorg.conf to the new one but X would not start. I will have to do some digging on this one. Any suggestions?
Back to top
Display posts from previous:   

All times are GMT - 8 Hours