Page: 1, 2  Next

Installing fbsplash on a Liquorix kernel
Stian1979
Status: Interested
Joined: 12 Jul 2009
Posts: 19
Reply Quote
I have not ben able to make fbsplash work on debian befour, but it don't frighten me to try again, but using the liquorix kernel for this have not got me anywhere.
Where it stops for me is changing the config file.

I can not turn off Tile Blitting Support.
I'm quite lost here.
Back to top
eriefisher
Status: Contributor
Joined: 21 Jun 2008
Posts: 59
Reply Quote
Many of us using antiX run fbsplash. I run Liquorix kernels on my machine and I do see some bleed through but the splash does work.

some reading: antix.freeforums.org/antix-fbsplash-theme-t1448.html
Back to top
Stian1979
Status: Interested
Joined: 12 Jul 2009
Posts: 19
Reply Quote
Alot of other info that could helped me with the problems I had in the past, but nothing about how to turn off Tile Blitting Support.

Two options I can not find.
Support for the Framebuffer and Console Decorations
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 740
Reply Quote
:: Code ::
$ cat /boot/config-2.6.30-2.dmz.3-liquorix-amd64 | grep -i tileblit
CONFIG_FB_TILEBLITTING=y


You cannot find this option because it is enabled when certain other options are also enabled.

:: Code ::
  │ Symbol: FB_TILEBLITTING [=y]                                                                                                                                                 
  │ Prompt: Enable Tile Blitting Support                                                                                                                                           
  │   Defined at drivers/video/Kconfig:219                                                                                                                                       
  │   Depends on: HAS_IOMEM && FB                                                                                                                                                 
  │   Location:                                                                                                                                                                 
  │     -> Device Drivers                                                                                                                                                         
  │       -> Graphics support                                                                                                                                                     
  │         -> Support for frame buffer devices (FB [=y])                                                                                                                         
  │   Selected by: FB_S3 && HAS_IOMEM && FB && PCI || FB_VT8623 && HAS_IOMEM && FB && PCI || FB_ARK && HAS_IOMEM && FB && PCI

Back to top
Stian1979
Status: Interested
Joined: 12 Jul 2009
Posts: 19
Reply Quote
So how do I turn it off?
And how can I get those other options to show?

Here is the description about what has to be on and off.

:: Code ::
Device Drivers --> Graphics support --> Support for frame buffer devices [on]
Device Drivers --> Graphics support --> Support for frame buffer devices --> Enable Tile Blitting Support [must be off!]
Device Drivers --> Graphics support --> Support for frame buffer devices --> VESA VGA graphics support [on]
Device Drivers --> Graphics support --> Console display driver support --> Framebuffer Console support [on]
Device Drivers --> Graphics support --> Console display driver support --> Framebuffer Console support --> Support for the Framebuffer Console Decorations [on]


Edit:
Opened the config file in vim and comented out the Tile Blitting Suport Line by #space and removed the =y and addet is not set.
This did nothing since it's still enabled when I use menueconfig.

I'm stuck again as normal.
Is there no way to get it out?
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 740
Reply Quote
:: Quote ::
Selected by: FB_S3 && HAS_IOMEM && FB && PCI || FB_VT8623 && HAS_IOMEM && FB && PCI || FB_ARK && HAS_IOMEM && FB && PCI


Find FB_S3, FB_V8623, and FB_ARK and disable them. After that, hunt for tileblitting.
Back to top
Stian1979
Status: Interested
Joined: 12 Jul 2009
Posts: 19
Reply Quote
Thank you ohh mighty kernel master.
Until last night I thought it was you had done something to the kernel making me unable to configure this option, but started to think it was me bad when I could not do it to a kernel from kernel.org eather.

I will think about you when I boot my computer using this kernel.
I feel humble when I understand what I don't know.

Is it posible to get the post reamed to Stupid Stian's user error? :D
Back to top
Stian1979
Status: Interested
Joined: 12 Jul 2009
Posts: 19
Reply Quote
:: damentz wrote ::
:: Quote ::
Selected by: FB_S3 && HAS_IOMEM && FB && PCI || FB_VT8623 && HAS_IOMEM && FB && PCI || FB_ARK && HAS_IOMEM && FB && PCI


Find FB_S3, FB_V8623, and FB_ARK and disable them. After that, hunt for tileblitting.


Do you know how to build in the uvesafb driver? I seam to only be able to have it as module.
I got fbsplash working by the way, but it's not perfect.
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 740
Reply Quote
What if you load it as a static module? In debian, the file is /etc/modules.
Back to top
Stian1979
Status: Interested
Joined: 12 Jul 2009
Posts: 19
Reply Quote
:: damentz wrote ::
What if you load it as a static module? In debian, the file is /etc/modules.


I don't have any folder called modules, but ther is a text file containing
:: Code ::
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
# Parameters can be specified after the module name.

loop
sbp2


Should I add uvesafb as plain text in this file?
I asume it would be bether to have it buildt into the kernel, but that is maybe not posible?
Back to top
Display posts from previous:   
Page: 1, 2  Next
All times are GMT - 8 Hours