rtc: lost some interrupts at.. vmware linux
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4034
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
If you're getting this error type message:

:: Quote ::
Feb 21 03:02:08 wer kernel: rtc: lost some interrupts at 1024Hz.
Feb 21 03:02:49 wer last message repeated 9 times
Feb 21 03:02:55 wer kernel: psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
Feb 21 03:03:49 wer kernel: rtc: lost some interrupts at 1024Hz.
Feb 21 03:03:53 wer kernel: rtc: lost some interrupts at 1024Hz.
Feb 21 03:05:15 wer last message repeated 19 times
Feb 21 03:06:22 wer last message repeated 2 times


Then read this thread: communities.vmware.com/message/355598

And note this fix: kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1591

:: Quote ::
This problem occurs because current VMware for Linux products do not have complete support for host power management features (such as Intel SpeedStep, or AMD PowerNow or Cool'n'Quiet) that vary the processor speed. This article gives one workaround that prevents guest clocks from running quickly and another that periodically corrects the time when guest clocks run slowly. Alternatively, for more accurate time, you can lock the host processor to a constant speed; see knowledge base articles 708 and 916 at the links above.

To prevent guest clocks from running too quickly, specify the correct maximum host CPU speed in your global configuration file, /etc/vmware/config . If this file exists, edit it with a text editor, adding the lines described below. The file may not exist. If it does not exist, create it as a plain text file.

The example presented here assumes that the host computer has a maximum speed of 1700MHz. The first line is the most important one. It should be your host computer's maximum speed in kHz -- that is, its speed in MHz times 1000, or its speed in GHz times 1000000. To find your actual host's maximum CPU speed, run cat /proc/cpuinfo and look for the line cpu MHz, which is your host's maximum CPU speed. Add the following lines to your global configuration file:

host.cpukHz = 1700000
host.noTSC = TRUE
ptsc.noTSC = TRUE

To periodically correct the time (once per minute) when a guest clock runs slowly, VMware Tools must be installed in the guest. On the Options tab of VMware Tools in the guest, verify that Time synchronization between the virtual machine and the host operating system is selected.

Note: If the problem is still not corrected, this may be addressed by disabling power management altogether. This can be done by adding apm=off to the boot entry of the host's /etc/grub.conf file.

Note: If the problem is more widespread than just timekeeping and the virtual machine is simply running too slowly or quickly, and using apm=off is not sufficient, additionally add acpi=off noapic to the boot entry of the host's /etc/grub.conf file.

Back to top
Display posts from previous:   

All times are GMT - 8 Hours