Page: Previous  1, 2, 3

techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4018
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
As I've said, remove the kernel metapackages and select the option to use manual.

That's it. smxi detects metapackages and doesn't offer the kernel install.

I can't figure out the other stuff in your system, it seems like you're mixing stuff up or something, installing kernels that were already installed, etc.
Back to top
hoodwink
Status: Interested
Joined: 17 Sep 2008
Posts: 21
Location: Denver Area
Reply Quote
Just to reiterate, I've never tinkered with the smxi setup, but somewhere in the past it changed. The only change I've ever made since October last year is to add the aptitude option a few weeks ago. I probably should have raised a question a couple of months ago when the kernel handling changed when running smxi, but I figured that the change was something intentional by the author, namely you. Repeat.Repeat.Repeat. I've never installed ANY kernels other than via running smxi, and I've never selected any kernels in the section at the end of smxi where one can select a specific kernel other than the automatic choice (which is no longer a choice). Every third or forth time, I do run the kernel remover to clean up.

No back to the show. I don't see any thing related to kernel when doing a 'dpkg -l | grep meta'. How do I removed the "kernel meta packages", since nothing kernel-related show up as meta?

Also, here is the smxi.conf. Do I remove/alter anything here? Except for line 1, I've never messed with this file.
:: Code ::
apt-type=aptitude
busybox-fix-1
debian-mirrors-1
du-connection-drop-1
gpm-fix-1
kernel-directory-update-1
kernel-metapackage-1
keyrings-sidux-1
keyrings-update-4
libc6-fix-4
meta-package-selection=automatic
nvidia-sse-test-1
RememberResponses
script-last-du-complete=2008-11-01-13:46
script-last-used=2008-11-01-13:50
smxi-kernel-mirror-2

Back to top
hoodwink
Status: Interested
Joined: 17 Sep 2008
Posts: 21
Location: Denver Area
Reply Quote
OK, I just discovered in one of your earlier posts, that there is am smxi option to remove meta packages, so I'll try that.

Will choosing that option also fix op the smxi.conf?
Back to top
hoodwink
Status: Interested
Joined: 17 Sep 2008
Posts: 21
Location: Denver Area
Reply Quote
Well, it worked, and there was one adjustment to the xmxi.conf. Now the smxi behavior is what I remembered in the past, and there is no problem with linking the nvidia module.

I still don't know how I got into this situation, but now it's fixed. Thanks for your patience. I know more about kernel metapackages now than I ever wanted to, and I hope I never need to know this again.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 4018
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
well, you had some patience here too. But the problem remains, it looks to me like there is in fact some type of bug, but I'm not sure what.

The only thing I can figure is this: the new kernel installed via apt du and metapackages, then you didn't realize this had happened, and installed it again.

But that shouldn't have mattered, but maybe it did, I can't say.

Anyway, now you know why the first group of one time only things you see when you run smxi the first time includes the option to remove metapackages.
Back to top
Display posts from previous:   
Page: Previous  1, 2, 3
All times are GMT - 8 Hours