Page: Previous  1, 2, 3  Next

Chris M
Status: Interested
Joined: 11 Aug 2013
Posts: 39
Reply Quote
www.phoronix.com/scan.php?page=news_item&px=NVIDIA-352.41-Linux-Driver ...

https://devtalk.nvidia.com/default/topic/872100/unix-graphics-announcements-and-news/linux-solaris-and-freebsd-driver-352-41/

I'm still using the beta 355.06 driver, but obviously noticed the latest stable 352.41.

I'm interested in seeing if NVIDIA "fixed" the issue spoken to here, so I attempted to install 352.41.

I downloaded the latest smxi.zip today, and executed smxi, but the script still wants to install 352.30.

Not sure why: ftp://download.nvidia.com/XFree86/Linux-x86_64/latest.txt shows 352.41 352.41/NVIDIA-Linux-x86_64-352.41.run
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3764
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
there was/is a glitch in my scripting for updates, caused by the forced move from googlecode to somewhere else, github in this case.

I believe this is corrected now.

try: inxi -U then see what it offers to install, it should be the current driver again.

Note that you NEVER need to download and install the zip file of smxi after the initial install, smxi/sgfxi/svmi always update themselves every start.
Back to top
Chris M
Status: Interested
Joined: 11 Aug 2013
Posts: 39
Reply Quote
Yes, you got it with that update.

Still having the same problem with the updated stable driver, though. I'm having zero issues with the beta, so I'll stick with it, but no one has commented on the removal of the 3 lines from xorg.conf - assuming no news is good news.

Thanks
Back to top
Gene_Benson
Status: New User - Welcome
Joined: 29 Aug 2015
Posts: 3
Reply Quote
Like others here I was having trouble with the 352.30 driver. Xorg.0.log showed the following:
:: Code ::
[   119.438] (EE) NVIDIA: GPU:0: Failed to query OR info 0x1f.
[   119.472] (EE) NVIDIA(0): Failing initialization of X screen 0
[   119.472] (II) NVIDIA: Freed GPU:0 (GPU-dc232183-bab5-3ad2-2f36-843aae047b8d) @
[   119.472] (II) NVIDIA:     PCI:0000:03:00.0
[   119.659] (II) UnloadModule: "nvidia"
[   119.659] (II) UnloadSubModule: "wfb"
[   119.659] (II) UnloadSubModule: "fb"
[   119.660] (EE) Screen(s) found, but none have a usable configuration.
[   119.660] (EE)
Fatal server error:
[   119.660] (EE) no screens found(EE)

Got the same thing with 352.41. So this time I commented out the 3 lines mentioned on the previous page and reinstalled 352.41. Still no go. So I checked xorg.conf only to find that sgfxi had un-commented the lines back. So I commented them out again and now I could startx. I rebooted and everything was still working fine.
I did this on Debian (tracking testing), LMDE2, and Mint 17.2.
Hope this helps.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3764
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
it does help, that kind of testing and validation is important to decide on the xorg conf change that seems to be required, thanks

But let me rephrase that, what would really help is to add them back in, then comment each one out one at a time, try restarting x,, and see if there is only one of those lines, and which which one, that causes the problem.

This won't take long, just a few minutes test, and once I have that data I can update sgfxi to have that fix in it.
Back to top
Gene_Benson
Status: New User - Welcome
Joined: 29 Aug 2015
Posts: 3
Reply Quote
Testing done. It turns out the only option I need to comment out is:
:: Code ::
Option   "IgnoreDisplayDevices"   "TV"

Works fine after this.
Also found the following in Xorg.0.log:
:: Code ::
15.059] (WW) NVIDIA(0): Option "UseEvents" is not used

I'll just leave it as it is for now.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3764
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
great, thank you, I'll update sgfxi for those two lines.

I have to admit, ignoredisplaydevice would have been my last guess, heh.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3764
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
This seems basic enough, so I've updated sgfxi to not use those two lines in its xorg.conf update.

Let me know if you have further issues.
Back to top
Gene_Benson
Status: New User - Welcome
Joined: 29 Aug 2015
Posts: 3
Reply Quote
Tested this out on Debian. Booted into Debian. Edited xorg.conf and un-commented Option "IgnoreDisplayDevices" "TV"
Ran sgfxi and reinstalled 352.41. Went well and the desktop started just fine.

I had a look in xorg.conf and saw that the two options:
Option "IgnoreDisplayDevices" "TV"
Option "UseEvents" "true"
where no longer present. Nice job!! Thank you very much for fixing this.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3764
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
thank you for taking the time to test it, in general I don't like tossing changes into sgfxi until we can really see, as you did here, what is exactly needed.

The xorg.conf changes are updated now and then, but I have to be honesat and admit that I am shocked that nvidia would be so careless as to make IgnoreDisplay setting break xorg start. Unless it is xorg that breaks it.

The way legacy features should be handled is exactly what you showed in your xorg log output, nvidia notes that a feature that is no longer used was listed, and ignores it. I found it dismaying that nvidia/xorg would be this sloppy, it is very much unlike nvidia to be so careless.

I didn't initially remove all three because almost always when someone says remove 3 things, it means they didn't test the three one by one to make sure they were all to be removed, as you can see here, only two, but really only one, needs to be removed.

But I removed the events thing too in case it triggers a future issue.

The downside of this is of course for legacy drivers, and supporting those legacy systems, which is something I try to keep working in sgfxi, but honestly, how many people really use a tv for a display device in the first place?
Back to top
Display posts from previous:   
Page: Previous  1, 2, 3  Next
All times are GMT - 8 Hours