Installing 352.30 with sgfxi makes sddm fail (Debian teting / KDE Plasma 5)
shmerl
Status: Interested
Joined: 18 Apr 2012
Posts: 30
Reply Quote
I just updated the driver with sgfxi, and X doesn't load (my current display manager is sddm, used with KDE Plasma 5 in Debian testing). Is it a known issue? I couldn't find any sensible error messages in Xorg logs.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3753
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
run sgfxi --debugger

that will upload some debugging data that can show if it's a new feature or if it's something in your xorg.conf.

it might be a change, I can't say yet.
Back to top
shmerl
Status: Interested
Joined: 18 Apr 2012
Posts: 30
Reply Quote
I run it but obviously with the working version ;) I'll run it again with the broken configruation shortly.

UPDATE: I rerun it in the broken state. You can check the upload. (Delete the first report - it was wrong).
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3753
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
I want to see if this might be related, do this, before running sgfxi:

as root: sed -i 's/Card0/Device0/' /etc/X11/xorg.conf

If that works it means a bug report issue I got applies to not just lmde.

If this i is the case, that has to be one of the lamer mistakes nvidia driver has made re pointless changes that shouldn't exist because they are so trivial to not do in the first place. Or Xorg, I can't say which it is.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3753
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
this is confirmed, it makes me want to cry to be honest, well it would if I hadn't long since realized that asbergers dominates the software industry, free and non free, in one stroke nvidia breaks ALL existing xorg.conf for no point or reason at all.

Why is it so hard for these guys to do things like, oh, wait, yes, it was Card0, so let's keep supporting that, but change to Device0 as the default.

sgfxi now does this update just before updating xorg.conf, ie, changes CardX to DeviceX

so it should work now.

Usually nvidia isn't this dumb, but I guess you can't stop it slipping in whenever people get some great idea to 'fix' things that are not broken.
Back to top
shmerl
Status: Interested
Joined: 18 Apr 2012
Posts: 30
Reply Quote
I'll give it at try shortly.
Back to top
shmerl
Status: Interested
Joined: 18 Apr 2012
Posts: 30
Reply Quote
It still failed. I tried sed (replaced Card0 with Device0), and run sgfxi. I even deleted xorg.conf altogether and run sgfxi then. Same failure. I submitted a new debugger report.

So far I switched back to 352.21.
Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3753
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
As you can see, something went wrong with nvdia finding your screen.

I suggest going to:
https://devtalk.nvidia.com/default/board/98/

make sure to generate the bug report and upload it.

https://devtalk.nvidia.com/default/topic/522835/linux/if-you-have-a-problem-please-read-this-first/

I believe you had two issues, though I can't be certain.

Now you have one, I think.

:: Code ::
[ 66608.322] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[ 66608.322] (==) NVIDIA(0): RGB weight 888
[ 66608.322] (==) NVIDIA(0): Default visual is TrueColor
[ 66608.322] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 66608.322] (**) NVIDIA(0): Option "TripleBuffer" "true"
[ 66608.322] (**) NVIDIA(0): Option "IgnoreDisplayDevices" "TV"
[ 66608.322] (**) NVIDIA(0): Option "Coolbits" "8"
[ 66608.322] (**) NVIDIA(0): Enabling 2D acceleration
[ 66608.886] (II) NVIDIA: Allocated GPU:0 (GPU-bd0dd78a-1bd1-5445-c239-eac73662e070) @
[ 66608.886] (II) NVIDIA:     PCI:0000:01:00.0
[ 66608.895] (--) NVIDIA(0): Valid display device(s) on GPU-0 at PCI:1:0:0
[ 66608.895] (--) NVIDIA(0):     CRT-0
[ 66608.897] (--) NVIDIA(0): CRT-0: disconnected
[ 66608.897] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[ 66608.897] (--) NVIDIA(0):
[ 66608.897] (II) NVIDIA(GPU-0): Found DRM driver nvidia-drm (20150116)
[ 66608.898] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 680 (GK104) at PCI:1:0:0 (GPU-0)
[ 66608.898] (--) NVIDIA(0): Memory: 2097152 kBytes
[ 66608.898] (--) NVIDIA(0): VideoBIOS: 80.04.09.00.80
[ 66608.898] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 66608.903] (EE) NVIDIA: GPU:0: Failed to query OR info 0x1f.
[ 66608.928] (EE) NVIDIA(0): Failing initialization of X screen 0
[ 66608.928] (II) NVIDIA: Freed GPU:0 (GPU-bd0dd78a-1bd1-5445-c239-eac73662e070) @
[ 66608.928] (II) NVIDIA:     PCI:0000:01:00.0
[ 66610.193] (II) UnloadModule: "nvidia"
[ 66610.193] (II) UnloadSubModule: "wfb"
[ 66610.193] (II) UnloadSubModule: "fb"
[ 66610.193] (EE) Screen(s) found, but none have a usable configuration.
[ 66610.193] (EE)
Fatal server error:
[ 66610.193] (EE) no screens found(EE)

Back to top
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3753
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
There was another bug in sgfxi's attempt to fix the xorg.conf syntax.

So try it again, then post the sgfxi --debugger data and I'll see if it's all working.

I think your xorg.conf was right, but there was a bug in sgfxi as well, though only with the syntax correction.
Back to top
Display posts from previous:   

All times are GMT - 8 Hours