Kate 4.8 shows red or green border modifying lines
techAdmin
Status: Site Admin
Joined: 26 Sep 2003
Posts: 3749
Location: East Coast, West Coast? I know it's one of them.
Reply Quote
Well, here's a glitch: you upgraded to Kate 4.8. now suddenly when you type anything on any line, a red line appears (to indicate you have to save it), then when you save it, a green line appears. This is annoying to put it mildly.

You explore the settings trying to find a way to turn it off, but there is now way, finally google sends you to this page where you learn the following:

Close Kate, then copy this into a terminal and hit enter.
:: Code ::
kwriteconfig --file katerc --group "Kate View Defaults" --key "Line Modification" --type bool false


On the weird chance you might actually want to see that again (no idea why, it's super annoying):
:: Code ::
kwriteconfig --file katerc --group "Kate View Defaults" --key "Line Modification" --type bool true

sigh. All is not lost, Kate 4.9 will have a gui option to turn that off.

:: Quote ::
On KDE 4.8.0, there is no way to disable the line modification markers.
In KDE >= 4.8.1, you can disable them as follows by first closing Kate and then typing
....
In KDE >= 4.9, there is a graphical option in the editor configuration dialog in “Appearance > Borders > [x] Show line modification markers”.

Why add in a feature that you probably don't want without a gui method to turn it off? Kids.
Back to top
Display posts from previous:   

All times are GMT - 8 Hours