devianpctek
Status: New User - Welcome
Joined: 06 Feb 2012
Posts: 4
Back to top
Posted: Feb 6, 12, 13:17    [SOLVED] Error on Liquorix
Hi everyone, this is my first post here, I've been using Liquorix for quite some time and everything works perfect (running on Debian Sid), right now I'm running 3.2.0-2.dmz.1-liquorix-amd64, but yesterday when I tried to upgrade to 3.2.0-4.dmz.1-liquorix-amd64 I got an error
:: Code ::
The following partially installed packages will be configured:
  linux-image-3.2.0-4.dmz.1-liquorix-amd64 linux-image-liquorix-amd64
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
Setting up linux-image-3.2.0-4.dmz.1-liquorix-amd64 (3.2.0-8) ...
Running depmod.
vmlinuz(/boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64
) points to /boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64
(/boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64) -- doing nothing at /var/lib/dpkg/info/linux-image-3.2.0-4.dmz.1-liquorix-amd64.postinst line 346.
initrd.img(/boot/initrd.img-3.2.0-4.dmz.1-liquorix-amd64
) points to /boot/initrd.img-3.2.0-4.dmz.1-liquorix-amd64
(/boot/initrd.img-3.2.0-4.dmz.1-liquorix-amd64) -- doing nothing at /var/lib/dpkg/info/linux-image-3.2.0-4.dmz.1-liquorix-amd64.postinst line 346.                                                                                         
Examining /etc/kernel/postinst.d.                                                                                                                                                                                                           
run-parts: executing /etc/kernel/postinst.d/dkms 3.2.0-4.dmz.1-liquorix-amd64 /boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64                                                                                                                     
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-4.dmz.1-liquorix-amd64 /boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64                                                                                                         
update-initramfs: Generating /boot/initrd.img-3.2.0-4.dmz.1-liquorix-amd64                                                                                                                                                                   
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.2.0-4.dmz.1-liquorix-amd64 /boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64                                                                                                                 
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.2.0-4.dmz.1-liquorix-amd64 /boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64                                                                                                         
run-parts: executing /etc/kernel/postinst.d/zz-extlinux 3.2.0-4.dmz.1-liquorix-amd64 /boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64                                                                                                             
P: Checking for EXTLINUX directory... found.                                                                                                                                                                                                 
P: Writing config for /boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64...                                                                                                                                                                         
P: Writing config for /boot/vmlinuz-3.2.0-2.dmz.1-liquorix-amd64...                                                                                                                                                                         
P: Writing config for Windows 7 (loader) on /dev/sdb1...                                                                                                                                                                                     
E: /usr/share/syslinux/themes/debian/extlinux: No such file or directory                                                                                                                                                                     
run-parts: /etc/kernel/postinst.d/zz-extlinux exited with return code 1                                                                                                                                                                     
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.2.0-4.dmz.1-liquorix-amd64.postinst line 774.                                                                                                                   
dpkg: error processing linux-image-3.2.0-4.dmz.1-liquorix-amd64 (--configure):                                                                                                                                                               
subprocess installed post-installation script returned error exit status 1                                                                                                                                                                 
configured to not write apport reports                                                                                                                                                                                                       
                                      dpkg: dependency problems prevent configuration of linux-image-liquorix-amd64:                                                                                                                         
linux-image-liquorix-amd64 depends on linux-image-3.2.0-4.dmz.1-liquorix-amd64 (= 3.2.0-8); however:                                                                                                                                       
  Package linux-image-3.2.0-4.dmz.1-liquorix-amd64 is not configured yet.                                                                                                                                                                   
dpkg: error processing linux-image-liquorix-amd64 (--configure):                                                                                                                                                                             
dependency problems - leaving unconfigured                                                                                                                                                                                                 
configured to not write apport reports                                                                                                                                                                                                       
                                      Errors were encountered while processing:                                                                                                                                                             
linux-image-3.2.0-4.dmz.1-liquorix-amd64                                                                                                                                                                                                   
linux-image-liquorix-amd64                                                                                                                                                                                                                 
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:                                                                                                                                                                                             
Setting up linux-image-3.2.0-4.dmz.1-liquorix-amd64 (3.2.0-8) ...
Running depmod.
vmlinuz(/boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64
) points to /boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64
(/boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64) -- doing nothing at /var/lib/dpkg/info/linux-image-3.2.0-4.dmz.1-liquorix-amd64.postinst line 346.
initrd.img(/boot/initrd.img-3.2.0-4.dmz.1-liquorix-amd64
) points to /boot/initrd.img-3.2.0-4.dmz.1-liquorix-amd64
(/boot/initrd.img-3.2.0-4.dmz.1-liquorix-amd64) -- doing nothing at /var/lib/dpkg/info/linux-image-3.2.0-4.dmz.1-liquorix-amd64.postinst line 346.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 3.2.0-4.dmz.1-liquorix-amd64 /boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-4.dmz.1-liquorix-amd64 /boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64
update-initramfs: Generating /boot/initrd.img-3.2.0-4.dmz.1-liquorix-amd64
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.2.0-4.dmz.1-liquorix-amd64 /boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.2.0-4.dmz.1-liquorix-amd64 /boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64
run-parts: executing /etc/kernel/postinst.d/zz-extlinux 3.2.0-4.dmz.1-liquorix-amd64 /boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64
P: Checking for EXTLINUX directory... found.
P: Writing config for /boot/vmlinuz-3.2.0-4.dmz.1-liquorix-amd64...
P: Writing config for /boot/vmlinuz-3.2.0-2.dmz.1-liquorix-amd64...
P: Writing config for Windows 7 (loader) on /dev/sdb1...
E: /usr/share/syslinux/themes/debian/extlinux: No such file or directory
run-parts: /etc/kernel/postinst.d/zz-extlinux exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.2.0-4.dmz.1-liquorix-amd64.postinst line 774.
dpkg: error processing linux-image-3.2.0-4.dmz.1-liquorix-amd64 (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of linux-image-liquorix-amd64:
linux-image-liquorix-amd64 depends on linux-image-3.2.0-4.dmz.1-liquorix-amd64 (= 3.2.0-8); however:
  Package linux-image-3.2.0-4.dmz.1-liquorix-amd64 is not configured yet.
dpkg: error processing linux-image-liquorix-amd64 (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
linux-image-3.2.0-4.dmz.1-liquorix-amd64
linux-image-liquorix-amd64


I tried to modify /var/lib/dpkg/status and change the status to "Installed" and tried to remove the package but I also get an error
:: Code ::
    Package: linux-image-3.2.0-4.dmz.1-liquorix-amd64
    Status: install ok half-configured
    Priority: optional
    Section: kernel
    Installed-Size: 132667
    Maintainer: Steven Barrett <damentz@liquorix.net>
    Architecture: amd64
    Source: linux-liquorix
    Version: 3.2.0-8
    Provides: linux-image, linux-modules-3.2.0-4.dmz.1-liquorix-amd64
    Depends: module-init-tools, initramfs-tools | linux-initramfs-tool
    Pre-Depends: debconf | debconf-2.0
    Recommends: firmware-linux-free (>= 3~)
    Suggests: linux-doc-3.2.0, grub2 | grub-gfxboot | grub-legacy, crda
    Description: Linux 3.2.0 for 64-bit PCs
    The Linux kernel 3.2.0 and modules for use on PCs with AMD64 or Intel 64
    processors.
    Homepage: http://kernel.org/

Has anyone have this same problem? what can I do to get this fixed?
Thank you in advance

< Edited by devianpctek :: Feb 11, 12, 22:54 >
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 514
Back to top
Posted: Feb 6, 12, 15:26    
Looks like you have a grub theme package interfering with kernel installation. Or at least, the configuration of that package contradicts what is actually laid out on the filesystem.

Did you upgrade any syslinux, grub, or gfxboot packages in the last week?
devianpctek
Status: New User - Welcome
Joined: 06 Feb 2012
Posts: 4
Back to top
Posted: Feb 6, 12, 16:03    
:: damentz wrote ::
Looks like you have a grub theme package interfering with kernel installation. Or at least, the configuration of that package contradicts what is actually laid out on the filesystem.

Did you upgrade any syslinux, grub, or gfxboot packages in the last week?


Hey thanx for answering damentz, hmm not that I can remember, oh wait I removed those entries about memtest86 on grub, I don't know if that has something to do with it, but now that you mentioned I think (I'm not sure) that when I uninstalled those there was something saying about removing a grub theme or something
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 514
Back to top
Posted: Feb 6, 12, 16:05    
What does dpkg -S /etc/kernel/postinst.d/zz-extlinux output?
devianpctek
Status: New User - Welcome
Joined: 06 Feb 2012
Posts: 4
Back to top
Posted: Feb 6, 12, 16:19    
dpkg -S /etc/kernel/postinst.d/zz-extlinux
:: Code ::

extlinux: /etc/kernel/postinst.d/zz-extlinux
devianpctek
Status: New User - Welcome
Joined: 06 Feb 2012
Posts: 4
Back to top
Posted: Feb 6, 12, 16:55    
Hey I got it fixed, I didn't noticed the error until you pointed out :D

:: Code ::
E: /usr/share/syslinux/themes/debian/extlinux: No such file or directory


So I have to install syslinux-themes-debian, I still don't remember how I got that removed, anyway is working now, and no error messages :D

I wanted to make sure what got that package removed so right now I tried
aptitude remove memtest86 memtest86+
:: Code ::

The following packages will be REMOVED: 
  memtest86{p} memtest86+{p}
0 packages upgraded, 0 newly installed, 2 to remove and 19 not upgraded.
Need to get 0 B of archives. After unpacking 2,666 kB will be freed.
The following packages have unmet dependencies:
  syslinux-themes-debian-squeeze: Depends: memtest86+ but it is not going to be installed.
The following actions will resolve these dependencies:

     Remove the following packages:             
1)     syslinux-themes-debian                   
2)     syslinux-themes-debian-squeeze           

     Leave the following dependencies unresolved:
3)     extlinux recommends syslinux-themes-debian

So now I know why I got the error
Display posts from previous:   

All times are GMT - 8 Hours