Sound problem with latest liquorix 2.6.37 kernels
kukaraja
Status: Curious
Joined: 23 Jan 2011
Posts: 9
Reply Quote
Hi, I have Dell XPS M1530 laptop with Linux Mint 10 installed. Since the liquorix 2.6.37 update, my microphone stoped working. The mic was ok with liquorix 2.6.36 kernels.

Here is my alsa configuration: www.alsa-project.org/db/?f=deb126d4779e20feb3fafda6742003a4881b7856


Can you help me to restore input sound from mic?
Back to top
Sound problem with latest liquorix 2.6.37 kernels
Jos.v.W.
Status: Contributor
Joined: 25 Jan 2011
Posts: 57
Reply Quote
I have the same issue with my Acer Travelmate 4530 AMD QL-64 using Debian/Sid and kernel 2.6.37: no microphone sound input.
Mic working well with liquorix 2.6.36 and previous kernels.
Back to top
Jos.v.W.
Status: Contributor
Joined: 25 Jan 2011
Posts: 57
Reply Quote
After upgrading to kernel 2.6.37-0.dmz.6 both the external and internal microphones are again working (tested with audacity)
Back to top
kukaraja
Status: Curious
Joined: 23 Jan 2011
Posts: 9
Reply Quote
Mic still doesn't work after upgrade to 2.6.37-6
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 641
Reply Quote
Kukaraja, this is probably a bug in the upstream linux kernel. Google for bug reports that share your device ids with 2.6.37. You can collect the information you need with this script: www.alsa-project.org/alsa-info.sh
Back to top
kukaraja
Status: Curious
Joined: 23 Jan 2011
Posts: 9
Reply Quote
Damentz, thanks for the tip.

I found a solution. It's a pulseaudio bug: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/680810

There is a workaround for the problem by modifying /usr/share/pulseaudio/alsa-mixer/paths/analog-input.conf.common,
adding this section (reboot or restart pulseaudio to test):

[Option Input Source:Internal Mic 1]
name = input-microphone
priority = 19
Back to top
Display posts from previous:   

All times are GMT - 8 Hours