kukaraja
Status: Curious
Joined: 23 Jan 2011
Posts: 9
Back to top
Posted: Jan 23, 11, 2:49    Sound problem with latest liquorix 2.6.37 kernels
Hi, I have Dell XPS M1530 laptop with Linux Mint 10 installed. Since the liquorix 2.6.37 update, my microphone stoped working. The mic was ok with liquorix 2.6.36 kernels.

Here is my alsa configuration: www.alsa-project.org/db/?f=deb126d4779e20feb3fafda6742003a4881b7856


Can you help me to restore input sound from mic?
Jos.v.W.
Status: Interested
Joined: 25 Jan 2011
Posts: 41
Back to top
Posted: Jan 25, 11, 5:57    Sound problem with latest liquorix 2.6.37 kernels
I have the same issue with my Acer Travelmate 4530 AMD QL-64 using Debian/Sid and kernel 2.6.37: no microphone sound input.
Mic working well with liquorix 2.6.36 and previous kernels.
Jos.v.W.
Status: Interested
Joined: 25 Jan 2011
Posts: 41
Back to top
Posted: Jan 26, 11, 22:22    
After upgrading to kernel 2.6.37-0.dmz.6 both the external and internal microphones are again working (tested with audacity)
kukaraja
Status: Curious
Joined: 23 Jan 2011
Posts: 9
Back to top
Posted: Jan 27, 11, 6:58    
Mic still doesn't work after upgrade to 2.6.37-6
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 517
Back to top
Posted: Jan 27, 11, 16:44    
Kukaraja, this is probably a bug in the upstream linux kernel. Google for bug reports that share your device ids with 2.6.37. You can collect the information you need with this script: www.alsa-project.org/alsa-info.sh
kukaraja
Status: Curious
Joined: 23 Jan 2011
Posts: 9
Back to top
Posted: Jan 29, 11, 7:48    
Damentz, thanks for the tip.

I found a solution. It's a pulseaudio bug: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/680810

There is a workaround for the problem by modifying /usr/share/pulseaudio/alsa-mixer/paths/analog-input.conf.common,
adding this section (reboot or restart pulseaudio to test):

[Option Input Source:Internal Mic 1]
name = input-microphone
priority = 19
Display posts from previous:   

All times are GMT - 8 Hours