For those who have some ACPI glitches with newest kernels
DeepDayze
Status: Contributor
Joined: 21 May 2009
Posts: 102
Reply Quote
Here's a tip I got from user towo| on sidux forum to help resolve some ACPI issues that arise from using the newest Linux kernels.

Try the following:

add the following to /boot/grub/menu.lst:

:: Code ::
# defoptions=vga=791 acpi_enforce_resources=lax


After the change, do:

:: Code ::
update-grub


For me, the message is gone, also sensors are working again.

After following these tips, this works for me as well.

The full thread is here:
sidux.com/PNphpBB2-viewtopic-t-17950.html
Back to top
damentz
Status: Assistant
Joined: 09 Sep 2008
Posts: 679
Reply Quote
This is the same as disabling hotplug in Xorg, not a solution but a workaround that isn't maintainable. Not to mention, this is dangerous to enable and these resource checks were implemented to increase stability and identify problem modules negatively affecting thermal management.

Conflicts appear because another module is trying to access the same resources as another driver to read temperature, fan, and other data. Most likely ACPI has all the data you need and you don't need to load the previous deprecated module.

Read about the recent solution here -> techpatterns.com/forums/about1410.html
Back to top
Display posts from previous:   

All times are GMT - 8 Hours